fix build with json-c-0.12
This commit is contained in:
parent
8b4cac4bf2
commit
2078206f10
34
0001-json-include-json.h-accordingly-to-json-c-CFLAGS.patch
Normal file
34
0001-json-include-json.h-accordingly-to-json-c-CFLAGS.patch
Normal file
@ -0,0 +1,34 @@
|
||||
From 1cef1ddc28f327534cfdb433d1f2e10d01b10f44 Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Filak <jfilak@redhat.com>
|
||||
Date: Thu, 24 Jul 2014 16:07:36 +0200
|
||||
Subject: [PATCH] json: include json.h accordingly to json-c CFLAGS
|
||||
|
||||
We use $(pkg-config --cflags json-c) but we include <json/json.h>. The
|
||||
proper way to include the json-c header is to include <json.h>.
|
||||
|
||||
That absolute include causes errors while compiling with json-c-0.12
|
||||
where the base include directory was changed to "json-c".
|
||||
|
||||
https://github.com/json-c/json-c/blob/master/ChangeLog
|
||||
|
||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
||||
---
|
||||
src/lib/json.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/lib/json.c b/src/lib/json.c
|
||||
index 08ffe8c..fc26bc6 100644
|
||||
--- a/src/lib/json.c
|
||||
+++ b/src/lib/json.c
|
||||
@@ -17,7 +17,7 @@
|
||||
51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
|
||||
*/
|
||||
|
||||
-#include <json/json.h>
|
||||
+#include <json.h>
|
||||
|
||||
#include <satyr/abrt.h>
|
||||
#include <satyr/report.h>
|
||||
--
|
||||
1.9.3
|
||||
|
@ -0,0 +1,45 @@
|
||||
From cc36c5c2b109fa7ac864400e695c88808b19a5ed Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Filak <jfilak@redhat.com>
|
||||
Date: Fri, 25 Jul 2014 12:39:28 +0200
|
||||
Subject: [PATCH] ureport: include json.h accordingly to json-c CFLAGS
|
||||
|
||||
commit 1cef1ddc28f327534cfdb433d1f2e10d01b10f44
|
||||
|
||||
Signed-off-by: Jakub Filak <jfilak@redhat.com>
|
||||
---
|
||||
src/plugins/Makefile.am | 2 ++
|
||||
src/plugins/ureport.c | 2 +-
|
||||
2 files changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/plugins/Makefile.am b/src/plugins/Makefile.am
|
||||
index 2d95f07..7e0e753 100644
|
||||
--- a/src/plugins/Makefile.am
|
||||
+++ b/src/plugins/Makefile.am
|
||||
@@ -260,9 +260,11 @@ reporter_ureport_CPPFLAGS = \
|
||||
-I$(srcdir)/../lib \
|
||||
$(GLIB_CFLAGS) \
|
||||
$(LIBREPORT_CFLAGS) \
|
||||
+ $(JSON_C_CFLAGS) \
|
||||
-DPLUGINS_CONF_DIR=\"$(REPORT_PLUGINS_CONF_DIR)\" \
|
||||
-D_GNU_SOURCE
|
||||
reporter_ureport_LDADD = \
|
||||
+ $(JSON_C_LIBS) \
|
||||
../lib/libreport.la \
|
||||
../lib/libreport-web.la
|
||||
endif
|
||||
diff --git a/src/plugins/ureport.c b/src/plugins/ureport.c
|
||||
index e6237cc..063a1e7 100644
|
||||
--- a/src/plugins/ureport.c
|
||||
+++ b/src/plugins/ureport.c
|
||||
@@ -17,7 +17,7 @@
|
||||
51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
|
||||
*/
|
||||
|
||||
-#include <json/json.h>
|
||||
+#include <json.h>
|
||||
#include "internal_libreport.h"
|
||||
#include "ureport.h"
|
||||
#include "libreport_curl.h"
|
||||
--
|
||||
1.9.3
|
||||
|
@ -7,7 +7,7 @@
|
||||
Summary: Generic library for reporting various problems
|
||||
Name: libreport
|
||||
Version: 2.2.3
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Libraries
|
||||
URL: https://fedorahosted.org/abrt/
|
||||
@ -22,6 +22,8 @@ Patch5: 0005-wizard-fix-help-text-for-screencasting.patch
|
||||
Patch6: 0006-gui-support-Enter-2Click-in-Preferences-list.patch
|
||||
Patch7: 0007-gui-apply-configuration-dialogues-changes-on-Enter-k.patch
|
||||
Patch8: 0008-gui-close-ask-dialogues-on-Enter-key.patch
|
||||
Patch9: 0001-json-include-json.h-accordingly-to-json-c-CFLAGS.patch
|
||||
Patch10: 0001-ureport-include-json.h-accordingly-to-json-c-CFLAGS.patch
|
||||
|
||||
# git is need for '%%autosetup -S git' which automatically applies all the
|
||||
# patches above. Please, be aware that the patches must be generated
|
||||
@ -660,6 +662,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jul 25 2014 Jakub Filak <jfilak@redhat.com> 2.2.3-3
|
||||
- fix build with json-c-0.12
|
||||
|
||||
* Wed Jul 23 2014 Jakub Filak <jfilak@redhat.com> 2.2.3-2
|
||||
- reporter-ureport: attach anonymous comment
|
||||
- gui: close dialogues on Enter key
|
||||
|
Loading…
Reference in New Issue
Block a user