Bump to 1.7.16
This commit is contained in:
parent
48dd703f51
commit
d7dc275bdf
1
.gitignore
vendored
1
.gitignore
vendored
@ -35,3 +35,4 @@
|
||||
/librepo-8f931e8.tar.xz
|
||||
/librepo-d970c44.tar.xz
|
||||
/librepo-6f8e5b0.tar.xz
|
||||
/librepo-d9bed0d.tar.xz
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff -up librepo/tests/test_repoconf.c.repoconf-assert librepo/tests/test_repoconf.c
|
||||
--- librepo/tests/test_repoconf.c.repoconf-assert 2015-05-27 15:23:29.000000000 +0200
|
||||
+++ librepo/tests/test_repoconf.c 2015-05-27 15:26:35.000000000 +0200
|
||||
@@ -49,9 +49,9 @@ static void
|
||||
repoconf_assert_na(LrYumRepoConf *repoconf,
|
||||
LrYumRepoConfOption option)
|
||||
{
|
||||
- void *ptr = NULL;
|
||||
+ char array[2048];
|
||||
_cleanup_error_free_ GError *tmp_err = NULL;
|
||||
- gboolean ret = lr_yum_repoconf_getinfo(repoconf, &tmp_err, option, &ptr);
|
||||
+ gboolean ret = lr_yum_repoconf_getinfo(repoconf, &tmp_err, option, array);
|
||||
g_assert(!ret);
|
||||
g_assert_error(tmp_err, LR_REPOCONF_ERROR, LRE_NOTSET);
|
||||
}
|
22
librepo.spec
22
librepo.spec
@ -1,4 +1,4 @@
|
||||
%global gitrev 6f8e5b0
|
||||
%global gitrev d9bed0d
|
||||
# gitrev is output of: git rev-parse --short HEAD
|
||||
|
||||
%if 0%{?rhel} != 0 && 0%{?rhel} <= 7
|
||||
@ -12,8 +12,8 @@
|
||||
%endif
|
||||
|
||||
Name: librepo
|
||||
Version: 1.7.15
|
||||
Release: 3%{?dist}
|
||||
Version: 1.7.16
|
||||
Release: 1%{?dist}
|
||||
Summary: Repodata downloading library
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -24,8 +24,6 @@ URL: https://github.com/Tojaj/librepo
|
||||
# cd librepo
|
||||
# utils/make_tarball.sh %{gitrev}
|
||||
Source0: librepo-%{gitrev}.tar.xz
|
||||
# https://github.com/Tojaj/librepo/commit/7f684757ba803641defad6c3cf5e2044912620cd
|
||||
Patch0: librepo-1.7.15-repoconf-assert.patch
|
||||
|
||||
BuildRequires: check-devel
|
||||
BuildRequires: cmake
|
||||
@ -90,7 +88,6 @@ Python 3 bindings for the librepo library.
|
||||
|
||||
%prep
|
||||
%setup -q -n librepo
|
||||
%patch0 -p1 -b .repoconf-assert
|
||||
|
||||
%if %{with python3}
|
||||
rm -rf py3
|
||||
@ -151,8 +148,17 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed May 27 2015 Dan Horák <dan[at]danny.cz> - 1.7.15-3
|
||||
- fix segfault in repoconf_assert_na (RhBug: 1222471)
|
||||
* Fri May 29 2015 Colin Walters <tmlcoch@redhat.com> - 1.7.16-1
|
||||
- Add LRI_LOWSPEEDTIME and LRI_LOWSPEEDLIMIT
|
||||
- downloader: Don't consider CURLE_RECV_ERROR and CURLE_SEND_ERROR as fatal errors (RhBug: 1219817)
|
||||
- test_repoconf: Fix SIGSEGV in repoconf_assert_na (RhBug: 1222471)
|
||||
- repoconf: Proper handling of gint64 and guint64 types
|
||||
- build: Be compatible with cmake 2.8
|
||||
- handle: Do not free temporary error msg if there is no one (RhBug: 1219822)
|
||||
- utils/make_rpm.sh: Accept rpmbuild options as second argument (Issue #49)
|
||||
- Python: call lr_global_init() during module initialization
|
||||
- Add global function log_set_file that allow user to set a file where logs will be written (Issue #53)
|
||||
- util: Honor RFC 3986 (Issue #55)
|
||||
|
||||
* Tue May 12 2015 Colin Walters <walters@redhat.com> - 1.7.15-2
|
||||
- Disable tests and drop python-flask build dependency on RHEL7, as
|
||||
|
Loading…
Reference in New Issue
Block a user