Update to 1.10.5
This commit is contained in:
parent
d916149dad
commit
b7f1e556e7
1
.gitignore
vendored
1
.gitignore
vendored
@ -50,3 +50,4 @@
|
||||
/librepo-1.9.5.tar.gz
|
||||
/librepo-1.9.6.tar.gz
|
||||
/librepo-1.10.2.tar.gz
|
||||
/librepo-1.10.5.tar.gz
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 42ab00919b7415ce92ab33388398e97609805021 Mon Sep 17 00:00:00 2001
|
||||
From: Jonathan Dieter <jdieter@gmail.com>
|
||||
Date: Thu, 16 May 2019 20:43:37 +0100
|
||||
Subject: [PATCH] Make sure to check next transfer if current zck transfer
|
||||
already exists
|
||||
|
||||
Signed-off-by: Jonathan Dieter <jdieter@gmail.com>
|
||||
---
|
||||
librepo/downloader.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/librepo/downloader.c b/librepo/downloader.c
|
||||
index ad778d3..6189681 100644
|
||||
--- a/librepo/downloader.c
|
||||
+++ b/librepo/downloader.c
|
||||
@@ -1450,7 +1450,7 @@ prepare_next_transfer(LrDownload *dd, gboolean *candidatefound, GError **err)
|
||||
goto fail;
|
||||
}
|
||||
|
||||
- // If zchunk is finished, we're done
|
||||
+ // If zchunk is finished, we're done, so move to next target
|
||||
if(target->zck_state == LR_ZCK_DL_FINISHED) {
|
||||
g_debug("%s: Target already fully downloaded: %s", __func__, target->target->path);
|
||||
target->state = LR_DS_FINISHED;
|
||||
@@ -1461,7 +1461,7 @@ prepare_next_transfer(LrDownload *dd, gboolean *candidatefound, GError **err)
|
||||
fclose(target->f);
|
||||
target->f = NULL;
|
||||
lr_downloadtarget_set_error(target->target, LRE_OK, NULL);
|
||||
- return TRUE;
|
||||
+ return prepare_next_transfer(dd, candidatefound, err);
|
||||
}
|
||||
}
|
||||
# endif /* WITH_ZCHUNK */
|
||||
--
|
||||
2.21.0
|
||||
|
13
librepo.spec
13
librepo.spec
@ -26,14 +26,13 @@
|
||||
%global dnf_conflict 2.8.8
|
||||
|
||||
Name: librepo
|
||||
Version: 1.10.2
|
||||
Release: 3%{?dist}
|
||||
Version: 1.10.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Repodata downloading library
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/rpm-software-management/librepo
|
||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0: 0001-Make-sure-to-check-next-transfer-if-current-zck-tran.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc
|
||||
@ -190,6 +189,14 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jul 29 2019 Pavla Kratochvilova <pkratoch@redhat.com> - 1.10.5-1
|
||||
- Update to 1.10.5
|
||||
- Exit gpg-agent after repokey import (RhBug:1650266)
|
||||
- Handle webservers that don't support ranges when downloading zck
|
||||
- Define LRO_SUPPORTS_CACHEDIR only with zchunk (RhBug:1726141)
|
||||
- Allow to use mirrors multiple times for a target (RhBug:1678588)
|
||||
- Allow to try baseurl multiple times (RhBug:1678588)
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (librepo-1.10.2.tar.gz) = a8b0dff4bb82890aa63006f1ba4216765cb8e59e8d994d285977bc8a8f5f71f6baf1d3070944c92848821a19182046d108837148863d898b603441ae773b703b
|
||||
SHA512 (librepo-1.10.5.tar.gz) = 95e8bafa0eb34faf22ad033cc96fe6008d318717f8b8011ce7d62a68ad3c42db40d8ed9d58a6b47935e2bfd3019b2678d442949511966fe885c8742dedd62f5b
|
||||
|
Loading…
Reference in New Issue
Block a user