- fix segfault in repoconf_assert_na (RhBug: 1222471)
This commit is contained in:
parent
000d698a75
commit
48dd703f51
15
librepo-1.7.15-repoconf-assert.patch
Normal file
15
librepo-1.7.15-repoconf-assert.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff -up librepo/tests/test_repoconf.c.repoconf-assert librepo/tests/test_repoconf.c
|
||||||
|
--- librepo/tests/test_repoconf.c.repoconf-assert 2015-05-27 15:23:29.000000000 +0200
|
||||||
|
+++ librepo/tests/test_repoconf.c 2015-05-27 15:26:35.000000000 +0200
|
||||||
|
@@ -49,9 +49,9 @@ static void
|
||||||
|
repoconf_assert_na(LrYumRepoConf *repoconf,
|
||||||
|
LrYumRepoConfOption option)
|
||||||
|
{
|
||||||
|
- void *ptr = NULL;
|
||||||
|
+ char array[2048];
|
||||||
|
_cleanup_error_free_ GError *tmp_err = NULL;
|
||||||
|
- gboolean ret = lr_yum_repoconf_getinfo(repoconf, &tmp_err, option, &ptr);
|
||||||
|
+ gboolean ret = lr_yum_repoconf_getinfo(repoconf, &tmp_err, option, array);
|
||||||
|
g_assert(!ret);
|
||||||
|
g_assert_error(tmp_err, LR_REPOCONF_ERROR, LRE_NOTSET);
|
||||||
|
}
|
10
librepo.spec
10
librepo.spec
@ -13,7 +13,7 @@
|
|||||||
|
|
||||||
Name: librepo
|
Name: librepo
|
||||||
Version: 1.7.15
|
Version: 1.7.15
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Repodata downloading library
|
Summary: Repodata downloading library
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -24,6 +24,8 @@ URL: https://github.com/Tojaj/librepo
|
|||||||
# cd librepo
|
# cd librepo
|
||||||
# utils/make_tarball.sh %{gitrev}
|
# utils/make_tarball.sh %{gitrev}
|
||||||
Source0: librepo-%{gitrev}.tar.xz
|
Source0: librepo-%{gitrev}.tar.xz
|
||||||
|
# https://github.com/Tojaj/librepo/commit/7f684757ba803641defad6c3cf5e2044912620cd
|
||||||
|
Patch0: librepo-1.7.15-repoconf-assert.patch
|
||||||
|
|
||||||
BuildRequires: check-devel
|
BuildRequires: check-devel
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
@ -88,6 +90,7 @@ Python 3 bindings for the librepo library.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n librepo
|
%setup -q -n librepo
|
||||||
|
%patch0 -p1 -b .repoconf-assert
|
||||||
|
|
||||||
%if %{with python3}
|
%if %{with python3}
|
||||||
rm -rf py3
|
rm -rf py3
|
||||||
@ -148,7 +151,10 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Jun 12 2015 Colin Walters <walters@redhat.com> - 1.7.15-2
|
* Wed May 27 2015 Dan Horák <dan[at]danny.cz> - 1.7.15-3
|
||||||
|
- fix segfault in repoconf_assert_na (RhBug: 1222471)
|
||||||
|
|
||||||
|
* Tue May 12 2015 Colin Walters <walters@redhat.com> - 1.7.15-2
|
||||||
- Disable tests and drop python-flask build dependency on RHEL7, as
|
- Disable tests and drop python-flask build dependency on RHEL7, as
|
||||||
it is not in the core
|
it is not in the core
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user