Update to 1.10.2
This commit is contained in:
parent
0cc00ce9db
commit
1bbb0bd7f8
@ -1,27 +0,0 @@
|
||||
From 0b15c58dad4a10dc6630955fdb7e105cf980196e Mon Sep 17 00:00:00 2001
|
||||
From: Jonathan Dieter <jdieter@gmail.com>
|
||||
Date: Sun, 31 Mar 2019 18:04:32 +0100
|
||||
Subject: [PATCH] Clean up target->curl_handle rather than target->handle
|
||||
|
||||
---
|
||||
librepo/downloader.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/librepo/downloader.c b/librepo/downloader.c
|
||||
index d7e2d70..9650f07 100644
|
||||
--- a/librepo/downloader.c
|
||||
+++ b/librepo/downloader.c
|
||||
@@ -1451,8 +1451,8 @@ prepare_next_transfer(LrDownload *dd, gboolean *candidatefound, GError **err)
|
||||
if(target->zck_state == LR_ZCK_DL_FINISHED) {
|
||||
g_debug("%s: Target already fully downloaded: %s", __func__, target->target->path);
|
||||
target->state = LR_DS_FINISHED;
|
||||
- curl_easy_cleanup(target->handle);
|
||||
- target->handle = NULL;
|
||||
+ curl_easy_cleanup(target->curl_handle);
|
||||
+ target->curl_handle = NULL;
|
||||
g_free(target->headercb_interrupt_reason);
|
||||
target->headercb_interrupt_reason = NULL;
|
||||
fclose(target->f);
|
||||
--
|
||||
libgit2 0.27.7
|
||||
|
13
librepo.spec
13
librepo.spec
@ -26,14 +26,13 @@
|
||||
%global dnf_conflict 2.8.8
|
||||
|
||||
Name: librepo
|
||||
Version: 1.9.6
|
||||
Release: 2%{?dist}
|
||||
Version: 1.10.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Repodata downloading library
|
||||
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/rpm-software-management/librepo
|
||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0: 0001-Clean-up-target-curl_handle-rather-than-target-handle.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc
|
||||
@ -75,6 +74,7 @@ BuildRequires: python2-devel
|
||||
%if %{with pythontests}
|
||||
BuildRequires: python2-flask
|
||||
BuildRequires: python2-nose
|
||||
BuildRequires: python2-requests
|
||||
%if (0%{?rhel} && 0%{?rhel} <= 7)
|
||||
BuildRequires: pyxattr
|
||||
BuildRequires: pygpgme
|
||||
@ -100,6 +100,7 @@ BuildRequires: python3-gpg
|
||||
BuildRequires: python3-flask
|
||||
BuildRequires: python3-nose
|
||||
BuildRequires: python3-pyxattr
|
||||
BuildRequires: python3-requests
|
||||
%endif
|
||||
BuildRequires: python3-sphinx
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
@ -188,6 +189,12 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon May 20 2019 Pavla Kratochvilova <pkratoch@redhat.com> - 1.10.2-1
|
||||
- Update to 1.10.2
|
||||
- Add an option to preserve timestamps of the downloaded files (RhBug:1688537)
|
||||
- librepo: append the '?' part of repo URL after the path
|
||||
- Fix librepo isn't able to load zchunk files from next server on failure
|
||||
|
||||
* Tue Apr 02 2019 Pavla Kratochvilova <pkratoch@redhat.com> - 1.9.6-2
|
||||
- Backport patch to fix segfault when using zchunk metadata
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user