e963fa4ddf
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/libreoffice#6fe1c8d7ea7598afc0d0c1694f3551a20beb6c75
41 lines
1.3 KiB
Diff
41 lines
1.3 KiB
Diff
From a332f53a202d90e99d5159f53f59381bb5f8e4c8 Mon Sep 17 00:00:00 2001
|
|
From: Thierry Vignaud <thierry.vignaud@gmail.com>
|
|
Date: Thu, 30 Jan 2020 11:19:20 +0000
|
|
Subject: [PATCH] fix detecting qrcodegen
|
|
|
|
Change-Id: Ib945b57420083489273cefc5655eb50932b5a3f8
|
|
---
|
|
configure.ac | 2 +-
|
|
cui/source/dialogs/QrCodeGenDialog.cxx | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 7e1ca6d..a6eeec6 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -10235,7 +10235,7 @@ if test "$with_system_qrcodegen" = "yes"; then
|
|
AC_MSG_RESULT([external])
|
|
SYSTEM_QRCODEGEN=TRUE
|
|
AC_LANG_PUSH([C++])
|
|
- AC_CHECK_HEADER(qrcodegen/QrCode.hpp, [],
|
|
+ AC_CHECK_HEADER(qrcodegencpp/QrCode.hpp, [],
|
|
[AC_MSG_ERROR(qrcodegen headers not found.)], [#include <stdexcept>])
|
|
AC_CHECK_LIB([qrcodegencpp], [main], [:],
|
|
[ AC_MSG_ERROR(qrcodegen C++ library not found.) ], [])
|
|
diff --git a/cui/source/dialogs/QrCodeGenDialog.cxx b/cui/source/dialogs/QrCodeGenDialog.cxx
|
|
index 85ed930..0850db5 100644
|
|
--- a/cui/source/dialogs/QrCodeGenDialog.cxx
|
|
+++ b/cui/source/dialogs/QrCodeGenDialog.cxx
|
|
@@ -18,7 +18,7 @@
|
|
#include <vcl/svapp.hxx>
|
|
|
|
#if defined(SYSTEM_QRCODEGEN)
|
|
-#include <qrcodegen/QrCode.hpp>
|
|
+#include <qrcodegencpp/QrCode.hpp>
|
|
#else
|
|
#include <QrCode.hpp>
|
|
#endif
|
|
--
|
|
2.26.2
|
|
|