41 lines
1.3 KiB
Diff
41 lines
1.3 KiB
Diff
From ddf72365b7e7c67b2580e328e55de6eb988b8787 Mon Sep 17 00:00:00 2001
|
|
From: Thierry Vignaud <thierry.vignaud@gmail.com>
|
|
Date: Thu, 30 Jan 2020 11:19:20 +0000
|
|
Subject: [PATCH] fix detecting qrcodegen
|
|
|
|
Change-Id: Ib945b57420083489273cefc5655eb50932b5a3f8
|
|
---
|
|
configure.ac | 2 +-
|
|
cui/source/dialogs/QrCodeGenDialog.cxx | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 388bee3..c061349 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -10092,7 +10092,7 @@ else
|
|
AC_MSG_RESULT([external])
|
|
SYSTEM_QRCODEGEN=TRUE
|
|
AC_LANG_PUSH([C++])
|
|
- AC_CHECK_HEADER(qrcodegen/QrCode.hpp, [],
|
|
+ AC_CHECK_HEADER(qrcodegencpp/QrCode.hpp, [],
|
|
[AC_MSG_ERROR(qrcodegen headers not found.)], [#include <stdexcept>])
|
|
AC_CHECK_LIB([qrcodegencpp], [main], [:],
|
|
[ AC_MSG_ERROR(qrcodegen C++ library not found.) ], [])
|
|
diff --git a/cui/source/dialogs/QrCodeGenDialog.cxx b/cui/source/dialogs/QrCodeGenDialog.cxx
|
|
index 6277e76..f8dd327 100644
|
|
--- a/cui/source/dialogs/QrCodeGenDialog.cxx
|
|
+++ b/cui/source/dialogs/QrCodeGenDialog.cxx
|
|
@@ -20,7 +20,7 @@
|
|
|
|
#if ENABLE_QRCODEGEN
|
|
#if defined(SYSTEM_QRCODEGEN)
|
|
-#include <qrcodegen/QrCode.hpp>
|
|
+#include <qrcodegencpp/QrCode.hpp>
|
|
#else
|
|
#include <QrCode.hpp>
|
|
#endif
|
|
--
|
|
2.26.2
|
|
|