Resolves: rhbz#1971435 upgrade to 7.1.4.2
This commit is contained in:
parent
e88d38b0e6
commit
78c527d441
12
.gitignore
vendored
12
.gitignore
vendored
@ -6,9 +6,9 @@
|
||||
/f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf
|
||||
/libreoffice-multiliblauncher.sh
|
||||
/dtoa-20180411.tgz
|
||||
/libreoffice-7.1.3.2.tar.xz
|
||||
/libreoffice-7.1.3.2.tar.xz.asc
|
||||
/libreoffice-help-7.1.3.2.tar.xz
|
||||
/libreoffice-help-7.1.3.2.tar.xz.asc
|
||||
/libreoffice-translations-7.1.3.2.tar.xz
|
||||
/libreoffice-translations-7.1.3.2.tar.xz.asc
|
||||
/libreoffice-7.1.4.2.tar.xz
|
||||
/libreoffice-7.1.4.2.tar.xz.asc
|
||||
/libreoffice-help-7.1.4.2.tar.xz
|
||||
/libreoffice-help-7.1.4.2.tar.xz.asc
|
||||
/libreoffice-translations-7.1.4.2.tar.xz
|
||||
/libreoffice-translations-7.1.4.2.tar.xz.asc
|
||||
|
@ -1,42 +0,0 @@
|
||||
From f4e496af66bc6a779f600158cc42b986d654f143 Mon Sep 17 00:00:00 2001
|
||||
From: Julien Nabet <serval2412@yahoo.fr>
|
||||
Date: Mon, 14 Dec 2020 19:45:22 +0100
|
||||
Subject: [PATCH] Related tdf#138888: fix assertion on avmedia/MediaControlBase
|
||||
|
||||
Assertion when trying to insert a video in Impress, see bt:
|
||||
https://bugs.documentfoundation.org/attachment.cgi?id=168161
|
||||
|
||||
According to https://en.cppreference.com/w/cpp/algorithm/clamp
|
||||
"behavior is undefined if the value of lo is greater than hi"
|
||||
|
||||
Regression from:
|
||||
commit 36b3b357fe2a882db6a5f5a006239e16200fb847
|
||||
Author: Noel <noelgrandin@gmail.com>
|
||||
Date: Thu Nov 12 16:10:56 2020 +0200
|
||||
|
||||
replace std::min(std::max()) with std::clamp
|
||||
|
||||
Change-Id: Idf33eb6c662b60174678f990f98aefc72edec2a6
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/107722
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
|
||||
---
|
||||
avmedia/source/framework/MediaControlBase.cxx | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/avmedia/source/framework/MediaControlBase.cxx b/avmedia/source/framework/MediaControlBase.cxx
|
||||
index ef92cce8a736..890bb04d805b 100644
|
||||
--- a/avmedia/source/framework/MediaControlBase.cxx
|
||||
+++ b/avmedia/source/framework/MediaControlBase.cxx
|
||||
@@ -64,7 +64,7 @@ void MediaControlBase::UpdateVolumeSlider( MediaItem const & aMediaItem )
|
||||
{
|
||||
mxVolumeSlider->set_sensitive(true);
|
||||
const sal_Int32 nVolumeDB = aMediaItem.getVolumeDB();
|
||||
- mxVolumeSlider->set_value( std::clamp( nVolumeDB, sal_Int32(0), AVMEDIA_DB_RANGE ) );
|
||||
+ mxVolumeSlider->set_value( std::clamp( nVolumeDB, AVMEDIA_DB_RANGE, sal_Int32(0)) );
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
162
0001-Replace-inet_ntoa-with-inet_ntop.patch
Normal file
162
0001-Replace-inet_ntoa-with-inet_ntop.patch
Normal file
@ -0,0 +1,162 @@
|
||||
From 366e9237399a948d2ef616b758d390bd7d0978a5 Mon Sep 17 00:00:00 2001
|
||||
From: Stephan Bergmann <sbergman@redhat.com>
|
||||
Date: Mon, 31 May 2021 09:36:28 +0200
|
||||
Subject: [PATCH] Replace inet_ntoa with inet_ntop
|
||||
|
||||
...as inet_ntoa is potentially not thread-safe; and add a test
|
||||
|
||||
Change-Id: I9df945b006ba7194c3b1444c4886101c08339ad0
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/116425
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
|
||||
(cherry picked from commit 33bf4f0bcf941ee4609f558442035514f54cbc8a)
|
||||
|
||||
and
|
||||
|
||||
Replace inet_addr with inet_pton
|
||||
|
||||
...as inet_addr is deprecated (it does not allow to distinguish successful
|
||||
return for "255.255.255.255" from -1 error return); and update tests
|
||||
|
||||
Change-Id: I605cb2ba18fe9bd11d2d68c8f1c94271c4503509
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/116441
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
|
||||
(cherry picked from commit 1fef071c01caf6c293dd941ee7c8340e6894afc3)
|
||||
|
||||
fix leak in SocketTest
|
||||
|
||||
Change-Id: I8c5e2d4c4687beab08876fe3e945d19a1629bc36
|
||||
Reviewed-on: https://gerrit.libreoffice.org/c/core/+/116514
|
||||
Tested-by: Jenkins
|
||||
Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
|
||||
(cherry picked from commit 313eaf979ea2d69e4ffa88a5e87cc09ffe0ff088)
|
||||
---
|
||||
sal/CppunitTest_sal_osl.mk | 1 +
|
||||
sal/osl/unx/socket.cxx | 16 +++++++----
|
||||
sal/qa/osl/socket.cxx | 58 ++++++++++++++++++++++++++++++++++++++
|
||||
3 files changed, 70 insertions(+), 5 deletions(-)
|
||||
create mode 100644 sal/qa/osl/socket.cxx
|
||||
|
||||
diff --git a/sal/CppunitTest_sal_osl.mk b/sal/CppunitTest_sal_osl.mk
|
||||
index 2e4b77509f56..d8c2627d9e0f 100644
|
||||
--- a/sal/CppunitTest_sal_osl.mk
|
||||
+++ b/sal/CppunitTest_sal_osl.mk
|
||||
@@ -23,6 +23,7 @@ $(eval $(call gb_CppunitTest_add_exception_objects,sal_osl,\
|
||||
sal/qa/osl/process/osl_Thread \
|
||||
sal/qa/osl/profile/osl_old_testprofile \
|
||||
sal/qa/osl/setthreadname/test-setthreadname \
|
||||
+ sal/qa/osl/socket \
|
||||
))
|
||||
|
||||
$(eval $(call gb_CppunitTest_use_libraries,sal_osl,\
|
||||
diff --git a/sal/osl/unx/socket.cxx b/sal/osl/unx/socket.cxx
|
||||
index 56a8f6cd63ac..9fafc6d1db81 100644
|
||||
--- a/sal/osl/unx/socket.cxx
|
||||
+++ b/sal/osl/unx/socket.cxx
|
||||
@@ -437,7 +437,10 @@ oslSocketAddr SAL_CALL osl_createInetBroadcastAddr (
|
||||
&pDottedAddr, strDottedAddr->buffer, strDottedAddr->length,
|
||||
RTL_TEXTENCODING_UTF8, OUSTRING_TO_OSTRING_CVTFLAGS);
|
||||
|
||||
- nAddr = inet_addr (pDottedAddr->buffer);
|
||||
+ in_addr buf;
|
||||
+ if (inet_pton (AF_INET, pDottedAddr->buffer, &buf) == 1) {
|
||||
+ nAddr = buf.s_addr;
|
||||
+ }
|
||||
rtl_string_release (pDottedAddr);
|
||||
}
|
||||
|
||||
@@ -505,11 +508,11 @@ oslSocketAddr osl_psz_createInetSocketAddr (
|
||||
sal_Int32 Port)
|
||||
{
|
||||
oslSocketAddr pAddr = nullptr;
|
||||
- sal_Int32 Addr = inet_addr(pszDottedAddr);
|
||||
- if(Addr != -1)
|
||||
+ in_addr buf;
|
||||
+ if(inet_pton(AF_INET, pszDottedAddr, &buf) == 1)
|
||||
{
|
||||
/* valid dotted addr */
|
||||
- pAddr = createSocketAddrWithFamily( osl_Socket_FamilyInet, htons(Port) , Addr );
|
||||
+ pAddr = createSocketAddrWithFamily( osl_Socket_FamilyInet, htons(Port) , buf.s_addr );
|
||||
}
|
||||
return pAddr;
|
||||
}
|
||||
@@ -1090,7 +1093,10 @@ oslSocketResult SAL_CALL osl_getDottedInetAddrOfSocketAddr(oslSocketAddr Addr, r
|
||||
return osl_Socket_Error;
|
||||
}
|
||||
|
||||
- rtl_uString_newFromAscii(ustrDottedInetAddr,inet_ntoa(pSystemInetAddr->sin_addr));
|
||||
+ char buf[INET_ADDRSTRLEN];
|
||||
+ auto const text = inet_ntop(AF_INET, &pSystemInetAddr->sin_addr, buf, INET_ADDRSTRLEN);
|
||||
+ assert(text != nullptr);
|
||||
+ rtl_uString_newFromAscii(ustrDottedInetAddr,text);
|
||||
|
||||
return osl_Socket_Ok;
|
||||
|
||||
diff --git a/sal/qa/osl/socket.cxx b/sal/qa/osl/socket.cxx
|
||||
new file mode 100644
|
||||
index 000000000000..ed31c9ede7ae
|
||||
--- /dev/null
|
||||
+++ b/sal/qa/osl/socket.cxx
|
||||
@@ -0,0 +1,58 @@
|
||||
+/* -*- Mode: C++; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 4; fill-column: 100 -*- */
|
||||
+/*
|
||||
+ * This file is part of the LibreOffice project.
|
||||
+ *
|
||||
+ * This Source Code Form is subject to the terms of the Mozilla Public
|
||||
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
|
||||
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
|
||||
+ */
|
||||
+
|
||||
+#include <cppunit/TestAssert.h>
|
||||
+#include <cppunit/TestFixture.h>
|
||||
+#include <cppunit/extensions/HelperMacros.h>
|
||||
+
|
||||
+#include <osl/socket.h>
|
||||
+#include <rtl/ustring.hxx>
|
||||
+
|
||||
+namespace
|
||||
+{
|
||||
+class SocketTest : public CppUnit::TestFixture
|
||||
+{
|
||||
+ CPPUNIT_TEST_SUITE(SocketTest);
|
||||
+ CPPUNIT_TEST(test_createInetSocketAddr);
|
||||
+ CPPUNIT_TEST(test_createInetBroadcastAddr);
|
||||
+ CPPUNIT_TEST_SUITE_END();
|
||||
+
|
||||
+ void test_createInetSocketAddr()
|
||||
+ {
|
||||
+ OUString const in("123.4.56.78");
|
||||
+ auto const addr = osl_createInetSocketAddr(in.pData, 100);
|
||||
+ CPPUNIT_ASSERT(addr != nullptr);
|
||||
+ CPPUNIT_ASSERT_EQUAL(osl_Socket_FamilyInet, osl_getFamilyOfSocketAddr(addr));
|
||||
+ OUString out;
|
||||
+ auto const res = osl_getDottedInetAddrOfSocketAddr(addr, &out.pData);
|
||||
+ CPPUNIT_ASSERT_EQUAL(osl_Socket_Ok, res);
|
||||
+ CPPUNIT_ASSERT_EQUAL(in, out);
|
||||
+ CPPUNIT_ASSERT_EQUAL(sal_Int32(100), osl_getInetPortOfSocketAddr(addr));
|
||||
+ osl_destroySocketAddr(addr);
|
||||
+ }
|
||||
+
|
||||
+ void test_createInetBroadcastAddr()
|
||||
+ {
|
||||
+ OUString const in("123.4.56.78");
|
||||
+ auto const addr = osl_createInetBroadcastAddr(in.pData, 100);
|
||||
+ CPPUNIT_ASSERT(addr != nullptr);
|
||||
+ CPPUNIT_ASSERT_EQUAL(osl_Socket_FamilyInet, osl_getFamilyOfSocketAddr(addr));
|
||||
+ OUString out;
|
||||
+ auto const res = osl_getDottedInetAddrOfSocketAddr(addr, &out.pData);
|
||||
+ CPPUNIT_ASSERT_EQUAL(osl_Socket_Ok, res);
|
||||
+ CPPUNIT_ASSERT_EQUAL(OUString("123.255.255.255"), out);
|
||||
+ CPPUNIT_ASSERT_EQUAL(sal_Int32(100), osl_getInetPortOfSocketAddr(addr));
|
||||
+ osl_destroySocketAddr(addr);
|
||||
+ }
|
||||
+};
|
||||
+
|
||||
+CPPUNIT_TEST_SUITE_REGISTRATION(SocketTest);
|
||||
+}
|
||||
+
|
||||
+/* vim:set shiftwidth=4 softtabstop=4 expandtab cinoptions=b1,g0,N-s cinkeys+=0=break: */
|
||||
--
|
||||
2.31.1
|
||||
|
201
0001-dtd-files-are-not-xml-files-and-shouldn-t-have-xml-h.patch
Normal file
201
0001-dtd-files-are-not-xml-files-and-shouldn-t-have-xml-h.patch
Normal file
@ -0,0 +1,201 @@
|
||||
From 3a19d8b8309070f8c14f3a3b4dc4b098ad64190f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Wed, 9 Jun 2021 10:20:57 +0100
|
||||
Subject: [PATCH 1/2] dtd files are not xml files and shouldn't have xml
|
||||
headers
|
||||
|
||||
so rpminspect is correct in complaining that they are not valid xml
|
||||
on inspecting files claiming to be xml
|
||||
|
||||
Change-Id: I70379989326c2ea63e6a54b3658ebea4684fa5df
|
||||
---
|
||||
framework/dtd/accelerator.dtd | 1 -
|
||||
framework/dtd/event.dtd | 1 -
|
||||
framework/dtd/groupuinames.dtd | 1 -
|
||||
framework/dtd/image.dtd | 1 -
|
||||
framework/dtd/menubar.dtd | 1 -
|
||||
framework/dtd/statusbar.dtd | 1 -
|
||||
framework/dtd/toolbar.dtd | 1 -
|
||||
i18npool/source/localedata/data/locale.dtd | 1 -
|
||||
officecfg/registry/component-schema.dtd | 1 -
|
||||
officecfg/registry/component-update.dtd | 1 -
|
||||
package/dtd/Manifest.dtd | 1 -
|
||||
xmerge/source/xmerge/converter.dtd | 1 -
|
||||
xmloff/dtd/office.dtd | 1 -
|
||||
xmlscript/dtd/dialog.dtd | 1 -
|
||||
xmlscript/dtd/libraries.dtd | 2 --
|
||||
xmlscript/dtd/library.dtd | 2 --
|
||||
xmlscript/dtd/module.dtd | 2 --
|
||||
17 files changed, 20 deletions(-)
|
||||
|
||||
diff --git a/framework/dtd/accelerator.dtd b/framework/dtd/accelerator.dtd
|
||||
index f4dcac65242d..912b652d3cf5 100644
|
||||
--- a/framework/dtd/accelerator.dtd
|
||||
+++ b/framework/dtd/accelerator.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
diff --git a/framework/dtd/event.dtd b/framework/dtd/event.dtd
|
||||
index 7a66d15e571b..5af4a3dd267f 100644
|
||||
--- a/framework/dtd/event.dtd
|
||||
+++ b/framework/dtd/event.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
diff --git a/framework/dtd/groupuinames.dtd b/framework/dtd/groupuinames.dtd
|
||||
index a29b77a4f13e..218939cf9bae 100644
|
||||
--- a/framework/dtd/groupuinames.dtd
|
||||
+++ b/framework/dtd/groupuinames.dtd
|
||||
@@ -24,4 +24,3 @@
|
||||
groupuinames:name CDATA #REQUIRED
|
||||
groupuinames:default-ui-name CDATA #REQUIRED
|
||||
>
|
||||
-
|
||||
diff --git a/framework/dtd/image.dtd b/framework/dtd/image.dtd
|
||||
index 59b0f3f92f08..fb69a5e5f4c8 100644
|
||||
--- a/framework/dtd/image.dtd
|
||||
+++ b/framework/dtd/image.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
diff --git a/framework/dtd/menubar.dtd b/framework/dtd/menubar.dtd
|
||||
index b41431f6d0ef..b3469f7324a6 100644
|
||||
--- a/framework/dtd/menubar.dtd
|
||||
+++ b/framework/dtd/menubar.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
diff --git a/framework/dtd/statusbar.dtd b/framework/dtd/statusbar.dtd
|
||||
index 9f4e9e2a35c3..40a5609b7cf6 100644
|
||||
--- a/framework/dtd/statusbar.dtd
|
||||
+++ b/framework/dtd/statusbar.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
diff --git a/framework/dtd/toolbar.dtd b/framework/dtd/toolbar.dtd
|
||||
index 6f2c38260524..7f8ee24e8ab9 100644
|
||||
--- a/framework/dtd/toolbar.dtd
|
||||
+++ b/framework/dtd/toolbar.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
diff --git a/i18npool/source/localedata/data/locale.dtd b/i18npool/source/localedata/data/locale.dtd
|
||||
index 103ab1721c4e..60006d87f439 100644
|
||||
--- a/i18npool/source/localedata/data/locale.dtd
|
||||
+++ b/i18npool/source/localedata/data/locale.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
diff --git a/officecfg/registry/component-schema.dtd b/officecfg/registry/component-schema.dtd
|
||||
index 242b9c6ea513..70bd51bf7d13 100644
|
||||
--- a/officecfg/registry/component-schema.dtd
|
||||
+++ b/officecfg/registry/component-schema.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
diff --git a/officecfg/registry/component-update.dtd b/officecfg/registry/component-update.dtd
|
||||
index d99ee499249e..0659e412305b 100644
|
||||
--- a/officecfg/registry/component-update.dtd
|
||||
+++ b/officecfg/registry/component-update.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
diff --git a/package/dtd/Manifest.dtd b/package/dtd/Manifest.dtd
|
||||
index 2dbdbf00c81d..9e16a007a799 100644
|
||||
--- a/package/dtd/Manifest.dtd
|
||||
+++ b/package/dtd/Manifest.dtd
|
||||
@@ -46,4 +46,3 @@
|
||||
manifest:key-derivation-name CDATA #REQUIRED
|
||||
manifest:salt CDATA #REQUIRED
|
||||
manifest:iteration-count CDATA #REQUIRED>
|
||||
-
|
||||
diff --git a/xmerge/source/xmerge/converter.dtd b/xmerge/source/xmerge/converter.dtd
|
||||
index f7c09f5c2c58..81ecbe69d80e 100644
|
||||
--- a/xmerge/source/xmerge/converter.dtd
|
||||
+++ b/xmerge/source/xmerge/converter.dtd
|
||||
@@ -82,4 +82,3 @@
|
||||
<!ELEMENT converter-target EMPTY>
|
||||
|
||||
<!ATTLIST converter-target type CDATA #REQUIRED>
|
||||
-
|
||||
diff --git a/xmloff/dtd/office.dtd b/xmloff/dtd/office.dtd
|
||||
index e056d57e5525..5da82955640b 100644
|
||||
--- a/xmloff/dtd/office.dtd
|
||||
+++ b/xmloff/dtd/office.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
diff --git a/xmlscript/dtd/dialog.dtd b/xmlscript/dtd/dialog.dtd
|
||||
index 1b7e6355631f..7290b8d22257 100644
|
||||
--- a/xmlscript/dtd/dialog.dtd
|
||||
+++ b/xmlscript/dtd/dialog.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
diff --git a/xmlscript/dtd/libraries.dtd b/xmlscript/dtd/libraries.dtd
|
||||
index 270d89209bba..3b3b82e535b8 100644
|
||||
--- a/xmlscript/dtd/libraries.dtd
|
||||
+++ b/xmlscript/dtd/libraries.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
@@ -33,4 +32,3 @@
|
||||
library:link %boolean; #REQUIRED
|
||||
library:readonly %boolean; #IMPLIED
|
||||
>
|
||||
-
|
||||
diff --git a/xmlscript/dtd/library.dtd b/xmlscript/dtd/library.dtd
|
||||
index 4f1512692ad6..c0341ed545b5 100644
|
||||
--- a/xmlscript/dtd/library.dtd
|
||||
+++ b/xmlscript/dtd/library.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
@@ -32,4 +31,3 @@
|
||||
<!ATTLIST library:element
|
||||
library:name CDATA #REQUIRED
|
||||
>
|
||||
-
|
||||
diff --git a/xmlscript/dtd/module.dtd b/xmlscript/dtd/module.dtd
|
||||
index 5b36ac033d89..b77d62f46498 100644
|
||||
--- a/xmlscript/dtd/module.dtd
|
||||
+++ b/xmlscript/dtd/module.dtd
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!--
|
||||
* This file is part of the LibreOffice project.
|
||||
*
|
||||
@@ -23,4 +22,3 @@
|
||||
script:name CDATA #REQUIRED
|
||||
script:language CDATA #REQUIRED
|
||||
>
|
||||
-
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,42 +0,0 @@
|
||||
From fd87193917a26437ffd6ce08a33bb22e7b7353fd Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Tue, 4 May 2021 21:04:40 +0100
|
||||
Subject: [PATCH] rhbz#1956977 crash on switch from active comment to slide
|
||||
sorter
|
||||
|
||||
Change-Id: I2b5a5cb8b0631971b775a70d96f2cbf0c118c090
|
||||
---
|
||||
sd/source/ui/annotations/annotationmanager.cxx | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/sd/source/ui/annotations/annotationmanager.cxx b/sd/source/ui/annotations/annotationmanager.cxx
|
||||
index 155862469313..898eb201d78e 100644
|
||||
--- a/sd/source/ui/annotations/annotationmanager.cxx
|
||||
+++ b/sd/source/ui/annotations/annotationmanager.cxx
|
||||
@@ -947,10 +947,13 @@ IMPL_LINK_NOARG(AnnotationManagerImpl, UpdateTagsHdl, void*, void)
|
||||
|
||||
void AnnotationManagerImpl::CreateTags()
|
||||
{
|
||||
-
|
||||
if( !(mxCurrentPage.is() && mpDoc) )
|
||||
return;
|
||||
|
||||
+ auto xViewShell = mrBase.GetMainViewShell();
|
||||
+ if (!xViewShell)
|
||||
+ return;
|
||||
+
|
||||
try
|
||||
{
|
||||
int nIndex = 1;
|
||||
@@ -963,7 +966,7 @@ void AnnotationManagerImpl::CreateTags()
|
||||
{
|
||||
Reference< XAnnotation > xAnnotation( xEnum->nextElement() );
|
||||
Color aColor( GetColorLight( mpDoc->GetAnnotationAuthorIndex( xAnnotation->getAuthor() ) ) );
|
||||
- rtl::Reference< AnnotationTag > xTag( new AnnotationTag( *this, *mrBase.GetMainViewShell()->GetView(), xAnnotation, aColor, nIndex++, maFont ) );
|
||||
+ rtl::Reference< AnnotationTag > xTag( new AnnotationTag( *this, *xViewShell->GetView(), xAnnotation, aColor, nIndex++, maFont ) );
|
||||
maTagVector.push_back(xTag);
|
||||
|
||||
if( xAnnotation == mxSelectedAnnotation )
|
||||
--
|
||||
2.31.1
|
||||
|
@ -0,0 +1,40 @@
|
||||
From ba66a3c76c8bd2f7f1e86b4a628b92951fcf82b3 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||
Date: Wed, 9 Jun 2021 09:35:28 +0100
|
||||
Subject: [PATCH 2/2] xmllint: Namespace prefix menu on menuseparator is not
|
||||
defined
|
||||
|
||||
xmllint --noout dbaccess/uiconfig/dbapp/toolbar/formobjectbar.xml
|
||||
dbaccess/uiconfig/dbapp/toolbar/formobjectbar.xml:24: namespace error : Namespace prefix menu on menuseparator is not defined
|
||||
<menu:menuseparator/>
|
||||
|
||||
should be a toolbarseparator here
|
||||
|
||||
a problem since...
|
||||
|
||||
commit 4f810905fa74128871f2fe924a3d28a79f4e4261
|
||||
Date: Tue Mar 5 15:42:19 2019 +0100
|
||||
|
||||
sync dbaccess ui files with swriter ui file structure
|
||||
|
||||
Change-Id: I000efac56a0af10bca7c22fba6f88f469ae9b272
|
||||
---
|
||||
dbaccess/uiconfig/dbapp/toolbar/formobjectbar.xml | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/dbaccess/uiconfig/dbapp/toolbar/formobjectbar.xml b/dbaccess/uiconfig/dbapp/toolbar/formobjectbar.xml
|
||||
index b3c2c9c37eef..78e698df3883 100644
|
||||
--- a/dbaccess/uiconfig/dbapp/toolbar/formobjectbar.xml
|
||||
+++ b/dbaccess/uiconfig/dbapp/toolbar/formobjectbar.xml
|
||||
@@ -21,7 +21,7 @@
|
||||
<toolbar:toolbaritem xlink:href=".uno:DBNewForm"/>
|
||||
<toolbar:toolbaritem xlink:href=".uno:DBFormOpen"/>
|
||||
<toolbar:toolbaritem xlink:href=".uno:DBFormEdit"/>
|
||||
- <menu:menuseparator/>
|
||||
+ <toolbar:toolbarseparator/>
|
||||
<toolbar:toolbaritem xlink:href=".uno:DBFormDelete"/>
|
||||
<toolbar:toolbaritem xlink:href=".uno:DBFormRename"/>
|
||||
<toolbar:toolbarseparator/>
|
||||
--
|
||||
2.31.1
|
||||
|
@ -1,5 +1,5 @@
|
||||
# download path contains version without the last (fourth) digit
|
||||
%global libo_version 7.1.3
|
||||
%global libo_version 7.1.4
|
||||
# Should contain .alphaX / .betaX, if this is pre-release (actually
|
||||
# pre-RC) version. The pre-release string is part of tarball file names,
|
||||
# so we need a way to define it easily at one place.
|
||||
@ -250,11 +250,12 @@ Patch2: 0001-Resolves-rhbz-1432468-disable-opencl-by-default.patch
|
||||
Patch3: 0001-fix-detecting-qrcodegen.patch
|
||||
Patch4: 0001-rhbz-1918152-fix-FTBFS.patch
|
||||
Patch5: 0001-Get-rid-of-apache-commons-logging.patch
|
||||
Patch6: 0001-rhbz-1956977-crash-on-switch-from-active-comment-to-.patch
|
||||
Patch7: 0001-Related-tdf-138888-fix-assertion-on-avmedia-MediaCon.patch
|
||||
Patch8: 0001-Adapt-to-libstdc-Implement-LWG-1203-for-rvalue-iostr.patch
|
||||
Patch9: 0001-Adapt-to-hamcrest-2.2-3.fc35.noarch.rpm.patch
|
||||
Patch10: 0001-gtk3-workaround-missing-gdk_threads_enter-calls-in-e.patch
|
||||
Patch6: 0001-Adapt-to-libstdc-Implement-LWG-1203-for-rvalue-iostr.patch
|
||||
Patch7: 0001-Adapt-to-hamcrest-2.2-3.fc35.noarch.rpm.patch
|
||||
Patch8: 0001-gtk3-workaround-missing-gdk_threads_enter-calls-in-e.patch
|
||||
Patch9: 0001-Replace-inet_ntoa-with-inet_ntop.patch
|
||||
Patch10: 0001-dtd-files-are-not-xml-files-and-shouldn-t-have-xml-h.patch
|
||||
Patch11: 0002-xmllint-Namespace-prefix-menu-on-menuseparator-is-no.patch
|
||||
|
||||
# not upstreamed
|
||||
Patch500: 0001-disable-libe-book-support.patch
|
||||
@ -2240,7 +2241,11 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_includedir}/LibreOfficeKit
|
||||
|
||||
%changelog
|
||||
* Thu May 06 2021 Caolán McNamara <caolanm@redhat.com> - 1:7.1.3.2-1
|
||||
* Wed Jun 09 2021 Caolán McNamara <caolanm@redhat.com> - 1:7.1.4.2-1
|
||||
- latest version
|
||||
- replace 'badfuncs' of inet_addr and inet_ntoa
|
||||
|
||||
* Thu May 20 2021 Caolán McNamara <caolanm@redhat.com> - 1:7.1.3.2-1
|
||||
- Resolves: rhbz#1962262 Get rid of apache-commons-logging
|
||||
- Impress crashes on switch from commenting to slide sorter
|
||||
- fix assertion on avmedia volumne control
|
||||
|
12
sources
12
sources
@ -7,9 +7,9 @@ SHA512 (0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz) = b9c02d63e9b47a838d
|
||||
SHA512 (f543e6e2d7275557a839a164941c0a86e5f2c3f2a0042bfc434c88c6dde9e140-opens___.ttf) = 6a6d131dad5191614950a49323ae6d9385afe331983c1c85fde82ce6ee816051d95dde9ef90658b8f0a8a0a21754e72ff724bf41f6b96c046b7b4c2660f7095b
|
||||
SHA512 (libreoffice-multiliblauncher.sh) = db532afdf5000bc66f9e02c7d0ab586468466f63f8f0bdb204832581e8277c5c59f688fa096548d642411cb8c46e8de4a744676b4e624c075262cfd6945138cd
|
||||
SHA512 (dtoa-20180411.tgz) = 722aa814c33a34bfffe6c0201b0035cc3b65854a0ba9ae2f51620a89d68019353e2c306651b35bca337186b22b2e9865ef3c5e3df8e9328006f882e4577f8c85
|
||||
SHA512 (libreoffice-7.1.3.2.tar.xz) = d7329475cad5bece9358b29bc590da1841c3c0b4aef511508d9398519c514fa176c90675857f1830925818f2dcc8b9c0986e5d34d3a33cce617e4ada23c60a72
|
||||
SHA512 (libreoffice-7.1.3.2.tar.xz.asc) = 9952bef51e851cd0b2601dce06304885cb9e53924641c5bf21f64ddd0c63c48c4be9223282640cb1fb84976be27e74e587781177c2155369017d3ad92147e4da
|
||||
SHA512 (libreoffice-help-7.1.3.2.tar.xz) = 576dbea391777a907275b630ed704dd3d9ad0627f8a18da1cbd23fe28df04c3a509583c2404f810df3aaac15ef0881e2c1e0a55c9f31618715586628873367eb
|
||||
SHA512 (libreoffice-help-7.1.3.2.tar.xz.asc) = 0c1a2280b855cc06d5698ff36448dbe9379bf84a2c3acbb755ff4f69de145b1909dd38ab7dc5498b29687841a101b9cd87e1a00f3abdc03b9015ebda8b28e454
|
||||
SHA512 (libreoffice-translations-7.1.3.2.tar.xz) = df320e5c41e94c08847b1f504461f6dcd11bc9c301ec0e219fead05a24982c0946e98263320c53357f89e8497e56871da071fff41f780f4ae8bf45859a88b34d
|
||||
SHA512 (libreoffice-translations-7.1.3.2.tar.xz.asc) = 7562148d64429a035c0d54973ed041e4623c181aa6f65a16448f14efa84b4ef36f3f8abb8cddf28cd47ba540f314d48d98f02a0fde2b0f269d180861c9c54637
|
||||
SHA512 (libreoffice-7.1.4.2.tar.xz) = b6c0d5ed91cd69e20e70b2fd5e6f53f05eb0fbd73c41208c317116c636b2ee8cfd848370389dd61d3c243b259ae66b9bd5de9341cd9009279ccfd299015c88c8
|
||||
SHA512 (libreoffice-7.1.4.2.tar.xz.asc) = 89eeb1605dca242bffd8f341b23dfc0e5f0cfbb95a5b554436a6f9e62783021d4596bdca62ad010c46e74c3861d63c9e006391a4d9a2ff355393caeb42db9e43
|
||||
SHA512 (libreoffice-help-7.1.4.2.tar.xz) = 7730a17cd171d126b3b094abde1797524ff7250a5895d6d80b10b30944225d318001cbc66bdff06019be69434278dfd864aec71b0b9572c6385639620b416268
|
||||
SHA512 (libreoffice-help-7.1.4.2.tar.xz.asc) = e5383926d4e2e676758dbd0a485113b9eda49e52aa38f29a17acd5134d7018f1e523fd96fb59d1ab916f5fd28737cacebaa0348b4ca1a6866359c168a1b9a498
|
||||
SHA512 (libreoffice-translations-7.1.4.2.tar.xz) = 987a4f9c86d70c52bdb80a89b73428aae63725a5c7e0def464a35220bf22b29adaa56937f93e0c48cee43e47a16d385b079acc2d0aa8b23b637e447a2eed30c4
|
||||
SHA512 (libreoffice-translations-7.1.4.2.tar.xz.asc) = 9c0a0d15b2ff18a3d704a338ee9939108d408584a12e9b3c381b36fcd5aa8bd9e9000f15487eebe65c5fa3a16d7289f557df17d05b5f8f8cd4de9021974999b3
|
||||
|
Loading…
Reference in New Issue
Block a user