import libreoffice-voikko-5.0-6.el8
This commit is contained in:
parent
7775b40941
commit
fbae9558aa
@ -0,0 +1,36 @@
|
|||||||
|
From 83e27fc67d81b76daea4ab0741cf5799456d867f Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
|
||||||
|
Date: Thu, 23 Jan 2020 10:16:38 +0000
|
||||||
|
Subject: [PATCH] make install-unpacked flattens the python hierarchy so result
|
||||||
|
doesn't work
|
||||||
|
|
||||||
|
the original oxt has the correct hierarchy but 'install' flattened it
|
||||||
|
|
||||||
|
Resolves:
|
||||||
|
https://github.com/voikko/libreoffice-voikko/issues/11
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1676830
|
||||||
|
https://bugs.documentfoundation.org/show_bug.cgi?id=122984
|
||||||
|
---
|
||||||
|
Makefile | 6 ++----
|
||||||
|
1 file changed, 2 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 18eaff6..da085f3 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -98,10 +98,8 @@ all: oxt
|
||||||
|
|
||||||
|
install-unpacked: extension-files
|
||||||
|
install -m 755 -d "$(DESTDIR)" "$(DESTDIR)/META-INF"
|
||||||
|
- install -m 644 build/oxt/META-INF/manifest.xml "$(DESTDIR)/META-INF"
|
||||||
|
- install -m 644 build/oxt/description.xml \
|
||||||
|
- $(patsubst %,build/oxt/%,$(STANDALONE_EXTENSION_FILES)) \
|
||||||
|
- $(patsubst %,build/oxt/%,$(COPY_TEMPLATES)) $(DESTDIR)
|
||||||
|
+ install -m 755 -d "$(DESTDIR)" "$(DESTDIR)/pythonpath"
|
||||||
|
+ cd oxt && find . -type f -exec install -D {} $(DESTDIR)/{} \;
|
||||||
|
|
||||||
|
# Sed scripts for modifying templates
|
||||||
|
DESCRIPTION_SEDSCRIPT:=s/VOIKKO_VERSION/$(VOIKKO_VERSION)/g
|
||||||
|
--
|
||||||
|
2.24.1
|
||||||
|
|
@ -11,7 +11,7 @@
|
|||||||
|
|
||||||
Name: libreoffice-voikko
|
Name: libreoffice-voikko
|
||||||
Version: 5.0
|
Version: 5.0
|
||||||
Release: 2%{?dist}
|
Release: 6%{?dist}
|
||||||
Summary: Finnish spellchecker and hyphenator extension for LibreOffice
|
Summary: Finnish spellchecker and hyphenator extension for LibreOffice
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
@ -20,8 +20,11 @@ URL: http://voikko.puimula.org/
|
|||||||
Source0: http://www.puimula.org/voikko-sources/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://www.puimula.org/voikko-sources/%{name}/%{name}-%{version}.tar.gz
|
||||||
# The usual format of test release URLs
|
# The usual format of test release URLs
|
||||||
#Source0: http://www.puimula.org/htp/testing/%{name}-%{version}rc2.tar.gz
|
#Source0: http://www.puimula.org/htp/testing/%{name}-%{version}rc2.tar.gz
|
||||||
|
# https://github.com/voikko/libreoffice-voikko/pull/12
|
||||||
|
Patch0: 0001-make-install-unpacked-flattens-the-python-hierarchy-.patch
|
||||||
|
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
|
BuildRequires: make
|
||||||
Requires: python3-libvoikko
|
Requires: python3-libvoikko
|
||||||
Requires: libreoffice-core%{?_isa}
|
Requires: libreoffice-core%{?_isa}
|
||||||
Requires: libreoffice-pyuno%{?_isa}
|
Requires: libreoffice-pyuno%{?_isa}
|
||||||
@ -34,20 +37,33 @@ provided by the Voikko library.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .fix.install-unpacked
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make extension-files %{?_smp_mflags}
|
make extension-files %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
make install-unpacked DESTDIR=$RPM_BUILD_ROOT%{voikkoext}
|
make install-unpacked DESTDIR=$RPM_BUILD_ROOT%{voikkoext}
|
||||||
|
chmod 644 %{buildroot}%{voikkoext}/{icon.png,SettingsDialog_en_US.default}
|
||||||
%py_byte_compile %{__python3} %{buildroot}%{voikkoext}
|
%py_byte_compile %{__python3} %{buildroot}%{voikkoext}
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%{voikkoext}
|
%{voikkoext}
|
||||||
%doc ChangeLog COPYING README
|
%doc ChangeLog COPYING README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 20 2021 Mike FABIAN <mfabian@redhat.com> - 5.0-6
|
||||||
|
- Related: rhbz#1862385 keep permissions 644 for icon.png and SettingsDialog_en_US.default
|
||||||
|
|
||||||
|
* Tue Apr 20 2021 Mike FABIAN <mfabian@redhat.com> - 5.0-5
|
||||||
|
- Related: rhbz#1862385 add tests/ folder and test script
|
||||||
|
|
||||||
|
* Mon Apr 19 2021 Mike FABIAN <mfabian@redhat.com> - 5.0-4
|
||||||
|
- Related: rhbz#1862385 add gating.yaml
|
||||||
|
|
||||||
|
* Mon Apr 12 2021 Mike FABIAN <mfabian@redhat.com> - 5.0-3
|
||||||
|
- Resolves: rhbz#1862385 fix make install-unpacked to keep hierarchy
|
||||||
|
|
||||||
* Sun Aug 5 2018 Ville-Pekka Vainio <vpvainio AT iki.fi> - 5.0-2
|
* Sun Aug 5 2018 Ville-Pekka Vainio <vpvainio AT iki.fi> - 5.0-2
|
||||||
- Fix dependencies
|
- Fix dependencies
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user