import librdkafka-0.11.4-1.el8

This commit is contained in:
CentOS Sources 2019-05-07 01:57:51 -04:00 committed by Andrew Lukoshko
commit d87fa3646d
4 changed files with 157 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/librdkafka-0.11.4.tar.gz

1
.librdkafka.metadata Normal file
View File

@ -0,0 +1 @@
00e5b9c610697a0f32910fd1ef19e9b2c684824e SOURCES/librdkafka-0.11.4.tar.gz

View File

@ -0,0 +1,42 @@
diff -up ./configure.librdkafka.python3 ./configure.librdkafka
--- ./configure.librdkafka.python3 2018-06-28 14:31:29.059417830 +0200
+++ ./configure.librdkafka 2018-06-28 14:31:54.328300531 +0200
@@ -179,7 +179,7 @@ void foo (void) {
# The linker-script generator (lds-gen.py) requires python
if [[ $WITH_LDS == y ]]; then
- if ! mkl_command_check python "HAVE_PYTHON" "disable" "python -V"; then
+ if ! mkl_command_check python "HAVE_PYTHON" "disable" "python3 -V"; then
mkl_err "disabling linker-script since python is not available"
mkl_mkvar_set WITH_LDS WITH_LDS "n"
fi
diff -up ./lds-gen.py.python3 ./lds-gen.py
--- ./lds-gen.py.python3 2017-07-19 22:10:29.000000000 +0200
+++ ./lds-gen.py 2018-06-28 14:22:12.745022430 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
#
#
# Generate linker script to only expose symbols of the public API
diff -up ./Makefile.python3 ./Makefile
--- ./Makefile.python3 2018-06-28 14:32:46.176059853 +0200
+++ ./Makefile 2018-06-28 14:32:56.542011734 +0200
@@ -5,7 +5,7 @@ CHECK_FILES+= CONFIGURATION.md \
examples/rdkafka_example_cpp
PACKAGE_NAME?= librdkafka
-VERSION?= $(shell python packaging/get_version.py src/rdkafka.h)
+VERSION?= $(shell python3 packaging/get_version.py src/rdkafka.h)
# Jenkins CI integration
BUILD_NUMBER ?= 1
diff -up ./packaging/get_version.py.python3 ./packaging/get_version.py
--- ./packaging/get_version.py.python3 2018-06-28 14:33:48.825769032 +0200
+++ ./packaging/get_version.py 2018-06-28 14:33:57.385729296 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
import sys

113
SPECS/librdkafka.spec Normal file
View File

@ -0,0 +1,113 @@
Name: librdkafka
Version: 0.11.4
Release: 1%{?dist}
Summary: The Apache Kafka C library
Group: Development/Libraries
License: BSD
URL: https://github.com/edenhill/librdkafka
Source0: https://github.com/edenhill/librdkafka/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: python3
BuildRequires: openssl-devel
BuildRequires: cyrus-sasl-devel
BuildRequires: lz4-devel
Patch1: librdkafka-python3.patch
%description
Librdkafka is a C/C++ library implementation of the Apache Kafka protocol,
containing both Producer and Consumer support.
It was designed with message delivery reliability and high performance in mind,
current figures exceed 800000 messages/second for the producer and 3 million
messages/second for the consumer.
%package devel
Summary: The Apache Kafka C library (Development Environment)
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
librdkafka is a C/C++ library implementation of the Apache Kafka protocol,
containing both Producer and Consumer support.
This package contains headers and libraries required to build applications
using librdkafka.
%prep
%setup -q
%patch1 -p1 -b .python3
%build
%configure --enable-lz4 \
--enable-ssl \
--enable-sasl
%make_build
%check
make check
%install
%make_install
find %{buildroot} -name '*.a' -delete -print
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%{_libdir}/librdkafka.so.*
%{_libdir}/librdkafka++.so.*
%doc README.md CONFIGURATION.md INTRODUCTION.md
%license LICENSE LICENSE.pycrc LICENSE.snappy
%files devel
%dir %{_includedir}/librdkafka
%attr(0644,root,root) %{_includedir}/librdkafka/*
%{_libdir}/librdkafka.so
%{_libdir}/librdkafka++.so
%{_libdir}/pkgconfig/rdkafka.pc
%{_libdir}/pkgconfig/rdkafka++.pc
%{_libdir}/pkgconfig/rdkafka-static.pc
%{_libdir}/pkgconfig/rdkafka++-static.pc
%changelog
* Fri Feb 08 2019 Jiri Vymazal <jvymazal@redhat.com> - 0.11.4-1
- rebase to v0.11.4 (0.11.5 was breaking rsyslog-kafka)
resolves: rhbz#1614697
* Fri Aug 10 2018 Jiri Vymazal <jvymazal@redhat.com> - 0.11.5-1
- rebase to v0.11.5
resolves: rhbz#1614697
- removed explicit %attr on symlinks
* Thu Jun 28 2018 Radovan Sroka <rsroka@redhat.com> - 0.11.0-2
- switch from python2 to python3
resolves: rhbz#1595795
* Thu Aug 31 2017 Michal Luscon <mluscon@gmail.com> - 0.11.0-1
- Update to 0.11.0
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Mon May 22 2017 Radovan Sroka <rsroka@redhat.com> - 0.9.5-1
- Update to 0.9.4
* Sat Mar 11 2017 Michal Luscon <mluscon@gmail.com> - 0.9.4-1
- Update to 0.9.4
- enable lz4, ssl, sasl
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Fri Nov 11 2016 Radovan Sroka <rsroka@redhat.com> 0.9.2-1
- 0.9.2 release
- package created