Import from AlmaLinux stable repository

This commit is contained in:
eabdullin 2024-05-31 16:49:27 +00:00
parent ca3f3d6b97
commit c1d35f634d
6 changed files with 36 additions and 73 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/librdkafka-0.11.4.tar.gz
SOURCES/librdkafka-1.6.1.tar.gz

View File

@ -1 +0,0 @@
00e5b9c610697a0f32910fd1ef19e9b2c684824e SOURCES/librdkafka-0.11.4.tar.gz

View File

@ -1,42 +0,0 @@
diff -up ./configure.librdkafka.python3 ./configure.librdkafka
--- ./configure.librdkafka.python3 2018-06-28 14:31:29.059417830 +0200
+++ ./configure.librdkafka 2018-06-28 14:31:54.328300531 +0200
@@ -179,7 +179,7 @@ void foo (void) {
# The linker-script generator (lds-gen.py) requires python
if [[ $WITH_LDS == y ]]; then
- if ! mkl_command_check python "HAVE_PYTHON" "disable" "python -V"; then
+ if ! mkl_command_check python "HAVE_PYTHON" "disable" "python3 -V"; then
mkl_err "disabling linker-script since python is not available"
mkl_mkvar_set WITH_LDS WITH_LDS "n"
fi
diff -up ./lds-gen.py.python3 ./lds-gen.py
--- ./lds-gen.py.python3 2017-07-19 22:10:29.000000000 +0200
+++ ./lds-gen.py 2018-06-28 14:22:12.745022430 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
#
#
# Generate linker script to only expose symbols of the public API
diff -up ./Makefile.python3 ./Makefile
--- ./Makefile.python3 2018-06-28 14:32:46.176059853 +0200
+++ ./Makefile 2018-06-28 14:32:56.542011734 +0200
@@ -5,7 +5,7 @@ CHECK_FILES+= CONFIGURATION.md \
examples/rdkafka_example_cpp
PACKAGE_NAME?= librdkafka
-VERSION?= $(shell python packaging/get_version.py src/rdkafka.h)
+VERSION?= $(shell python3 packaging/get_version.py src/rdkafka.h)
# Jenkins CI integration
BUILD_NUMBER ?= 1
diff -up ./packaging/get_version.py.python3 ./packaging/get_version.py
--- ./packaging/get_version.py.python3 2018-06-28 14:33:48.825769032 +0200
+++ ./packaging/get_version.py 2018-06-28 14:33:57.385729296 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python3
import sys

View File

@ -1,13 +0,0 @@
diff -up librdkafka-0.11.4/src/rdkafka_conf.c.orig librdkafka-0.11.4/src/rdkafka_conf.c
--- librdkafka-0.11.4/src/rdkafka_conf.c.orig 2021-11-01 18:29:29.669679125 +0100
+++ librdkafka-0.11.4/src/rdkafka_conf.c 2021-11-01 18:30:21.007126511 +0100
@@ -468,7 +468,8 @@ static const struct rd_kafka_property rd
"encryption, MAC and key exchange algorithm used to negotiate the "
"security settings for a network connection using TLS or SSL network "
"protocol. See manual page for `ciphers(1)` and "
- "`SSL_CTX_set_cipher_list(3)."
+ "`SSL_CTX_set_cipher_list(3).",
+ .sdef = "PROFILE=SYSTEM"
},
{ _RK_GLOBAL, "ssl.key.location", _RK_C_STR,
_RK(ssl.key_location),

View File

@ -0,0 +1,11 @@
diff -up librdkafka-1.6.1/src/rdkafka_conf.c.orig librdkafka-1.6.1/src/rdkafka_conf.c
--- librdkafka-1.6.1/src/rdkafka_conf.c.orig 2023-11-14 08:47:54.294933845 +0100
+++ librdkafka-1.6.1/src/rdkafka_conf.c 2023-11-14 08:48:30.777285310 +0100
@@ -707,6 +707,7 @@ static const struct rd_kafka_property rd
"security settings for a network connection using TLS or SSL network "
"protocol. See manual page for `ciphers(1)` and "
"`SSL_CTX_set_cipher_list(3).",
+ .sdef = "PROFILE=SYSTEM",
_UNSUPPORTED_SSL
},
{ _RK_GLOBAL, "ssl.curves.list", _RK_C_STR,

View File

@ -1,6 +1,6 @@
Name: librdkafka
Version: 0.11.4
Release: 3%{?dist}
Version: 1.6.1
Release: 1%{?dist}
Summary: The Apache Kafka C library
Group: Development/Libraries
@ -11,12 +11,13 @@ Source0: https://github.com/edenhill/librdkafka/archive/v%{version}.tar.gz#/%{na
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: python3
BuildRequires: openssl-devel
BuildRequires: cyrus-sasl-devel
BuildRequires: lz4-devel
BuildRequires: libzstd-devel
BuildRequires: lz4-devel
BuildRequires: openssl-devel
BuildRequires: cyrus-sasl-devel
BuildRequires: zlib-devel
Patch1: librdkafka-python3.patch
Patch2: rsyslog-0.11.4-rhbz1842817-crypto-compliance.patch
Patch1: rsyslog-1.6.1-rhbz1842817-crypto-compliance.patch
%description
Librdkafka is a C/C++ library implementation of the Apache Kafka protocol,
@ -39,12 +40,15 @@ using librdkafka.
%prep
%setup -q
%patch1 -p1 -b .python3
%patch2 -p1 -b .crypto-compliance
%patch -P 1 -p1
%build
%configure --enable-lz4 \
%configure --enable-zlib \
--enable-zstd \
--enable-lz4 \
--enable-lz4-ext \
--enable-ssl \
--enable-gssapi \
--enable-sasl
%make_build
@ -56,14 +60,13 @@ make check
%make_install
find %{buildroot} -name '*.a' -delete -print
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%ldconfig_scriptlets
%files
%{_libdir}/librdkafka.so.*
%{_libdir}/librdkafka++.so.*
%doc README.md CONFIGURATION.md INTRODUCTION.md
%license LICENSE LICENSE.pycrc LICENSE.snappy
%doc README.md CONFIGURATION.md INTRODUCTION.md STATISTICS.md CHANGELOG.md LICENSE LICENSES.txt
%license LICENSE LICENSE.pycrc LICENSE.snappy LICENSES.txt
%files devel
%dir %{_includedir}/librdkafka
@ -75,8 +78,13 @@ find %{buildroot} -name '*.a' -delete -print
%{_libdir}/pkgconfig/rdkafka-static.pc
%{_libdir}/pkgconfig/rdkafka++-static.pc
%changelog
* Tue Nov 14 2023 Attila Lakatos <alakatos@redhat.com> - 1.6.1-1
- Rebase to 1.6.1
resolves: RHEL-12892
- Fix warnings reported by rpmlint
- Enable support for zlib/zstd compression and GSSAPI
* Mon Nov 01 2021 Attila Lakatos <alakatos@redhat.com> - 0.11.4-3
- Set SSL_CTX_set_cipher_list to use system-wide crypto policies
resolves: rhbz#1842817
@ -91,7 +99,7 @@ find %{buildroot} -name '*.a' -delete -print
* Fri Aug 10 2018 Jiri Vymazal <jvymazal@redhat.com> - 0.11.5-1
- rebase to v0.11.5
resolves: rhbz#1614697
- removed explicit %attr on symlinks
- removed explicit attr macro on symlinks
* Thu Jun 28 2018 Radovan Sroka <rsroka@redhat.com> - 0.11.0-2
- switch from python2 to python3