- update to 0.5.0
- open https://github.com/alanxz/rabbitmq-c/issues/169 (version is 0.5.1-pre) - open https://github.com/alanxz/rabbitmq-c/issues/170 (amqp_get_server_properties)
This commit is contained in:
parent
81dfb08846
commit
2be768594d
3
.gitignore
vendored
3
.gitignore
vendored
@ -1,7 +1,8 @@
|
||||
*spec~
|
||||
clog
|
||||
/6fb87d6eb01b.tar.bz2
|
||||
/fb6fca832fd2.tar.bz2
|
||||
/alanxz-rabbitmq-c-0.2-69-g2059570.tar.gz
|
||||
/db13342f2443.tar.bz2
|
||||
/rabbitmq-c-v0.3.0.tar.gz
|
||||
/rabbitmq-c-0.4.1.tar.gz
|
||||
/rabbitmq-c-0.5.0.tar.gz
|
||||
|
@ -1,39 +0,0 @@
|
||||
From 02d5c58ae4b9bbaa6201990ff5066f0db561d231 Mon Sep 17 00:00:00 2001
|
||||
From: Alan Antonuk <alan.antonuk@gmail.com>
|
||||
Date: Wed, 1 Jan 2014 17:51:31 -0800
|
||||
Subject: [PATCH] Fixes librabbitmq.pc generation under autoconf
|
||||
|
||||
Properly substitute the @requires_private@ and @libs_private@ variables
|
||||
when configuring under autoconf
|
||||
|
||||
This fixes #154
|
||||
---
|
||||
configure.ac | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 0559f8f..382fafa 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -115,7 +115,8 @@ AS_IF([test "x$with_ssl" = "xcyassl"],
|
||||
[test "x$with_ssl" = "xgnutls"],
|
||||
[PKG_CHECK_MODULES([SSL], [gnutls],, [with_ssl=no])],
|
||||
[test "x$with_ssl" = "xopenssl"],
|
||||
- [PKG_CHECK_MODULES([SSL], [openssl >= 0.9.8],, [with_ssl=no])],
|
||||
+ [PKG_CHECK_MODULES([SSL], [openssl >= 0.9.8], [ssl_pkg_required=openssl],
|
||||
+ [with_ssl=no])],
|
||||
[test "x$with_ssl" = "xpolarssl"],
|
||||
[AX_LIB_POLARSSL([SSL_CFLAGS=$POLARSSL_CFLAGS
|
||||
SSL_LIBS=$POLARSSL_LIBS],
|
||||
@@ -162,6 +163,8 @@ AC_ARG_ENABLE([examples],
|
||||
[enable_examples=yes])
|
||||
AM_CONDITIONAL([EXAMPLES], [test "x$enable_examples" = "xyes"])
|
||||
|
||||
+AC_SUBST([requires_private], [$ssl_pkg_required])
|
||||
+AC_SUBST([libs_private], [$LIBS])
|
||||
AC_CONFIG_HEADERS([config.h])
|
||||
AC_CONFIG_FILES([
|
||||
librabbitmq.pc
|
||||
--
|
||||
1.8.5.1
|
||||
|
27
librabbitmq-ver.patch
Normal file
27
librabbitmq-ver.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From b7c3f97acf25cd0e8644be46f0a9a5f7ece2e33d Mon Sep 17 00:00:00 2001
|
||||
From: Alan Antonuk <alan.antonuk@gmail.com>
|
||||
Date: Wed, 29 Jan 2014 22:21:31 -0800
|
||||
Subject: [PATCH] Bumping version for development
|
||||
|
||||
---
|
||||
librabbitmq/amqp.h | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/librabbitmq/amqp.h b/librabbitmq/amqp.h
|
||||
index 7f4226c..fd13087 100644
|
||||
--- a/librabbitmq/amqp.h
|
||||
+++ b/librabbitmq/amqp.h
|
||||
@@ -223,8 +223,8 @@
|
||||
|
||||
#define AMQP_VERSION_MAJOR 0
|
||||
#define AMQP_VERSION_MINOR 5
|
||||
-#define AMQP_VERSION_PATCH 0
|
||||
-#define AMQP_VERSION_IS_RELEASE 1
|
||||
+#define AMQP_VERSION_PATCH 1
|
||||
+#define AMQP_VERSION_IS_RELEASE 0
|
||||
|
||||
|
||||
/**
|
||||
--
|
||||
1.8.5.1
|
||||
|
@ -9,14 +9,16 @@
|
||||
|
||||
Name: librabbitmq
|
||||
Summary: Client library for AMQP
|
||||
Version: 0.4.1
|
||||
Release: 4%{?dist}
|
||||
Version: 0.5.0
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: https://github.com/alanxz/rabbitmq-c
|
||||
|
||||
Source0: https://github.com/alanxz/rabbitmq-c/releases/download/v%{version}/rabbitmq-c-%{version}.tar.gz
|
||||
Patch0: %{name}-pc.patch
|
||||
|
||||
# for revert, switch from 0.5.0 to 0.5.1-pre
|
||||
Patch0: %{name}-ver.patch
|
||||
|
||||
BuildRequires: libtool
|
||||
BuildRequires: openssl-devel
|
||||
@ -60,7 +62,7 @@ amqp-publish Publish a message on an AMQP server
|
||||
%prep
|
||||
%setup -q -n rabbitmq-c-%{version}
|
||||
|
||||
%patch0 -p1
|
||||
%patch0 -p1 -R
|
||||
|
||||
# Copy sources to be included in -devel docs.
|
||||
cp -pr examples Examples
|
||||
@ -118,6 +120,11 @@ make check
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Feb 17 2014 Remi Collet <remi@fedoraproject.org> - 0.5.0-1
|
||||
- update to 0.5.0
|
||||
- open https://github.com/alanxz/rabbitmq-c/issues/169 (version is 0.5.1-pre)
|
||||
- open https://github.com/alanxz/rabbitmq-c/issues/170 (amqp_get_server_properties)
|
||||
|
||||
* Mon Jan 13 2014 Remi Collet <remi@fedoraproject.org> - 0.4.1-4
|
||||
- drop BR python-simplejson
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user