fix broken librabbitmq.pc, #1039555
This commit is contained in:
parent
c35a5244a3
commit
16aa3e7c12
39
librabbitmq-pc.patch
Normal file
39
librabbitmq-pc.patch
Normal file
@ -0,0 +1,39 @@
|
||||
From 02d5c58ae4b9bbaa6201990ff5066f0db561d231 Mon Sep 17 00:00:00 2001
|
||||
From: Alan Antonuk <alan.antonuk@gmail.com>
|
||||
Date: Wed, 1 Jan 2014 17:51:31 -0800
|
||||
Subject: [PATCH] Fixes librabbitmq.pc generation under autoconf
|
||||
|
||||
Properly substitute the @requires_private@ and @libs_private@ variables
|
||||
when configuring under autoconf
|
||||
|
||||
This fixes #154
|
||||
---
|
||||
configure.ac | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 0559f8f..382fafa 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -115,7 +115,8 @@ AS_IF([test "x$with_ssl" = "xcyassl"],
|
||||
[test "x$with_ssl" = "xgnutls"],
|
||||
[PKG_CHECK_MODULES([SSL], [gnutls],, [with_ssl=no])],
|
||||
[test "x$with_ssl" = "xopenssl"],
|
||||
- [PKG_CHECK_MODULES([SSL], [openssl >= 0.9.8],, [with_ssl=no])],
|
||||
+ [PKG_CHECK_MODULES([SSL], [openssl >= 0.9.8], [ssl_pkg_required=openssl],
|
||||
+ [with_ssl=no])],
|
||||
[test "x$with_ssl" = "xpolarssl"],
|
||||
[AX_LIB_POLARSSL([SSL_CFLAGS=$POLARSSL_CFLAGS
|
||||
SSL_LIBS=$POLARSSL_LIBS],
|
||||
@@ -162,6 +163,8 @@ AC_ARG_ENABLE([examples],
|
||||
[enable_examples=yes])
|
||||
AM_CONDITIONAL([EXAMPLES], [test "x$enable_examples" = "xyes"])
|
||||
|
||||
+AC_SUBST([requires_private], [$ssl_pkg_required])
|
||||
+AC_SUBST([libs_private], [$LIBS])
|
||||
AC_CONFIG_HEADERS([config.h])
|
||||
AC_CONFIG_FILES([
|
||||
librabbitmq.pc
|
||||
--
|
||||
1.8.5.1
|
||||
|
@ -1,6 +1,6 @@
|
||||
# spec file for librabbitmq
|
||||
#
|
||||
# Copyright (c) 2012-2013 Remi Collet
|
||||
# Copyright (c) 2012-2014 Remi Collet
|
||||
# License: CC-BY-SA
|
||||
# http://creativecommons.org/licenses/by-sa/3.0/
|
||||
#
|
||||
@ -10,12 +10,13 @@
|
||||
Name: librabbitmq
|
||||
Summary: Client library for AMQP
|
||||
Version: 0.4.1
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: https://github.com/alanxz/rabbitmq-c
|
||||
|
||||
Source0: https://github.com/alanxz/rabbitmq-c/archive/rabbitmq-c-%{version}.tar.gz
|
||||
Source0: https://github.com/alanxz/rabbitmq-c/releases/download/v%{version}/rabbitmq-c-%{version}.tar.gz
|
||||
Patch0: %{name}-pc.patch
|
||||
|
||||
BuildRequires: libtool
|
||||
BuildRequires: python-simplejson
|
||||
@ -112,6 +113,10 @@ make check
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jan 2 2014 Remi Collet <remi@fedoraproject.org> - 0.4.1-2
|
||||
- fix broken librabbitmq.pc, #1039555
|
||||
- fix Source0 URL
|
||||
|
||||
* Sat Sep 28 2013 Remi Collet <remi@fedoraproject.org> - 0.4.1-1
|
||||
- update to 0.4.1
|
||||
- add ssl support
|
||||
|
Loading…
Reference in New Issue
Block a user