import libqmi-1.32.2-3.el8
This commit is contained in:
parent
4f52c6d1f5
commit
bc6bf445ba
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/libqmi-1.30.2.tar.xz
|
||||
SOURCES/libqmi-1.32.2.tar.bz2
|
||||
|
@ -1 +1 @@
|
||||
0e6f876f9ea558ef507fabc7eac836a311efb7b6 SOURCES/libqmi-1.30.2.tar.xz
|
||||
3bc82111a621e684dd61f26ea0cc7cc54cf09c9f SOURCES/libqmi-1.32.2.tar.bz2
|
||||
|
24
SOURCES/0001-Disable-docs-check.patch
Normal file
24
SOURCES/0001-Disable-docs-check.patch
Normal file
@ -0,0 +1,24 @@
|
||||
From b963eff93ec9f3c8d282ff1cd8f7b019f4aed82a Mon Sep 17 00:00:00 2001
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Date: Mon, 12 Dec 2022 07:43:29 +0100
|
||||
Subject: [PATCH] Disable docs check
|
||||
|
||||
This fails if we're disabling qrtr.
|
||||
---
|
||||
docs/reference/libqmi-glib/meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/docs/reference/libqmi-glib/meson.build b/docs/reference/libqmi-glib/meson.build
|
||||
index c07454a..54b4262 100644
|
||||
--- a/docs/reference/libqmi-glib/meson.build
|
||||
+++ b/docs/reference/libqmi-glib/meson.build
|
||||
@@ -77,5 +77,5 @@ gnome.gtkdoc(
|
||||
fixxref_args: fixxref_args,
|
||||
content_files: [sections_txt, version_xml],
|
||||
install: true,
|
||||
- check: true,
|
||||
+ check: false,
|
||||
)
|
||||
--
|
||||
2.38.1
|
||||
|
@ -1,20 +1,30 @@
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 9
|
||||
%bcond_without qrtr
|
||||
%else
|
||||
%bcond_with qrtr
|
||||
%endif
|
||||
|
||||
Name: libqmi
|
||||
Version: 1.30.2
|
||||
Release: 1%{?dist}
|
||||
Version: 1.32.2
|
||||
Release: 3%{?dist}
|
||||
Summary: Support library to use the Qualcomm MSM Interface (QMI) protocol
|
||||
License: LGPLv2+
|
||||
URL: http://freedesktop.org/software/libqmi
|
||||
Source: http://freedesktop.org/software/libqmi/%{name}-%{version}.tar.xz
|
||||
Source: https://gitlab.freedesktop.org/mobile-broadband/libqmi/-/archive/%{version}/%{name}-%{version}.tar.bz2
|
||||
Patch0: 0001-Disable-docs-check.patch
|
||||
|
||||
BuildRequires: meson >= 0.53
|
||||
BuildRequires: gcc
|
||||
BuildRequires: glib2-devel >= 2.48.0
|
||||
BuildRequires: glib2-devel >= 2.56
|
||||
BuildRequires: gobject-introspection-devel
|
||||
BuildRequires: gtk-doc
|
||||
BuildRequires: pkgconfig(gudev-1.0) >= 147
|
||||
BuildRequires: libmbim-devel >= 1.18.0
|
||||
#BuildRequires: libqrtr-glib-devel
|
||||
BuildRequires: make
|
||||
%if %{with qrtr}
|
||||
BuildRequires: libqrtr-glib-devel
|
||||
%endif
|
||||
BuildRequires: python3
|
||||
BuildRequires: help2man
|
||||
|
||||
%description
|
||||
This package contains the libraries that make it easier to use QMI functionality
|
||||
@ -24,7 +34,7 @@ from applications that use glib.
|
||||
%package devel
|
||||
Summary: Header files for adding QMI support to applications that use glib
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: glib2-devel
|
||||
Requires: glib2-devel%{?_isa}
|
||||
Requires: pkgconfig
|
||||
|
||||
%description devel
|
||||
@ -47,14 +57,29 @@ from the command line.
|
||||
|
||||
|
||||
%build
|
||||
%configure --disable-static --enable-gtk-doc --enable-mbim-qmux
|
||||
%{make_build} V=1
|
||||
# Let's avoid BuildRequiring bash-completion because it changes behavior
|
||||
# of shell, at least until the .pc file gets into the -devel subpackage.
|
||||
# We'll just install the bash-completion file ourselves.
|
||||
%meson -Dgtk_doc=true -Dbash_completion=false \
|
||||
%if %{with qrtr}
|
||||
-Dqrtr=true
|
||||
%else
|
||||
-Dqrtr=false
|
||||
%endif
|
||||
%meson_build
|
||||
%ninja_build -C %{_vpath_builddir} libqmi-glib-doc
|
||||
|
||||
|
||||
%install
|
||||
%make_install
|
||||
find %{buildroot}%{_datadir}/gtk-doc |xargs touch --reference configure.ac
|
||||
%meson_install
|
||||
find %{buildroot}%{_datadir}/gtk-doc |xargs touch --reference meson.build
|
||||
find %{buildroot} -type f -name "*.la" -delete
|
||||
mkdir -p %{buildroot}%{_datadir}/bash-completion
|
||||
cp -a src/qmicli/qmicli %{buildroot}%{_datadir}/bash-completion
|
||||
|
||||
|
||||
%check
|
||||
%meson_test
|
||||
|
||||
|
||||
%ldconfig_scriptlets
|
||||
@ -62,7 +87,7 @@ find %{buildroot} -type f -name "*.la" -delete
|
||||
|
||||
%files
|
||||
%license COPYING.LIB
|
||||
%doc NEWS AUTHORS README
|
||||
%doc NEWS AUTHORS README.md
|
||||
%{_libdir}/libqmi-glib.so.*
|
||||
%{_libdir}/girepository-1.0/Qmi-1.0.typelib
|
||||
|
||||
@ -86,6 +111,10 @@ find %{buildroot} -type f -name "*.la" -delete
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Dec 12 2022 Lubomir Rintel <lkundrak@v3.sk> - 1.32.2-3
|
||||
- Update to 1.32.2
|
||||
- Build without QRTR
|
||||
|
||||
* Fri Oct 1 2021 Ana Cabral <acabral@redhat.com> - 1.30.2-1
|
||||
- Upgrade to 1.30.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user