1.0-1 - Update to libqb-1.0
...for list of changes see, in order: https://github.com/ClusterLabs/libqb/releases/tag/v1.0rc1 https://github.com/ClusterLabs/libqb/releases/tag/v1.0rc2 https://github.com/ClusterLabs/libqb/releases/tag/v1.0rc3 https://github.com/ClusterLabs/libqb/releases/tag/v1.0rc4 https://github.com/ClusterLabs/libqb/releases/tag/v1.0 - Adapt spec file per the upstream version (drop defattr statements, autogen.sh call with %build, conditionalize build process) - Add gcc as an explicit BuildRequires (required per the new guidelines) - Do not depend on the rpmbuild-imposed man page archiving method Signed-off-by: Jan Pokorný <jpokorny@redhat.com>
This commit is contained in:
parent
75d665761f
commit
f69746a56d
@ -1,42 +0,0 @@
|
||||
From aec4cde4312ada559888371554b0ae862cf91b9a Mon Sep 17 00:00:00 2001
|
||||
From: Christine Caulfield <ccaulfie@redhat.com>
|
||||
Date: Fri, 11 Sep 2015 09:16:52 +0100
|
||||
Subject: [PATCH] Fix check_ipc tests so they exit correctly
|
||||
|
||||
On some platforms the check_ipc test can fail due to SIGTERM
|
||||
being delivered to to exiting server process. There is a race
|
||||
condition between the server main loop quitting and the
|
||||
signal being delivered.
|
||||
|
||||
This patch closes that race loophole in two places, firstly
|
||||
it makes SIGTERM/SIGSTOP exit immediately rather than just signalling
|
||||
the mainloop, secondly it calls exit() rather than return when the server
|
||||
mainloop completes to that the client code does not start executing!
|
||||
|
||||
Signed-off-by: Christine Caulfield <ccaulfie@redhat.com>
|
||||
---
|
||||
tests/check_ipc.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tests/check_ipc.c b/tests/check_ipc.c
|
||||
index 4397963..26985df 100644
|
||||
--- a/tests/check_ipc.c
|
||||
+++ b/tests/check_ipc.c
|
||||
@@ -102,7 +102,7 @@ exit_handler(int32_t rsignal, void *data)
|
||||
{
|
||||
qb_log(LOG_DEBUG, "caught signal %d", rsignal);
|
||||
qb_ipcs_destroy(s1);
|
||||
- return -1;
|
||||
+ exit(0);
|
||||
}
|
||||
|
||||
static void
|
||||
@@ -424,7 +424,7 @@ run_function_in_new_process(void (*run_ipc_server_fn)(void))
|
||||
|
||||
if (pid == 0) {
|
||||
run_ipc_server_fn();
|
||||
- return 0;
|
||||
+ exit(0);
|
||||
}
|
||||
return pid;
|
||||
}
|
38
libqb.spec
38
libqb.spec
@ -1,15 +1,19 @@
|
||||
%bcond_without check
|
||||
%bcond_without syslog_tests
|
||||
|
||||
Name: libqb
|
||||
Version: 0.17.2
|
||||
Release: 2%{?dist}
|
||||
Version: 1.0
|
||||
Release: 1%{?dist}
|
||||
Summary: An IPC library for high performance servers
|
||||
|
||||
Group: System Environment/Libraries
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/ClusterLabs/libqb
|
||||
Source0: https://fedorahosted.org/releases/q/u/quarterback/%{name}-%{version}.tar.xz
|
||||
Patch1: https://github.com/ClusterLabs/libqb/commit/aec4cde4312ada559888371554b0ae862cf91b9a.patch
|
||||
Source0: https://github.com/ClusterLabs/libqb/releases/download/v%{version}/%{name}-%{version}.tar.xz
|
||||
|
||||
BuildRequires: autoconf automake libtool doxygen procps check-devel
|
||||
# https://fedoraproject.org/wiki/Packaging:C_and_C%2B%2B#BuildRequires_and_Requires
|
||||
BuildRequires: gcc
|
||||
|
||||
%description
|
||||
libqb provides high-performance, reusable features for client-server
|
||||
@ -19,15 +23,19 @@ and polling.
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
# Make sure the timestamps are correct
|
||||
find . -exec touch \{\} \;
|
||||
## Make sure the timestamps are correct
|
||||
#find . -exec touch \{\} \;
|
||||
|
||||
%build
|
||||
%configure --disable-static
|
||||
./autogen.sh
|
||||
%configure --disable-static \
|
||||
%{?with_syslog_tests:--enable-syslog-tests}
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%if 0%{?with_check}
|
||||
%check
|
||||
make -j1 check
|
||||
%endif
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
@ -39,7 +47,6 @@ rm -rf $RPM_BUILD_ROOT/%{_docdir}/*
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%license COPYING
|
||||
%{_sbindir}/qb-blackbox
|
||||
%{_libdir}/libqb.so.*
|
||||
@ -54,16 +61,27 @@ The %{name}-devel package contains libraries and header files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%doc README.markdown
|
||||
%license COPYING
|
||||
%{_includedir}/qb/
|
||||
%{_libdir}/libqb.so
|
||||
%{_libdir}/pkgconfig/libqb.pc
|
||||
%{_mandir}/man3/qb*3*
|
||||
%{_mandir}/man8/qb-blackbox.8.gz
|
||||
%{_mandir}/man8/qb-blackbox.8*
|
||||
|
||||
%changelog
|
||||
* Mon Apr 4 2016 Jan Pokorný <jpokorny+rpm-libqb@redhat.com> - 1.0-1
|
||||
- Update to libqb-1.0, for list of changes see, in order:
|
||||
https://github.com/ClusterLabs/libqb/releases/tag/v1.0rc1
|
||||
https://github.com/ClusterLabs/libqb/releases/tag/v1.0rc2
|
||||
https://github.com/ClusterLabs/libqb/releases/tag/v1.0rc3
|
||||
https://github.com/ClusterLabs/libqb/releases/tag/v1.0rc4
|
||||
https://github.com/ClusterLabs/libqb/releases/tag/v1.0
|
||||
- Adapt spec file per the upstream version (drop defattr statements,
|
||||
autogen.sh call with %build, conditionalize build process)
|
||||
- Add gcc as an explicit BuildRequires (required per the new guidelines)
|
||||
- Do not depend on the rpmbuild-imposed man page archiving method
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user