Fix tests (missing ";")
Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
This commit is contained in:
parent
0c48cf156c
commit
e59e59c0d4
35
0001-TEST-fix-typo-s-in-check_ipc.c.patch
Normal file
35
0001-TEST-fix-typo-s-in-check_ipc.c.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From 25828196a0862118a013c00efe1e63e5831da6d4 Mon Sep 17 00:00:00 2001
|
||||
From: Angus Salkeld <asalkeld@redhat.com>
|
||||
Date: Mon, 29 Oct 2012 11:54:23 +1100
|
||||
Subject: [PATCH] TEST: fix typo s/,/; in check_ipc.c
|
||||
|
||||
Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
|
||||
---
|
||||
tests/check_ipc.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tests/check_ipc.c b/tests/check_ipc.c
|
||||
index c396d61..09ad619 100644
|
||||
--- a/tests/check_ipc.c
|
||||
+++ b/tests/check_ipc.c
|
||||
@@ -620,7 +620,7 @@ test_ipc_bulk_events(void)
|
||||
|
||||
events_received = 0;
|
||||
cl = qb_loop_create();
|
||||
- res = qb_ipcc_fd_get(conn, &fd),
|
||||
+ res = qb_ipcc_fd_get(conn, &fd);
|
||||
ck_assert_int_eq(res, 0);
|
||||
res = qb_loop_poll_add(cl, QB_LOOP_MED,
|
||||
fd, POLLIN,
|
||||
@@ -692,7 +692,7 @@ test_ipc_event_on_created(void)
|
||||
|
||||
events_received = 0;
|
||||
cl = qb_loop_create();
|
||||
- res = qb_ipcc_fd_get(conn, &fd),
|
||||
+ res = qb_ipcc_fd_get(conn, &fd);
|
||||
ck_assert_int_eq(res, 0);
|
||||
res = qb_loop_poll_add(cl, QB_LOOP_MED,
|
||||
fd, POLLIN,
|
||||
--
|
||||
1.7.11.7
|
||||
|
11
libqb.spec
11
libqb.spec
@ -1,6 +1,6 @@
|
||||
Name: libqb
|
||||
Version: 0.14.3
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: An IPC library for high performance servers
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -9,7 +9,7 @@ URL: http://www.libqb.org
|
||||
Source0: https://fedorahosted.org/releases/q/u/quarterback/%{name}-%{version}.tar.xz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
#Patch1:
|
||||
Patch1: 0001-TEST-fix-typo-s-in-check_ipc.c.patch
|
||||
|
||||
BuildRequires: libtool doxygen procps check-devel automake
|
||||
|
||||
@ -22,11 +22,10 @@ Initially these are IPC and poll.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
#%patch1 -p1
|
||||
%patch1 -p1
|
||||
|
||||
# work-around for broken epoll in rawhide/f17
|
||||
%build
|
||||
./autogen.sh
|
||||
%configure --disable-static ac_cv_func_epoll_create1=no ac_cv_func_epoll_create=no
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -72,6 +71,10 @@ developing applications that use %{name}.
|
||||
|
||||
%changelog
|
||||
|
||||
* Mon Oct 29 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.3-2
|
||||
Fix test code highlighted by new check version
|
||||
Remove the call to autogen.sh - not needed anymore.
|
||||
|
||||
* Mon Oct 29 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.3-1
|
||||
IPC: Pass the timeout to poll() if the recv function returns EAGAIN
|
||||
LOG: make the format comparison safe and sane
|
||||
|
Loading…
Reference in New Issue
Block a user