Rebase to 0.9.0 to get bug fixes
Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
This commit is contained in:
parent
9bd8c740ca
commit
b1e84265cd
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/libqb-0.6.0.tar.gz
|
||||
/libqb-0.7.0.tar.gz
|
||||
/libqb-0.8.1.tar.xz
|
||||
/libqb-0.9.0.tar.xz
|
||||
|
@ -1,31 +0,0 @@
|
||||
From ef64fd1186979bae8eee2babb04d9b5b29d3099b Mon Sep 17 00:00:00 2001
|
||||
From: Angus Salkeld <asalkeld@redhat.com>
|
||||
Date: Mon, 9 Jan 2012 10:24:08 +1100
|
||||
Subject: [PATCH] UTIL: fix qb_timespec_add_ms()
|
||||
|
||||
It was overwriting the timespec value instead of
|
||||
add to it.
|
||||
|
||||
Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
|
||||
---
|
||||
lib/util.c | 4 ++--
|
||||
1 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/lib/util.c b/lib/util.c
|
||||
index 51c94bb..6b835cc 100644
|
||||
--- a/lib/util.c
|
||||
+++ b/lib/util.c
|
||||
@@ -126,8 +126,8 @@ void
|
||||
qb_timespec_add_ms(struct timespec *ts, int32_t ms)
|
||||
{
|
||||
#ifndef S_SPLINT_S
|
||||
- ts->tv_sec = ms / 1000;
|
||||
- ts->tv_nsec = (ms % 1000) * QB_TIME_NS_IN_MSEC;
|
||||
+ ts->tv_sec += ms / 1000;
|
||||
+ ts->tv_nsec += (ms % 1000) * QB_TIME_NS_IN_MSEC;
|
||||
if (ts->tv_nsec >= 1000000000L) {
|
||||
ts->tv_sec++;
|
||||
ts->tv_nsec = ts->tv_nsec - 1000000000L;
|
||||
--
|
||||
1.7.7.5
|
||||
|
11
libqb.spec
11
libqb.spec
@ -1,6 +1,6 @@
|
||||
Name: libqb
|
||||
Version: 0.8.1
|
||||
Release: 2%{?dist}
|
||||
Version: 0.9.0
|
||||
Release: 1%{?dist}
|
||||
Summary: An IPC library for high performance servers
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -9,7 +9,7 @@ URL: http://www.libqb.org
|
||||
Source0: https://fedorahosted.org/releases/q/u/quarterback/%{name}-%{version}.tar.xz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch1: 0001-UTIL-fix-qb_timespec_add_ms.patch
|
||||
#Patch1:
|
||||
|
||||
BuildRequires: libtool doxygen procps check-devel
|
||||
|
||||
@ -22,7 +22,7 @@ Initially these are IPC and poll.
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1
|
||||
#%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure --disable-static
|
||||
@ -67,6 +67,9 @@ developing applications that use %{name}.
|
||||
%{_mandir}/man3/qb*3*
|
||||
|
||||
%changelog
|
||||
* Fri Jan 27 2012 Angus Salkeld <asalkeld@redhat.com> - 0.9.0-1
|
||||
- Rebased to 0.9.0
|
||||
|
||||
* Tue Jan 10 2012 Angus Salkeld <asalkeld@redhat.com> - 0.8.1-2
|
||||
- fix qb_timespec_add_ms()
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user