Update to latest upstream version
Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
This commit is contained in:
parent
58cf080c07
commit
a817575f3b
@ -1,35 +0,0 @@
|
|||||||
From 25828196a0862118a013c00efe1e63e5831da6d4 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Angus Salkeld <asalkeld@redhat.com>
|
|
||||||
Date: Mon, 29 Oct 2012 11:54:23 +1100
|
|
||||||
Subject: [PATCH] TEST: fix typo s/,/; in check_ipc.c
|
|
||||||
|
|
||||||
Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
|
|
||||||
---
|
|
||||||
tests/check_ipc.c | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tests/check_ipc.c b/tests/check_ipc.c
|
|
||||||
index c396d61..09ad619 100644
|
|
||||||
--- a/tests/check_ipc.c
|
|
||||||
+++ b/tests/check_ipc.c
|
|
||||||
@@ -620,7 +620,7 @@ test_ipc_bulk_events(void)
|
|
||||||
|
|
||||||
events_received = 0;
|
|
||||||
cl = qb_loop_create();
|
|
||||||
- res = qb_ipcc_fd_get(conn, &fd),
|
|
||||||
+ res = qb_ipcc_fd_get(conn, &fd);
|
|
||||||
ck_assert_int_eq(res, 0);
|
|
||||||
res = qb_loop_poll_add(cl, QB_LOOP_MED,
|
|
||||||
fd, POLLIN,
|
|
||||||
@@ -692,7 +692,7 @@ test_ipc_event_on_created(void)
|
|
||||||
|
|
||||||
events_received = 0;
|
|
||||||
cl = qb_loop_create();
|
|
||||||
- res = qb_ipcc_fd_get(conn, &fd),
|
|
||||||
+ res = qb_ipcc_fd_get(conn, &fd);
|
|
||||||
ck_assert_int_eq(res, 0);
|
|
||||||
res = qb_loop_poll_add(cl, QB_LOOP_MED,
|
|
||||||
fd, POLLIN,
|
|
||||||
--
|
|
||||||
1.7.11.7
|
|
||||||
|
|
36
libqb.spec
36
libqb.spec
@ -1,6 +1,6 @@
|
|||||||
Name: libqb
|
Name: libqb
|
||||||
Version: 0.14.3
|
Version: 0.14.4
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: An IPC library for high performance servers
|
Summary: An IPC library for high performance servers
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -9,8 +9,6 @@ URL: http://www.libqb.org
|
|||||||
Source0: https://fedorahosted.org/releases/q/u/quarterback/%{name}-%{version}.tar.xz
|
Source0: https://fedorahosted.org/releases/q/u/quarterback/%{name}-%{version}.tar.xz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Patch1: 0001-TEST-fix-typo-s-in-check_ipc.c.patch
|
|
||||||
|
|
||||||
BuildRequires: libtool doxygen procps check-devel automake
|
BuildRequires: libtool doxygen procps check-devel automake
|
||||||
|
|
||||||
#Requires: <nothing>
|
#Requires: <nothing>
|
||||||
@ -22,8 +20,6 @@ Initially these are IPC and poll.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
# work-around for broken epoll in rawhide/f17
|
# work-around for broken epoll in rawhide/f17
|
||||||
%build
|
%build
|
||||||
%configure --disable-static ac_cv_func_epoll_create1=no ac_cv_func_epoll_create=no
|
%configure --disable-static ac_cv_func_epoll_create1=no ac_cv_func_epoll_create=no
|
||||||
@ -70,6 +66,34 @@ developing applications that use %{name}.
|
|||||||
%{_mandir}/man8/qb-blackbox.8.gz
|
%{_mandir}/man8/qb-blackbox.8.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 17 2013 Angus Salkeld <asalkeld@redhat.com> - 0.14.4-1
|
||||||
|
LOG: prevent the last char of the blackbox message from getting lost.
|
||||||
|
Example: make the blackbox example more practical.
|
||||||
|
Add the processing which remove notifier at skiplist_destroy function
|
||||||
|
Add the processing which remove hash node and notifier at hashtable_destroy function
|
||||||
|
Unify to QB_TRUE/QB_FALSE a boolean value
|
||||||
|
Document the default prefix in INSTALL
|
||||||
|
Unify the list processing with qb_list function
|
||||||
|
Add travis link to the readme.
|
||||||
|
Fix return code which is an error occurred at pthread function
|
||||||
|
TEST: add a progam to compare the speed of vsnprintf and qb_vsnprintf_serialize
|
||||||
|
LOG: add a test for a padded hex int.
|
||||||
|
Fedora's splint has a strange syntax error, don't fail on it.
|
||||||
|
LOG: fix truncation in some messages that get padded.
|
||||||
|
Fix the blackbox formatter when specifing the string len/precision
|
||||||
|
Fix strlcpy and strlcat functions
|
||||||
|
IPC: don't over log on disconnect
|
||||||
|
Make sure we don't use the format string whilst it is getting changed.
|
||||||
|
ptrie: deref the current node in trie_iter_free()
|
||||||
|
LOG: fix the format comparison to avoid generating multiple entries.
|
||||||
|
LOG: set the return code when calloc fails
|
||||||
|
IPC: call poll if we are mid message and get EAGAIN
|
||||||
|
Remove extra ";"
|
||||||
|
IPC: set the error more correctly when qb_sys_mmap_file_open() fails.
|
||||||
|
Make sure that mmap'ed files smaller than a page size are written to.
|
||||||
|
example/test: check for error in qb_ipc_run()
|
||||||
|
example: check for error in qb_ipc_run()
|
||||||
|
TEST: fix typo s/,/; in check_ipc.c
|
||||||
|
|
||||||
* Mon Oct 29 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.3-2
|
* Mon Oct 29 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.3-2
|
||||||
Fix test code highlighted by new check version
|
Fix test code highlighted by new check version
|
||||||
|
Loading…
Reference in New Issue
Block a user