Rebase to upstream v0.14.2
Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
This commit is contained in:
parent
6963e2b20c
commit
84babc25cd
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@
|
|||||||
/libqb-0.13.0.tar.xz
|
/libqb-0.13.0.tar.xz
|
||||||
/libqb-0.14.0.tar.xz
|
/libqb-0.14.0.tar.xz
|
||||||
/libqb-0.14.1.tar.xz
|
/libqb-0.14.1.tar.xz
|
||||||
|
/libqb-0.14.2.tar.xz
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index 4a4dd0a..10981e4 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -11,7 +11,7 @@ AC_CONFIG_SRCDIR([lib/ringbuffer.c])
|
|
||||||
AC_CONFIG_HEADERS([include/config.h include/qb/qbconfig.h])
|
|
||||||
AC_USE_SYSTEM_EXTENSIONS
|
|
||||||
|
|
||||||
-AM_INIT_AUTOMAKE([-Wno-portability dist-xz color-tests parallel-tests])
|
|
||||||
+AM_INIT_AUTOMAKE([-Wno-portability dist-xz])
|
|
||||||
dnl automake >= 1.11 offers --enable-silent-rules for suppressing the output from
|
|
||||||
dnl normal compilation. When a failure occurs, it will then display the full
|
|
||||||
dnl command line
|
|
51
libqb.spec
51
libqb.spec
@ -1,5 +1,5 @@
|
|||||||
Name: libqb
|
Name: libqb
|
||||||
Version: 0.14.1
|
Version: 0.14.2
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: An IPC library for high performance servers
|
Summary: An IPC library for high performance servers
|
||||||
|
|
||||||
@ -9,8 +9,6 @@ URL: http://www.libqb.org
|
|||||||
Source0: https://fedorahosted.org/releases/q/u/quarterback/%{name}-%{version}.tar.xz
|
Source0: https://fedorahosted.org/releases/q/u/quarterback/%{name}-%{version}.tar.xz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Patch1: 0000-test-with-output.patch
|
|
||||||
|
|
||||||
BuildRequires: libtool doxygen procps check-devel automake
|
BuildRequires: libtool doxygen procps check-devel automake
|
||||||
|
|
||||||
#Requires: <nothing>
|
#Requires: <nothing>
|
||||||
@ -22,8 +20,6 @@ Initially these are IPC and poll.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
# work-around for broken epoll in rawhide/f17
|
# work-around for broken epoll in rawhide/f17
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
@ -71,6 +67,51 @@ developing applications that use %{name}.
|
|||||||
%{_mandir}/man8/qb-blackbox.8.gz
|
%{_mandir}/man8/qb-blackbox.8.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
|
||||||
|
* Mon Sep 10 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.2-1
|
||||||
|
Get libqb building on cygwin.
|
||||||
|
ipc_us: slightly more robust cmsg handling
|
||||||
|
ipc_us: on Linux, set SO_PASSCRED on the sending socket too
|
||||||
|
ipc_us: clear request unused fields
|
||||||
|
TEST: Include writing and reading the blackbox in the log_long_msg test
|
||||||
|
LOG: fix qb_vsnprintf_deserialize()
|
||||||
|
blackbox: fix 64-bit big-endian issues
|
||||||
|
Remove IPC_NEEDS_RESPONSE_ACK and turn off shm ipc on solaris
|
||||||
|
Define unix path max for openbsd
|
||||||
|
Only turn on ipc_needs_response_ack=yes for solaris
|
||||||
|
Some improvements to kqueue usage.
|
||||||
|
kqueue: drop log message to trace.
|
||||||
|
Fix splint warning
|
||||||
|
openbsd requires netinet/in.h before arpa/inet.h
|
||||||
|
Avoid strcpy() use strlcpy() instead.
|
||||||
|
Fix kqueue complile warnings
|
||||||
|
openbsd doesn't have EBADMSG
|
||||||
|
openbsd has a different UNIX_PATH_MAX
|
||||||
|
LOG: change qb_vsprintf_serialize() into qb_vsnprintf_serialize()
|
||||||
|
TEST: increase timeout to 6 secs as the recv timeout is 5 secs
|
||||||
|
TEST: get the logic right - grrr.
|
||||||
|
Turn off attribute_section on netbsd
|
||||||
|
Some missing pshared semaphore checks
|
||||||
|
Cleanup the checks for pshared semaphores
|
||||||
|
Add a config check for pthread_mutexattr_setpshared
|
||||||
|
Remove uses of timersub and use qb_util_stopwatch
|
||||||
|
RB: change the #error to ENOTSUP if no usable shared process sem
|
||||||
|
LOOP-KQUEUE: fix reference before assignment.
|
||||||
|
build: fix libqb.pc creation and make maintainer-clean
|
||||||
|
LOG: Make sure the semaphores are initialized.
|
||||||
|
build: remove bashism in cc support check
|
||||||
|
Catch disconnected sockets on Solaris
|
||||||
|
Don't free rb->shared_hdr in qb_rb_create_from_file()
|
||||||
|
Check error return of qb_ipcs_uc_recv_and_auth()
|
||||||
|
Fix removal of automatically installed doc files when building rpms
|
||||||
|
Add the mailing list to the travis email notifications.
|
||||||
|
Work around debian not setting the arch path in splint.
|
||||||
|
Remove color-tests and parallel-tests automake options.
|
||||||
|
Add travis continuous integration config
|
||||||
|
LOG: Invoke custom log filter function if tag changes
|
||||||
|
tests/rbwriter: don't ignore write failure
|
||||||
|
ipcs: avoid use-after-free for size-0 || disconnect-request
|
||||||
|
|
||||||
* Wed Jul 18 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.1-1
|
* Wed Jul 18 2012 Angus Salkeld <asalkeld@redhat.com> - 0.14.1-1
|
||||||
RB: set the new read pointer after clearing the header (#839605).
|
RB: set the new read pointer after clearing the header (#839605).
|
||||||
RB: improve the debug print outs
|
RB: improve the debug print outs
|
||||||
|
Loading…
Reference in New Issue
Block a user