Rebase to 0.10.1 to get fix for #788742
Signed-off-by: Angus Salkeld <asalkeld@redhat.com>
This commit is contained in:
parent
39294f20ae
commit
683368af96
1
.gitignore
vendored
1
.gitignore
vendored
@ -6,3 +6,4 @@
|
||||
/libqb-0.8.1.tar.xz
|
||||
/libqb-0.9.0.tar.xz
|
||||
/libqb-0.10.0.tar.xz
|
||||
/libqb-0.10.1.tar.xz
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/tests/check_loop.c b/tests/check_loop.c
|
||||
index eb79a51..b67df76 100644
|
||||
--- a/tests/check_loop.c
|
||||
+++ b/tests/check_loop.c
|
||||
@@ -210,7 +210,7 @@ START_TEST(test_job_rate_limit)
|
||||
* and cause cpu spin. We are going to say that a spin is more than
|
||||
* one job per 50ms if there is only one job pending in the loop.
|
||||
*/
|
||||
- _ck_assert_int(job_1_run_count, <, (RATE_LIMIT_RUNTIME_SEC * (QB_TIME_MS_IN_SEC/50)) + 1);
|
||||
+ _ck_assert_int(job_1_run_count, <, (RATE_LIMIT_RUNTIME_SEC * (QB_TIME_MS_IN_SEC/50)) + 5);
|
||||
qb_loop_destroy(l);
|
||||
qb_util_stopwatch_free(rl_sw);
|
||||
}
|
23
libqb.spec
23
libqb.spec
@ -1,5 +1,5 @@
|
||||
Name: libqb
|
||||
Version: 0.10.0
|
||||
Version: 0.10.1
|
||||
Release: 1%{?dist}
|
||||
Summary: An IPC library for high performance servers
|
||||
|
||||
@ -10,7 +10,6 @@ Source0: https://fedorahosted.org/releases/q/u/quarterback/%{name}-%{vers
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Patch1: 0000-test-with-output.patch
|
||||
Patch2: 0001-fix-loop-test.patch
|
||||
|
||||
BuildRequires: libtool doxygen procps check-devel automake
|
||||
|
||||
@ -24,7 +23,6 @@ Initially these are IPC and poll.
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
@ -70,6 +68,25 @@ developing applications that use %{name}.
|
||||
%{_mandir}/man3/qb*3*
|
||||
|
||||
%changelog
|
||||
* Tue Feb 14 2012 Angus Salkeld <asalkeld@redhat.com> - 0.10.1-1
|
||||
- Fix "make distcheck" add include path to AM_CPPFLAGS
|
||||
- Bump the version to 0.10.1
|
||||
- clang: Remove unused code
|
||||
- TEST: make the ipc failure test closer to corosync's case.
|
||||
- RB: add a debug message if trying to read a message of the wrong size
|
||||
- IPC: split up the recv into chuncks of 2 seconds. (#788742)
|
||||
- Be more consistent with the internal logs.
|
||||
- LOOP: make it possible to pass in NULL as the default loop instance
|
||||
- RB: use the proper struct not the typedef in the implementation.
|
||||
- RB: Fix potential mem leak
|
||||
- Don't mix enums (QB_TRUE/TRUE)
|
||||
- use random() not rand()
|
||||
- Remove dead code
|
||||
- set umask before calling mkstemp()
|
||||
- Use safer versions of string functions (strcpy -> strlcpy)
|
||||
- Increase the coverity aggressiveness
|
||||
- TEST: make the loop ratelimit test more forgiving.
|
||||
|
||||
* Tue Feb 07 2012 Angus Salkeld <asalkeld@redhat.com> - 0.10.0-1
|
||||
- LOOP: handle errors from the poll function
|
||||
- LOOP: make the item type applicable to jobs too.
|
||||
|
Loading…
Reference in New Issue
Block a user