Update to 0.3.0
This commit is contained in:
parent
d746922580
commit
37c6477ef3
@ -1 +1 @@
|
|||||||
libproxy-0.2.3.tar.gz
|
libproxy-0.3.0.tar.gz
|
||||||
|
@ -1 +1,2 @@
|
|||||||
libproxy-0_2_3-8_fc10:HEAD:libproxy-0.2.3-8.fc10.src.rpm:1232723319
|
libproxy-0_2_3-8_fc10:HEAD:libproxy-0.2.3-8.fc10.src.rpm:1232723319
|
||||||
|
libproxy-0_3_0-1_fc12:HEAD:libproxy-0.3.0-1.fc12.src.rpm:1255986871
|
||||||
|
@ -1,59 +0,0 @@
|
|||||||
diff -up libproxy-0.2.3/configure.dbus libproxy-0.2.3/configure
|
|
||||||
--- libproxy-0.2.3/configure.dbus 2008-07-11 12:13:12.000000000 +0200
|
|
||||||
+++ libproxy-0.2.3/configure 2008-07-11 12:13:24.000000000 +0200
|
|
||||||
@@ -20408,12 +20408,12 @@ if test -n "$NetworkManager_CFLAGS"; the
|
|
||||||
pkg_cv_NetworkManager_CFLAGS="$NetworkManager_CFLAGS"
|
|
||||||
elif test -n "$PKG_CONFIG"; then
|
|
||||||
if test -n "$PKG_CONFIG" && \
|
|
||||||
- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"NetworkManager\"") >&5
|
|
||||||
- ($PKG_CONFIG --exists --print-errors "NetworkManager") 2>&5
|
|
||||||
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"NetworkManager dbus-1\"") >&5
|
|
||||||
+ ($PKG_CONFIG --exists --print-errors "NetworkManager dbus-1") 2>&5
|
|
||||||
ac_status=$?
|
|
||||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
||||||
(exit $ac_status); }; then
|
|
||||||
- pkg_cv_NetworkManager_CFLAGS=`$PKG_CONFIG --cflags "NetworkManager" 2>/dev/null`
|
|
||||||
+ pkg_cv_NetworkManager_CFLAGS=`$PKG_CONFIG --cflags "NetworkManager dbus-1" 2>/dev/null`
|
|
||||||
else
|
|
||||||
pkg_failed=yes
|
|
||||||
fi
|
|
||||||
@@ -20424,12 +20424,12 @@ if test -n "$NetworkManager_LIBS"; then
|
|
||||||
pkg_cv_NetworkManager_LIBS="$NetworkManager_LIBS"
|
|
||||||
elif test -n "$PKG_CONFIG"; then
|
|
||||||
if test -n "$PKG_CONFIG" && \
|
|
||||||
- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"NetworkManager\"") >&5
|
|
||||||
- ($PKG_CONFIG --exists --print-errors "NetworkManager") 2>&5
|
|
||||||
+ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"NetworkManager dbus-1\"") >&5
|
|
||||||
+ ($PKG_CONFIG --exists --print-errors "NetworkManager dbus-1") 2>&5
|
|
||||||
ac_status=$?
|
|
||||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
||||||
(exit $ac_status); }; then
|
|
||||||
- pkg_cv_NetworkManager_LIBS=`$PKG_CONFIG --libs "NetworkManager" 2>/dev/null`
|
|
||||||
+ pkg_cv_NetworkManager_LIBS=`$PKG_CONFIG --libs "NetworkManager dbus-1" 2>/dev/null`
|
|
||||||
else
|
|
||||||
pkg_failed=yes
|
|
||||||
fi
|
|
||||||
@@ -20447,9 +20447,9 @@ else
|
|
||||||
_pkg_short_errors_supported=no
|
|
||||||
fi
|
|
||||||
if test $_pkg_short_errors_supported = yes; then
|
|
||||||
- NetworkManager_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "NetworkManager" 2>&1`
|
|
||||||
+ NetworkManager_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "NetworkManager dbus-1" 2>&1`
|
|
||||||
else
|
|
||||||
- NetworkManager_PKG_ERRORS=`$PKG_CONFIG --print-errors "NetworkManager" 2>&1`
|
|
||||||
+ NetworkManager_PKG_ERRORS=`$PKG_CONFIG --print-errors "NetworkManager dbus-1" 2>&1`
|
|
||||||
fi
|
|
||||||
# Put the nasty error message in config.log where it belongs
|
|
||||||
echo "$NetworkManager_PKG_ERRORS" >&5
|
|
||||||
diff -up libproxy-0.2.3/configure.ac.dbus libproxy-0.2.3/configure.ac
|
|
||||||
--- libproxy-0.2.3/configure.ac.dbus 2008-07-11 12:12:43.000000000 +0200
|
|
||||||
+++ libproxy-0.2.3/configure.ac 2008-07-11 12:12:58.000000000 +0200
|
|
||||||
@@ -19,7 +19,7 @@ PKG_CHECK_MODULES(webkit, webkit-1.0, ha
|
|
||||||
PKG_CHECK_MODULES(mozjs, xulrunner-js, have_mozjs=yes,
|
|
||||||
[PKG_CHECK_MODULES(mozjs, firefox-js, have_mozjs=yes,
|
|
||||||
[PKG_CHECK_MODULES(mozjs, mozilla-js, have_mozjs=yes, have_mozjs=no)])])
|
|
||||||
-PKG_CHECK_MODULES(NetworkManager, NetworkManager,
|
|
||||||
+PKG_CHECK_MODULES(NetworkManager, NetworkManager dbus-1,
|
|
||||||
have_networkmanager=yes, have_networkmanager=no)
|
|
||||||
|
|
||||||
# Environmental Variable
|
|
@ -3,15 +3,14 @@
|
|||||||
%define gecko_version 1.9.1
|
%define gecko_version 1.9.1
|
||||||
|
|
||||||
Name: libproxy
|
Name: libproxy
|
||||||
Version: 0.2.3
|
Version: 0.3.0
|
||||||
Release: 12%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A library handling all the details of proxy configuration
|
Summary: A library handling all the details of proxy configuration
|
||||||
|
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: http://code.google.com/p/libproxy/
|
URL: http://code.google.com/p/libproxy/
|
||||||
Source0: http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
|
Source0: http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
|
||||||
Patch0: libproxy-0.2.3-dbus.patch
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
@ -113,9 +112,7 @@ developing applications that use %{name}.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .dbus
|
|
||||||
touch -r configure.dbus configure
|
|
||||||
touch -r configure.ac.dbus configure.ac
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -181,6 +178,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 24 2009 kwizart < kwizart at gmail.com > - 0.3.0-1
|
||||||
|
- Update to 0.3.0
|
||||||
|
|
||||||
* Thu Sep 17 2009 kwizart < kwizart at gmail.com > - 0.2.3-12
|
* Thu Sep 17 2009 kwizart < kwizart at gmail.com > - 0.2.3-12
|
||||||
- Remove Requirement of %%{name}-pac virtual provides
|
- Remove Requirement of %%{name}-pac virtual provides
|
||||||
from the main package - #524043
|
from the main package - #524043
|
||||||
|
Loading…
Reference in New Issue
Block a user