Update to 0.5.5
Resolves: RHEL-32784
This commit is contained in:
parent
3bdabbe69d
commit
2ebcaa3d80
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
||||
/0.5.1.tar.gz
|
||||
/0.5.2.tar.gz
|
||||
/0.5.3.tar.gz
|
||||
/0.5.5.tar.gz
|
||||
|
@ -1,33 +0,0 @@
|
||||
From a1e6c95fe6b3eaf558274f5a6234d022b7da4002 Mon Sep 17 00:00:00 2001
|
||||
From: David King <amigadave@amigadave.com>
|
||||
Date: Thu, 2 Nov 2023 09:10:46 +0000
|
||||
Subject: [PATCH] Specify library version more completely
|
||||
|
||||
If the library version is not specified, meson installs the shared
|
||||
object using only the soversion, and tis causes ldconfig to emit a
|
||||
warning that the shared object is not a symlink. Specifying a version
|
||||
that matches the project version means that version is used for the
|
||||
shared object, and the soversion-named file is then a symilnk to that,
|
||||
which is common across other libraries, and avoids the warning from
|
||||
ldconfig.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=2247508
|
||||
---
|
||||
src/libproxy/meson.build | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/libproxy/meson.build b/src/libproxy/meson.build
|
||||
index 343b645..558719c 100644
|
||||
--- a/src/libproxy/meson.build
|
||||
+++ b/src/libproxy/meson.build
|
||||
@@ -29,6 +29,7 @@ libproxy = shared_library(
|
||||
link_args : vflag,
|
||||
link_depends : mapfile,
|
||||
soversion: '1',
|
||||
+ version: meson.project_version(),
|
||||
install: true,
|
||||
install_rpath: pkglibdir,
|
||||
)
|
||||
--
|
||||
2.41.0
|
||||
|
@ -3,16 +3,13 @@
|
||||
%global __requires_exclude ^(%{_privatelibs})$
|
||||
|
||||
Name: libproxy
|
||||
Version: 0.5.3
|
||||
Version: 0.5.5
|
||||
Release: %autorelease
|
||||
Summary: A library handling all the details of proxy configuration
|
||||
|
||||
License: LGPL-2.1-or-later
|
||||
URL: https://libproxy.github.io/libproxy/
|
||||
Source0: https://github.com/libproxy/%{name}/archive/refs/tags/%{version}.tar.gz
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2247508
|
||||
# https://github.com/libproxy/libproxy/pull/259
|
||||
Patch0: libproxy-0.5.3-library-version-symlink.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: meson
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (0.5.3.tar.gz) = 0fa4c677372afa76a9f143abb1472af1df85e1190425ec4168b98e575a9b9c9fe3dcc56062609da8ef266d56dfb153e7f7a1c15aed2d385003d9f3f421d08590
|
||||
SHA512 (0.5.5.tar.gz) = 101139fe6972c9b8b46a8bc5f5cea807649ad21e201a9cd7d532d2145c34eadc861d8039fc8a2bf129f364ddc99ffb1324ab8f19bb0b4b9e52eb0f6bd703c8a8
|
||||
|
Loading…
Reference in New Issue
Block a user