Update libproxy to 0.4.4:
- Removed install workarounds (fixed upstream) - Removed patches (fixed upstream) - Moved -python to noarch - Downgrade cmake requirement (upstream change) - Disabled perl bindings - Run tests
This commit is contained in:
parent
0f2352351c
commit
10d58e6061
@ -1 +1 @@
|
||||
libproxy-0.4.0.tar.gz
|
||||
libproxy-0.4.4.tar.gz
|
||||
|
@ -1,3 +1,4 @@
|
||||
libproxy-0_2_3-8_fc10:HEAD:libproxy-0.2.3-8.fc10.src.rpm:1232723319
|
||||
libproxy-0_3_0-1_fc12:HEAD:libproxy-0.3.0-1.fc12.src.rpm:1255986871
|
||||
libproxy-0_4_0-1_fc12:HEAD:libproxy-0.4.0-1.fc12.src.rpm:1269473814
|
||||
libproxy-0_4_4-1_fc13:HEAD:libproxy-0.4.4-1.fc13.src.rpm:1278188825
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up libproxy-0.4.0/libproxy/CMakeLists.txt.ldflags libproxy-0.4.0/libproxy/CMakeLists.txt
|
||||
--- libproxy-0.4.0/libproxy/CMakeLists.txt.ldflags 2010-02-25 21:29:54.000000000 +0100
|
||||
+++ libproxy-0.4.0/libproxy/CMakeLists.txt 2010-03-14 16:08:52.147990318 +0100
|
||||
@@ -58,7 +58,7 @@ if("${PKG_CONFIG_FOUND}")
|
||||
endif()
|
||||
endif()
|
||||
if(X11_FOUND)
|
||||
- px_check_modules(GNOME gconf-2.0)
|
||||
+ px_check_modules(GNOME gconf-2.0 gobject-2.0)
|
||||
find_package(KDE4)
|
||||
find_package(Qt4)
|
||||
if(KDE4_FOUND AND QT4_FOUND)
|
@ -1,12 +0,0 @@
|
||||
diff -up libproxy-0.4.0/bindings/CMakeLists.txt.pyarch libproxy-0.4.0/bindings/CMakeLists.txt
|
||||
--- libproxy-0.4.0/bindings/CMakeLists.txt.pyarch 2010-02-25 21:29:54.000000000 +0100
|
||||
+++ libproxy-0.4.0/bindings/CMakeLists.txt 2010-03-14 21:03:16.059831098 +0100
|
||||
@@ -3,7 +3,7 @@ find_package(PythonInterp)
|
||||
if(PYTHONINTERP_FOUND)
|
||||
execute_process(COMMAND
|
||||
${PYTHON_EXECUTABLE}
|
||||
- -c "import distutils.sysconfig ; print distutils.sysconfig.get_python_lib(plat_specific=1)"
|
||||
+ -c "import distutils.sysconfig ; print distutils.sysconfig.get_python_lib()"
|
||||
OUTPUT_VARIABLE pysitepkgdir
|
||||
OUTPUT_STRIP_TRAILING_WHITESPACE)
|
||||
install(FILES libproxy.py DESTINATION ${pysitepkgdir})
|
@ -3,20 +3,18 @@
|
||||
%global gecko_version 1.9.2
|
||||
|
||||
Name: libproxy
|
||||
Version: 0.4.0
|
||||
Release: 2%{?dist}
|
||||
Version: 0.4.4
|
||||
Release: 1%{?dist}
|
||||
Summary: A library handling all the details of proxy configuration
|
||||
|
||||
Group: System Environment/Libraries
|
||||
License: LGPLv2+
|
||||
URL: http://code.google.com/p/libproxy/
|
||||
Source0: http://libproxy.googlecode.com/files/libproxy-%{version}.tar.gz
|
||||
Patch0: libproxy-0.4-ldflags.patch
|
||||
Patch1: libproxy-0.4.0-pyarch.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: python-devel
|
||||
BuildRequires: cmake >= 2.8.0
|
||||
BuildRequires: cmake >= 2.6.0
|
||||
|
||||
# gnome
|
||||
BuildRequires: GConf2-devel
|
||||
@ -56,6 +54,7 @@ The %{name}-bin package contains the proxy binary for %{name}
|
||||
Summary: Binding for %{name} and python
|
||||
Group: System Environment/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
BuildArch: noarch
|
||||
|
||||
%description python
|
||||
The %{name}-python package contains the python binding for %{name}
|
||||
@ -93,7 +92,8 @@ Group: System Environment/Libraries
|
||||
Requires: %{name} = %{version}
|
||||
|
||||
%description networkmanager
|
||||
The %{name}-networkmanager package contains the %{name} plugin for networkmanager.
|
||||
The %{name}-networkmanager package contains the %{name} plugin
|
||||
for networkmanager.
|
||||
|
||||
%package webkit
|
||||
Summary: Plugin for %{name} and webkit
|
||||
@ -115,51 +115,27 @@ Requires: pkgconfig
|
||||
The %{name}-devel package contains libraries and header files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .ldflags
|
||||
%patch1 -p1 -b .pyarch
|
||||
sed -i -e 's|-Werror||' CMakeLists.txt
|
||||
|
||||
|
||||
%build
|
||||
%{cmake} \
|
||||
-Dmoduledir=%{_libdir}/%{name}/%{version}/modules \
|
||||
-DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
|
||||
-DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
|
||||
-DWITH_PERL=OFF \
|
||||
.
|
||||
make VERBOSE=1 %{?_smp_mflags}
|
||||
|
||||
|
||||
%check
|
||||
make test
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
|
||||
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
|
||||
|
||||
#Manual install for modules
|
||||
mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}/modules
|
||||
install -pm 0755 lib/libproxy.so $RPM_BUILD_ROOT%{_libdir}/libproxy.so.1.0.0
|
||||
ln -s libproxy.so.1.0.0 $RPM_BUILD_ROOT%{_libdir}/libproxy.so.1
|
||||
ln -s libproxy.so.1.0.0 $RPM_BUILD_ROOT%{_libdir}/libproxy.so
|
||||
for f in lib/*_*.so ; do
|
||||
install -pm 0755 ${f} \
|
||||
$RPM_BUILD_ROOT%{_libdir}/%{name}/%{version}/modules
|
||||
done
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT%{_libdir}/pkgconfig
|
||||
sed -e's|@prefix@|%{_prefix}|g' \
|
||||
-e's|@libdir@|%{_libdir}|g' \
|
||||
-e's|@includedir@|%{_includedir}|g' \
|
||||
-e's|@VERSION@|%{version}|g' \
|
||||
< libproxy/libproxy-1.0.pc.in \
|
||||
> $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libproxy-1.0.pc
|
||||
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
@ -184,6 +160,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%files gnome
|
||||
%defattr(-,root,root,-)
|
||||
%{_libdir}/%{name}/%{version}/modules/config_gnome.so
|
||||
%{_libexecdir}/pxgconf
|
||||
|
||||
%files kde
|
||||
%defattr(-,root,root,-)
|
||||
@ -206,15 +183,18 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_includedir}/proxy.h
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/libproxy-1.0.pc
|
||||
%{_datadir}/cmake/Modules/Findlibproxy.cmake
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jul 02 2010 Nicolas Chauvet <kwizart@gmail.com> - 0.4.0-2
|
||||
- rebuilt for webkitgtk
|
||||
|
||||
* Wed Mar 24 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 0.4.0-1
|
||||
- Update to 0.4.0
|
||||
- Switch to cmake
|
||||
* Sun Jun 13 2010 Nathaniel McCallum <nathaniel@natemccallum.com> - 0.4.4-1
|
||||
- Update to 0.4.4
|
||||
- Removed install workarounds (fixed upstream)
|
||||
- Removed patches (fixed upstream)
|
||||
- Moved -python to noarch
|
||||
- Downgrade cmake requirement (upstream change)
|
||||
- Disabled perl bindings
|
||||
- Run tests
|
||||
|
||||
* Thu Mar 11 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 0.3.1-4
|
||||
- Add missing libXmu-devel
|
||||
|
Loading…
Reference in New Issue
Block a user