Rebase to upstream release 12.1
Version: 12.1-1
This commit is contained in:
parent
18bf476fec
commit
edeb3b9559
@ -1,7 +1,3 @@
|
||||
The libpq package is supposed to be used for all the PostgreSQL modules
|
||||
available in RHEL 8, and ABI versioning will guarantee us that modular RPMs will
|
||||
depend on appropriate libpq ABI version (picked at build-time).
|
||||
|
||||
diff --git a/config/Makefile b/config/Makefile
|
||||
index 67e7998f55..86612a42c3 100644
|
||||
--- a/config/Makefile
|
||||
@ -16,7 +12,7 @@ index 67e7998f55..86612a42c3 100644
|
||||
$(MKDIR_P) '$(DESTDIR)$(pgxsdir)/config'
|
||||
diff --git a/config/build-exports-gnu-ld b/config/build-exports-gnu-ld
|
||||
new file mode 100755
|
||||
index 0000000000..bdcfb40d48
|
||||
index 0000000000..84c48e3ade
|
||||
--- /dev/null
|
||||
+++ b/config/build-exports-gnu-ld
|
||||
@@ -0,0 +1,41 @@
|
||||
@ -62,10 +58,10 @@ index 0000000000..bdcfb40d48
|
||||
+echo " *;"
|
||||
+close_block
|
||||
diff --git a/src/Makefile.shlib b/src/Makefile.shlib
|
||||
index 95b82a6dea..a7065d02a4 100644
|
||||
index 373d73caef..d5bd5468cd 100644
|
||||
--- a/src/Makefile.shlib
|
||||
+++ b/src/Makefile.shlib
|
||||
@@ -221,7 +221,7 @@ ifeq ($(PORTNAME), linux)
|
||||
@@ -231,7 +231,7 @@ ifeq ($(PORTNAME), linux)
|
||||
ifdef soname
|
||||
LINK.shared += -Wl,-soname,$(soname)
|
||||
endif
|
||||
@ -75,15 +71,15 @@ index 95b82a6dea..a7065d02a4 100644
|
||||
ifneq (,$(exports_file))
|
||||
LINK.shared += -Wl,--version-script=$(exports_file)
|
||||
diff --git a/src/interfaces/libpq/exports.txt b/src/interfaces/libpq/exports.txt
|
||||
index d6a38d0df8..29bebeac7e 100644
|
||||
index 7c808e5215..3631340b23 100644
|
||||
--- a/src/interfaces/libpq/exports.txt
|
||||
+++ b/src/interfaces/libpq/exports.txt
|
||||
@@ -171,4 +171,4 @@ PQsslAttributeNames 168
|
||||
@@ -171,7 +171,7 @@ PQsslAttributeNames 168
|
||||
PQsslAttribute 169
|
||||
PQsetErrorContextVisibility 170
|
||||
PQresultVerboseErrorMessage 171
|
||||
-PQencryptPasswordConn 172
|
||||
+PQencryptPasswordConn 172 10
|
||||
--
|
||||
2.17.0
|
||||
|
||||
PQresultMemorySize 173
|
||||
PQhostaddr 174
|
||||
PQgssEncInUse 175
|
21
libpq.spec
21
libpq.spec
@ -1,22 +1,22 @@
|
||||
%global majorversion 11
|
||||
%global majorversion 12
|
||||
%global obsoletes_version %( echo $(( %majorversion + 1 )) )
|
||||
|
||||
Summary: PostgreSQL client library
|
||||
Name: libpq
|
||||
Version: %{majorversion}.6
|
||||
Release: 2%{?dist}
|
||||
Version: %{majorversion}.1
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: PostgreSQL
|
||||
Url: http://www.postgresql.org/
|
||||
|
||||
Source0: https://ftp.postgresql.org/pub/source/v%version/postgresql-%version.tar.bz2
|
||||
Source1: https://ftp.postgresql.org/pub/source/v%version/postgresql-%version.tar.bz2.sha256
|
||||
Source0: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
|
||||
Source1: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
|
||||
|
||||
|
||||
# Comments for these patches are in the patch files.
|
||||
Patch1: libpq-10.3-rpm-pgsql.patch
|
||||
Patch2: libpq-10.3-var-run-socket.patch
|
||||
Patch3: libpq-10.4-symbol-versioning.patch
|
||||
Patch3: libpq-12.1-symbol-versioning.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: glibc-devel bison flex gawk
|
||||
@ -78,9 +78,11 @@ export SYMBOL_VERSION_PREFIX=RHPG_
|
||||
--datadir=%_datadir/pgsql
|
||||
|
||||
%global build_subdirs \\\
|
||||
src/include \\\
|
||||
src/common \\\
|
||||
src/port \\\
|
||||
src/interfaces/libpq \\\
|
||||
src/bin/pg_config \\\
|
||||
src/include
|
||||
src/bin/pg_config
|
||||
|
||||
for subdir in %build_subdirs; do
|
||||
%make_build -C "$subdir"
|
||||
@ -128,6 +130,9 @@ find_lang_bins %name-devel.lst pg_config
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Feb 04 2020 Patrik Novotný <panovotn@redhat.com> - 12.1-1
|
||||
- Rebase to upstream release 12.1
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 11.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (postgresql-11.6.tar.bz2) = de6833c0df8dbac7bc498ac573dc4c3645070d9bbdd6b5d89db3ef41e86e7fc19d5e6450aa46ee2a1392d86c33acf6b9364b2863caac49f45351a46647feecbd
|
||||
SHA512 (postgresql-11.6.tar.bz2.sha256) = cb462b2ed50c6cb1e6afe914cae9a6a47fb81bcca313b1489e36a61fa0b5fa884b201e81e105fb361f344b2ccd3e123267438513bf534276d9f629f6ac3a48ce
|
||||
SHA512 (postgresql-12.1.tar.bz2) = f45b1762fd60b6f7419305d108b7fc521e3a7afa833d3aacccba814465baf40d19f57ff9bf2909d726c4c94a1cd99a39f1aa8e45fd0364cdedbcbed36ff48caf
|
||||
SHA512 (postgresql-12.1.tar.bz2.sha256) = 275a72bb1e27c6ec4385722cd53d7244186885a402d613d1c6a45c1173154559791713dfbdf5af11b596a867cec7eb6be949c734badd3c458b0a9345b37bd899
|
||||
|
Loading…
Reference in New Issue
Block a user