import CS libpq-16.8-2.el10
This commit is contained in:
parent
58de4544e8
commit
9579f9c6c9
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/postgresql-13.20.tar.bz2
|
||||
postgresql-16.8.tar.bz2
|
||||
|
@ -1 +0,0 @@
|
||||
e56b335306a0dd446987c35dba655427dfcc325c SOURCES/postgresql-13.20.tar.bz2
|
@ -1,53 +0,0 @@
|
||||
Change the built-in default socket directory to be /var/run/postgresql.
|
||||
For backwards compatibility with (probably non-libpq-based) clients that
|
||||
might still expect to find the socket in /tmp, also create a socket in
|
||||
/tmp. This is to resolve communication problems with clients operating
|
||||
under systemd's PrivateTmp environment, which won't be using the same
|
||||
global /tmp directory as the server; see bug #825448.
|
||||
|
||||
Note that we apply the socket directory change at the level of the
|
||||
hard-wired defaults in the C code, not by just twiddling the setting in
|
||||
postgresql.conf.sample; this is so that the change will take effect on
|
||||
server package update, without requiring any existing postgresql.conf
|
||||
to be updated. (Of course, a user who dislikes this behavior can still
|
||||
override it via postgresql.conf.)
|
||||
|
||||
diff --git a/src/backend/utils/misc/guc.c b/src/backend/utils/misc/guc.c
|
||||
index 9481f2d..75532c7 100644
|
||||
--- a/src/backend/utils/misc/guc.c
|
||||
+++ b/src/backend/utils/misc/guc.c
|
||||
@@ -3196,7 +3196,7 @@ static struct config_string ConfigureNamesString[] =
|
||||
},
|
||||
&Unix_socket_directories,
|
||||
#ifdef HAVE_UNIX_SOCKETS
|
||||
- DEFAULT_PGSOCKET_DIR,
|
||||
+ DEFAULT_PGSOCKET_DIR ", /tmp",
|
||||
#else
|
||||
"",
|
||||
#endif
|
||||
diff --git a/src/bin/initdb/initdb.c b/src/bin/initdb/initdb.c
|
||||
index feeff9e..3e3d784 100644
|
||||
--- a/src/bin/initdb/initdb.c
|
||||
+++ b/src/bin/initdb/initdb.c
|
||||
@@ -1234,7 +1234,7 @@ setup_config(void)
|
||||
|
||||
#ifdef HAVE_UNIX_SOCKETS
|
||||
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = '%s'",
|
||||
- DEFAULT_PGSOCKET_DIR);
|
||||
+ DEFAULT_PGSOCKET_DIR ", /tmp");
|
||||
#else
|
||||
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = ''");
|
||||
#endif
|
||||
diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
|
||||
index e278fa0..9ee15d4 100644
|
||||
--- a/src/include/pg_config_manual.h
|
||||
+++ b/src/include/pg_config_manual.h
|
||||
@@ -201,7 +201,7 @@
|
||||
* support them yet.
|
||||
*/
|
||||
#ifndef WIN32
|
||||
-#define DEFAULT_PGSOCKET_DIR "/tmp"
|
||||
+#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
|
||||
#else
|
||||
#define DEFAULT_PGSOCKET_DIR ""
|
||||
#endif
|
@ -1,96 +0,0 @@
|
||||
- The libpq package is supposed to be used for all the PostgreSQL modules
|
||||
|
||||
- available in RHEL 8, and ABI versioning will guarantee us that modular RPMs will
|
||||
- depend on appropriate libpq ABI version (picked at build-time).
|
||||
|
||||
diff --git a/config/Makefile b/config/Makefile
|
||||
index 67e7998f55..86612a42c3 100644
|
||||
--- a/config/Makefile
|
||||
+++ b/config/Makefile
|
||||
@@ -8,6 +8,7 @@ include $(top_builddir)/src/Makefile.global
|
||||
install: all installdirs
|
||||
$(INSTALL_SCRIPT) $(srcdir)/install-sh '$(DESTDIR)$(pgxsdir)/config/install-sh'
|
||||
$(INSTALL_SCRIPT) $(srcdir)/missing '$(DESTDIR)$(pgxsdir)/config/missing'
|
||||
+ $(INSTALL_SCRIPT) $(srcdir)/build-exports-gnu-ld '$(DESTDIR)$(pgxsdir)/config/build-exports-gnu-ld'
|
||||
|
||||
installdirs:
|
||||
$(MKDIR_P) '$(DESTDIR)$(pgxsdir)/config'
|
||||
diff --git a/config/build-exports-gnu-ld b/config/build-exports-gnu-ld
|
||||
new file mode 100755
|
||||
index 0000000000..84c48e3ade
|
||||
--- /dev/null
|
||||
+++ b/config/build-exports-gnu-ld
|
||||
@@ -0,0 +1,41 @@
|
||||
+#! /bin/sh
|
||||
+
|
||||
+# by default use PG_ prefix
|
||||
+: "${SYMBOL_VERSION_PREFIX=PG_}"
|
||||
+
|
||||
+# we started symbol versioning since v10
|
||||
+: "${SYMBOL_VERSION_START=9.6}"
|
||||
+
|
||||
+version=$SYMBOL_VERSION_START
|
||||
+version_prev=
|
||||
+first=:
|
||||
+
|
||||
+open_block ()
|
||||
+{
|
||||
+ $first || echo
|
||||
+ first=false
|
||||
+ echo "${SYMBOL_VERSION_PREFIX}$version {"
|
||||
+ echo "global:"
|
||||
+}
|
||||
+
|
||||
+close_block ()
|
||||
+{
|
||||
+ echo "}${version_prev:+ $SYMBOL_VERSION_PREFIX$version_prev};"
|
||||
+ version_prev=$version
|
||||
+ version=$1
|
||||
+}
|
||||
+
|
||||
+open_block
|
||||
+while read -r symbol _ new_version
|
||||
+do
|
||||
+ case $symbol in '#'*) continue ;; esac
|
||||
+ if test -n "$new_version" && test "$new_version" != "$version"; then
|
||||
+ close_block "$new_version"
|
||||
+ open_block
|
||||
+ fi
|
||||
+ echo " $symbol;"
|
||||
+done
|
||||
+
|
||||
+echo "local:"
|
||||
+echo " *;"
|
||||
+close_block
|
||||
diff --git a/src/Makefile.shlib b/src/Makefile.shlib
|
||||
index 373d73caef..d5bd5468cd 100644
|
||||
--- a/src/Makefile.shlib
|
||||
+++ b/src/Makefile.shlib
|
||||
@@ -231,7 +231,7 @@ ifeq ($(PORTNAME), linux)
|
||||
ifdef soname
|
||||
LINK.shared += -Wl,-soname,$(soname)
|
||||
endif
|
||||
- BUILD.exports = ( echo '{ global:'; $(AWK) '/^[^\#]/ {printf "%s;\n",$$1}' $<; echo ' local: *; };' ) >$@
|
||||
+ BUILD.exports = $(SHELL) $(top_srcdir)/config/build-exports-gnu-ld < $< > $@
|
||||
exports_file = $(SHLIB_EXPORTS:%.txt=%.list)
|
||||
ifneq (,$(exports_file))
|
||||
LINK.shared += -Wl,--version-script=$(exports_file)
|
||||
diff --git a/src/interfaces/libpq/exports.txt b/src/interfaces/libpq/exports.txt
|
||||
index ccec59919b..4c2be8b7d5 100644
|
||||
--- a/src/interfaces/libpq/exports.txt
|
||||
+++ b/src/interfaces/libpq/exports.txt
|
||||
@@ -171,11 +171,11 @@
|
||||
PQsslAttribute 169
|
||||
PQsetErrorContextVisibility 170
|
||||
PQresultVerboseErrorMessage 171
|
||||
-PQencryptPasswordConn 172
|
||||
-PQresultMemorySize 173
|
||||
+PQencryptPasswordConn 172 10
|
||||
+PQresultMemorySize 173 12
|
||||
PQhostaddr 174
|
||||
PQgssEncInUse 175
|
||||
PQgetgssctx 176
|
||||
-PQsetSSLKeyPassHook_OpenSSL 177
|
||||
+PQsetSSLKeyPassHook_OpenSSL 177 13
|
||||
PQgetSSLKeyPassHook_OpenSSL 178
|
||||
PQdefaultSSLKeyPassHook_OpenSSL 179
|
@ -1 +0,0 @@
|
||||
8134b685724d15e60d93bea206fbe0f14c8295e84f1cc91d5a3928163e4fb288 postgresql-13.20.tar.bz2
|
191
SPECS/libpq.spec
191
SPECS/libpq.spec
@ -1,191 +0,0 @@
|
||||
%global majorversion 13
|
||||
%global obsoletes_version %( echo $(( %majorversion + 1 )) )
|
||||
|
||||
Summary: PostgreSQL client library
|
||||
Name: libpq
|
||||
Version: %{majorversion}.20
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: PostgreSQL
|
||||
Url: http://www.postgresql.org/
|
||||
|
||||
Source0: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
|
||||
Source1: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
|
||||
|
||||
|
||||
# Comments for these patches are in the patch files.
|
||||
Patch1: libpq-10.3-rpm-pgsql.patch
|
||||
Patch2: libpq-10.3-var-run-socket.patch
|
||||
Patch3: libpq-13.1-symbol-versioning.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: glibc-devel bison flex gawk
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: krb5-devel
|
||||
BuildRequires: openldap-devel
|
||||
BuildRequires: gettext
|
||||
BuildRequires: multilib-rpm-config
|
||||
|
||||
Obsoletes: postgresql-libs < %obsoletes_version
|
||||
Provides: postgresql-libs = %version-%release
|
||||
|
||||
|
||||
%description
|
||||
The libpq package provides the essential shared library for any PostgreSQL
|
||||
client program or interface. You will need to install this package to use any
|
||||
other PostgreSQL package or any clients that need to connect to a PostgreSQL
|
||||
server.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for building PostgreSQL client tools
|
||||
Requires: %name%{?_isa} = %version-%release
|
||||
# Historically we had 'postgresql-devel' package which was used for building
|
||||
# both PG clients and PG server modules; let's have this fake provide to cover
|
||||
# most of the depending packages and the rest (those which want to build server
|
||||
# modules) need to be fixed to require postgresql-server-devel package.
|
||||
Provides: postgresql-devel = %version-%release
|
||||
Obsoletes: postgresql-devel < %obsoletes_version
|
||||
|
||||
%description devel
|
||||
The libpq package provides the essential shared library for any PostgreSQL
|
||||
client program or interface. You will need to install this package to build any
|
||||
package or any clients that need to connect to a PostgreSQL server.
|
||||
|
||||
|
||||
%prep
|
||||
( cd "$(dirname "%SOURCE1")" ; sha256sum -c "%SOURCE1" )
|
||||
%autosetup -n postgresql-%{version} -p1
|
||||
|
||||
# remove .gitignore files to ensure none get into the RPMs (bug #642210)
|
||||
find . -type f -name .gitignore | xargs rm
|
||||
|
||||
|
||||
%build
|
||||
# complements symbol-versioning patch
|
||||
export SYMBOL_VERSION_PREFIX=RHPG_
|
||||
|
||||
# We don't build server nor client (e.g. /bin/psql) binaries in this package, so
|
||||
# we can disable some configure options.
|
||||
%configure \
|
||||
--disable-rpath \
|
||||
--with-ldap \
|
||||
--with-openssl \
|
||||
--with-gssapi \
|
||||
--enable-nls \
|
||||
--without-readline \
|
||||
--datadir=%_datadir/pgsql
|
||||
|
||||
%global build_subdirs \\\
|
||||
src/include \\\
|
||||
src/common \\\
|
||||
src/port \\\
|
||||
src/interfaces/libpq \\\
|
||||
src/bin/pg_config
|
||||
|
||||
for subdir in %build_subdirs; do
|
||||
%make_build -C "$subdir"
|
||||
done
|
||||
|
||||
|
||||
%install
|
||||
for subdir in %build_subdirs; do
|
||||
%make_install -C "$subdir"
|
||||
done
|
||||
|
||||
# remove files not to be packaged
|
||||
find $RPM_BUILD_ROOT -name '*.a' -delete
|
||||
rm -r $RPM_BUILD_ROOT%_includedir/pgsql/server
|
||||
|
||||
%multilib_fix_c_header --file "%_includedir/pg_config.h"
|
||||
%multilib_fix_c_header --file "%_includedir/pg_config_ext.h"
|
||||
|
||||
find_lang_bins ()
|
||||
{
|
||||
lstfile=$1 ; shift
|
||||
cp /dev/null "$lstfile"
|
||||
for binary; do
|
||||
%find_lang "$binary"-%majorversion
|
||||
cat "$binary"-%majorversion.lang >>"$lstfile"
|
||||
done
|
||||
}
|
||||
|
||||
find_lang_bins %name.lst libpq5
|
||||
find_lang_bins %name-devel.lst pg_config
|
||||
|
||||
|
||||
%files -f %name.lst
|
||||
%license COPYRIGHT
|
||||
%_libdir/libpq.so.*
|
||||
%dir %_datadir/pgsql
|
||||
%doc %_datadir/pgsql/pg_service.conf.sample
|
||||
|
||||
|
||||
%files devel -f %name-devel.lst
|
||||
%_bindir/pg_config
|
||||
%_includedir/*
|
||||
%_libdir/libpq.so
|
||||
%_libdir/pkgconfig/libpq.pc
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Feb 18 2025 Ales Nezbeda <anezbeda@redhat.com> - 13.20-1
|
||||
- Update to 13.20
|
||||
|
||||
* Wed Jun 21 2023 Masahiro Matsuya <mmatsuya@redhat.com> - 13.11-1
|
||||
- Rebase to 13.11
|
||||
Resolves: #2171369
|
||||
|
||||
* Mon Nov 29 2021 Marek Kulik <mkulik@redhat.com> - 13.5-1
|
||||
- Rebase to 13.5
|
||||
Resolves: #2023294
|
||||
|
||||
* Mon May 31 2021 Honza Horak <hhorak@redhat.com> - 13.3-1
|
||||
- Rebase to 13.3
|
||||
Resolves: #1966146
|
||||
|
||||
* Tue Feb 16 2021 Honza Horak <hhorak@redhat.com> - 13.2-1
|
||||
- Rebase to 13.2
|
||||
Related: #1855776
|
||||
|
||||
* Tue Nov 17 2020 Patrik Novotný <panovotn@redhat.com> - 13.1-1
|
||||
- Rebase to upstream release 13.1
|
||||
Resolves: BZ#1855776
|
||||
(BZ#1856242 particuarly)
|
||||
|
||||
* Mon Aug 17 2020 Patrik Novotný <panovotn@redhat.com> - 12.4-1
|
||||
- Rebase to upstream release 12.4
|
||||
|
||||
* Tue Jun 16 2020 Patrik Novotný <panovotn@redhat.com> - 12.3-1
|
||||
- Rebase to upstream release 12.3
|
||||
|
||||
* Tue Nov 19 2019 Patrik Novotný <panovotn@redhat.com> - 12.1-3
|
||||
- Rebuild with rebased symbol versioning patch
|
||||
|
||||
* Fri Nov 15 2019 Patrik Novotný <panovotn@redhat.com> - 12.1-2
|
||||
- Rebuild with rebased symbol versioning patch
|
||||
|
||||
* Tue Nov 12 2019 Patrik Novotný <panovotn@redhat.com> - 12.1-1
|
||||
- Rebase to upstream release 12.1
|
||||
|
||||
* Fri Nov 08 2019 Honza Horak <hhorak@redhat.com> - 12.0-2
|
||||
- Bump release for a new build with gating.yaml added
|
||||
Related: #1749461
|
||||
|
||||
* Thu Oct 03 2019 Patrik Novotný <panovotn@redhat.com> - 12.0-1
|
||||
- Initial release for upstream version 12.0
|
||||
|
||||
* Wed Aug 08 2018 Pavel Raiskup <praiskup@redhat.com> - 10.5-1
|
||||
- update to 10.5 per release notes:
|
||||
https://www.postgresql.org/docs/10/static/release-10-5.html
|
||||
|
||||
* Fri Jul 13 2018 Pavel Raiskup <praiskup@redhat.com> - 10.4-2
|
||||
- ABI/symbol versioning
|
||||
|
||||
* Thu Jul 12 2018 Pavel Raiskup <praiskup@redhat.com> - 10.4-1
|
||||
- rebase to the latest upstream release
|
||||
|
||||
* Fri Apr 13 2018 Pavel Raiskup <praiskup@redhat.com> - 10.3-1
|
||||
- initial release, packaging inspired by postgresql.spec
|
||||
- provide postgresql-devel to avoid fixing all the client packages
|
@ -7,11 +7,11 @@ directory whose path happens to include "postgres" or "pgsql" already.
|
||||
However, datadir and sysconfdir are already set up in the specfile's
|
||||
configure call, so we do not have to append anything to them.
|
||||
|
||||
|
||||
diff -Naur postgresql-9.0.1.orig/src/Makefile.global.in postgresql-9.0.1/src/Makefile.global.in
|
||||
--- postgresql-9.0.1.orig/src/Makefile.global.in 2010-10-01 10:25:44.000000000 -0400
|
||||
+++ postgresql-9.0.1/src/Makefile.global.in 2010-10-11 11:52:05.224975308 -0400
|
||||
@@ -55,8 +55,7 @@
|
||||
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
|
||||
index 9a6265b3a0..c9371a07c4 100644
|
||||
--- a/src/Makefile.global.in
|
||||
+++ b/src/Makefile.global.in
|
||||
@@ -82,8 +82,7 @@ vpathsearch = `for f in $(addsuffix /$(1),$(subst :, ,. $(VPATH))); do test -r $
|
||||
# Installation directories
|
||||
#
|
||||
# These are set by the equivalent --xxxdir configure options. We
|
||||
@ -21,7 +21,7 @@ diff -Naur postgresql-9.0.1.orig/src/Makefile.global.in postgresql-9.0.1/src/Mak
|
||||
#
|
||||
# In a PGXS build, we cannot use the values inserted into Makefile.global
|
||||
# by configure, since the installation tree may have been relocated.
|
||||
@@ -74,45 +73,23 @@
|
||||
@@ -101,45 +100,23 @@ datarootdir := @datarootdir@
|
||||
bindir := @bindir@
|
||||
|
||||
datadir := @datadir@
|
51
libpq-10.3-var-run-socket.patch
Normal file
51
libpq-10.3-var-run-socket.patch
Normal file
@ -0,0 +1,51 @@
|
||||
|
||||
Change the built-in default socket directory to be /var/run/postgresql.
|
||||
For backwards compatibility with (probably non-libpq-based) clients that
|
||||
might still expect to find the socket in /tmp, also create a socket in
|
||||
/tmp. This is to resolve communication problems with clients operating
|
||||
under systemd's PrivateTmp environment, which won't be using the same
|
||||
global /tmp directory as the server; see bug #825448.
|
||||
|
||||
Note that we apply the socket directory change at the level of the
|
||||
hard-wired defaults in the C code, not by just twiddling the setting in
|
||||
postgresql.conf.sample; this is so that the change will take effect on
|
||||
server package update, without requiring any existing postgresql.conf
|
||||
to be updated. (Of course, a user who dislikes this behavior can still
|
||||
override it via postgresql.conf.)
|
||||
|
||||
diff -ur postgresql-16.1/src/backend/utils/misc/guc_tables.c pg_patched/src/backend/utils/misc/guc_tables.c
|
||||
--- postgresql-16.1/src/backend/utils/misc/guc_tables.c 2023-11-06 23:04:27.000000000 +0100
|
||||
+++ pg_patched/src/backend/utils/misc/guc_tables.c 2023-12-05 12:02:46.000000000 +0100
|
||||
@@ -4271,7 +4271,7 @@
|
||||
GUC_LIST_INPUT | GUC_LIST_QUOTE | GUC_SUPERUSER_ONLY
|
||||
},
|
||||
&Unix_socket_directories,
|
||||
- DEFAULT_PGSOCKET_DIR,
|
||||
+ DEFAULT_PGSOCKET_DIR ", /tmp",
|
||||
NULL, NULL, NULL
|
||||
},
|
||||
|
||||
diff -ur postgresql-16.1/src/bin/initdb/initdb.c pg_patched/src/bin/initdb/initdb.c
|
||||
--- postgresql-16.1/src/bin/initdb/initdb.c 2023-11-06 23:04:27.000000000 +0100
|
||||
+++ pg_patched/src/bin/initdb/initdb.c 2023-12-05 12:04:19.000000000 +0100
|
||||
@@ -1287,7 +1287,7 @@
|
||||
* these are indeed defaults, keep the postgresql.conf lines commented.
|
||||
*/
|
||||
conflines = replace_guc_value(conflines, "unix_socket_directories",
|
||||
- DEFAULT_PGSOCKET_DIR, true);
|
||||
+ DEFAULT_PGSOCKET_DIR ", /tmp", true);
|
||||
|
||||
conflines = replace_guc_value(conflines, "port",
|
||||
DEF_PGPORT_STR, true);
|
||||
diff -ur postgresql-16.1/src/include/pg_config_manual.h pg_patched/src/include/pg_config_manual.h
|
||||
--- postgresql-16.1/src/include/pg_config_manual.h 2023-11-06 23:04:27.000000000 +0100
|
||||
+++ pg_patched/src/include/pg_config_manual.h 2023-12-05 11:45:20.000000000 +0100
|
||||
@@ -206,7 +206,7 @@
|
||||
* support them yet.
|
||||
*/
|
||||
#ifndef WIN32
|
||||
-#define DEFAULT_PGSOCKET_DIR "/tmp"
|
||||
+#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
|
||||
#else
|
||||
#define DEFAULT_PGSOCKET_DIR ""
|
||||
#endif
|
106
libpq-12.1-symbol-versioning.patch
Normal file
106
libpq-12.1-symbol-versioning.patch
Normal file
@ -0,0 +1,106 @@
|
||||
commit 75040c3388d9a7dd5ad2bee53cbcc8bf3d35cd17
|
||||
Author: Honza Horak <hhorak@redhat.com>
|
||||
Date: Fri Oct 30 20:16:50 2020 +0100
|
||||
|
||||
The libpq package is supposed to be used for all the PostgreSQL modules
|
||||
available in RHEL 8, and ABI versioning will guarantee us that modular RPMs will
|
||||
depend on appropriate libpq ABI version (picked at build-time).
|
||||
|
||||
diff -ur postgresql-16.1/config/Makefile postgresql_patched/config/Makefile
|
||||
--- postgresql-16.1/config/Makefile 2023-11-06 23:04:27.000000000 +0100
|
||||
+++ postgresql_patched/config/Makefile 2023-12-05 10:43:19.733619095 +0100
|
||||
@@ -8,6 +8,7 @@
|
||||
install: all installdirs
|
||||
$(INSTALL_SCRIPT) $(srcdir)/install-sh '$(DESTDIR)$(pgxsdir)/config/install-sh'
|
||||
$(INSTALL_SCRIPT) $(srcdir)/missing '$(DESTDIR)$(pgxsdir)/config/missing'
|
||||
+ $(INSTALL_SCRIPT) $(srcdir)/build-exports-gnu-ld '$(DESTDIR)$(pgxsdir)/config/build-exports-gnu-ld'
|
||||
|
||||
installdirs:
|
||||
$(MKDIR_P) '$(DESTDIR)$(pgxsdir)/config'
|
||||
diff -ur postgresql-16.1/src/interfaces/libpq/exports.txt postgresql_patched/src/interfaces/libpq/exports.txt
|
||||
--- postgresql-16.1/src/interfaces/libpq/exports.txt 2023-11-06 23:04:27.000000000 +0100
|
||||
+++ postgresql_patched/src/interfaces/libpq/exports.txt 2023-12-05 10:48:24.627604638 +0100
|
||||
@@ -171,19 +171,19 @@
|
||||
PQsslAttribute 169
|
||||
PQsetErrorContextVisibility 170
|
||||
PQresultVerboseErrorMessage 171
|
||||
-PQencryptPasswordConn 172
|
||||
-PQresultMemorySize 173
|
||||
+PQencryptPasswordConn 172 10
|
||||
+PQresultMemorySize 173 12
|
||||
PQhostaddr 174
|
||||
PQgssEncInUse 175
|
||||
PQgetgssctx 176
|
||||
-PQsetSSLKeyPassHook_OpenSSL 177
|
||||
+PQsetSSLKeyPassHook_OpenSSL 177 13
|
||||
PQgetSSLKeyPassHook_OpenSSL 178
|
||||
PQdefaultSSLKeyPassHook_OpenSSL 179
|
||||
-PQenterPipelineMode 180
|
||||
+PQenterPipelineMode 180 14
|
||||
PQexitPipelineMode 181
|
||||
PQpipelineSync 182
|
||||
PQpipelineStatus 183
|
||||
PQsetTraceFlags 184
|
||||
PQmblenBounded 185
|
||||
PQsendFlushRequest 186
|
||||
-PQconnectionUsedGSSAPI 187
|
||||
+PQconnectionUsedGSSAPI 187 16
|
||||
diff -ur postgresql-16.1/src/Makefile.shlib postgresql_patched/src/Makefile.shlib
|
||||
--- postgresql-16.1/src/Makefile.shlib 2023-11-06 23:04:27.000000000 +0100
|
||||
+++ postgresql_patched/src/Makefile.shlib 2023-12-05 10:43:19.739634021 +0100
|
||||
@@ -185,7 +185,7 @@
|
||||
ifdef soname
|
||||
LINK.shared += -Wl,-soname,$(soname)
|
||||
endif
|
||||
- BUILD.exports = ( echo '{ global:'; $(AWK) '/^[^\#]/ {printf "%s;\n",$$1}' $<; echo ' local: *; };' ) >$@
|
||||
+ BUILD.exports = $(SHELL) $(top_srcdir)/config/build-exports-gnu-ld < $< > $@
|
||||
exports_file = $(SHLIB_EXPORTS:%.txt=%.list)
|
||||
ifneq (,$(exports_file))
|
||||
LINK.shared += -Wl,--version-script=$(exports_file)
|
||||
diff --git a/config/build-exports-gnu-ld b/config/build-exports-gnu-ld
|
||||
new file mode 100755
|
||||
index 0000000000..84c48e3ade
|
||||
--- /dev/null
|
||||
+++ b/config/build-exports-gnu-ld
|
||||
@@ -0,0 +1,41 @@
|
||||
+#! /bin/sh
|
||||
+
|
||||
+# by default use PG_ prefix
|
||||
+: "${SYMBOL_VERSION_PREFIX=PG_}"
|
||||
+
|
||||
+# we started symbol versioning since v10
|
||||
+: "${SYMBOL_VERSION_START=9.6}"
|
||||
+
|
||||
+version=$SYMBOL_VERSION_START
|
||||
+version_prev=
|
||||
+first=:
|
||||
+
|
||||
+open_block ()
|
||||
+{
|
||||
+ $first || echo
|
||||
+ first=false
|
||||
+ echo "${SYMBOL_VERSION_PREFIX}$version {"
|
||||
+ echo "global:"
|
||||
+}
|
||||
+
|
||||
+close_block ()
|
||||
+{
|
||||
+ echo "}${version_prev:+ $SYMBOL_VERSION_PREFIX$version_prev};"
|
||||
+ version_prev=$version
|
||||
+ version=$1
|
||||
+}
|
||||
+
|
||||
+open_block
|
||||
+while read -r symbol _ new_version
|
||||
+do
|
||||
+ case $symbol in '#'*) continue ;; esac
|
||||
+ if test -n "$new_version" && test "$new_version" != "$version"; then
|
||||
+ close_block "$new_version"
|
||||
+ open_block
|
||||
+ fi
|
||||
+ echo " $symbol;"
|
||||
+done
|
||||
+
|
||||
+echo "local:"
|
||||
+echo " *;"
|
||||
+close_block
|
294
libpq.spec
Normal file
294
libpq.spec
Normal file
@ -0,0 +1,294 @@
|
||||
%global majorversion 16
|
||||
%global obsoletes_version %( echo $(( %majorversion + 1 )) )
|
||||
|
||||
Summary: PostgreSQL client library
|
||||
Name: libpq
|
||||
Version: %{majorversion}.8
|
||||
Release: 2%{?dist}
|
||||
|
||||
License: PostgreSQL
|
||||
Url: http://www.postgresql.org/
|
||||
|
||||
Source0: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
|
||||
Source1: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2.sha256
|
||||
|
||||
|
||||
# Comments for these patches are in the patch files.
|
||||
Patch1: libpq-10.3-rpm-pgsql.patch
|
||||
Patch2: libpq-10.3-var-run-socket.patch
|
||||
Patch3: libpq-12.1-symbol-versioning.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: glibc-devel bison flex gawk
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: krb5-devel
|
||||
BuildRequires: openldap-devel
|
||||
BuildRequires: gettext
|
||||
BuildRequires: multilib-rpm-config
|
||||
BuildRequires: make
|
||||
BuildRequires: libicu-devel
|
||||
|
||||
Obsoletes: postgresql-libs < %obsoletes_version
|
||||
Provides: postgresql-libs = %version-%release
|
||||
|
||||
|
||||
%description
|
||||
The libpq package provides the essential shared library for any PostgreSQL
|
||||
client program or interface. You will need to install this package to use any
|
||||
other PostgreSQL package or any clients that need to connect to a PostgreSQL
|
||||
server.
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development files for building PostgreSQL client tools
|
||||
Requires: %name%{?_isa} = %version-%release
|
||||
# Historically we had 'postgresql-devel' package which was used for building
|
||||
# both PG clients and PG server modules; let's have this fake provide to cover
|
||||
# most of the depending packages and the rest (those which want to build server
|
||||
# modules) need to be fixed to require postgresql-server-devel package.
|
||||
Provides: postgresql-devel = %version-%release
|
||||
Obsoletes: postgresql-devel < %obsoletes_version
|
||||
|
||||
%description devel
|
||||
The libpq package provides the essential shared library for any PostgreSQL
|
||||
client program or interface. You will need to install this package to build any
|
||||
package or any clients that need to connect to a PostgreSQL server.
|
||||
|
||||
|
||||
%prep
|
||||
( cd "$(dirname "%SOURCE1")" ; sha256sum -c "%SOURCE1" )
|
||||
%autosetup -n postgresql-%version -p1
|
||||
|
||||
# remove .gitignore files to ensure none get into the RPMs (bug #642210)
|
||||
find . -type f -name .gitignore | xargs rm
|
||||
|
||||
|
||||
%build
|
||||
# complements symbol-versioning patch
|
||||
export SYMBOL_VERSION_PREFIX=RHPG_
|
||||
# Disable ENGINE_API
|
||||
CFLAGS="$CFLAGS -DOPENSSL_NO_ENGINE"
|
||||
export CFLAGS
|
||||
|
||||
# We don't build server nor client (e.g. /bin/psql) binaries in this package, so
|
||||
# we can disable some configure options.
|
||||
%configure \
|
||||
--disable-rpath \
|
||||
--with-ldap \
|
||||
--with-openssl \
|
||||
--with-gssapi \
|
||||
--enable-nls \
|
||||
--without-readline \
|
||||
--datadir=%_datadir/pgsql
|
||||
|
||||
%global build_subdirs \\\
|
||||
src/include \\\
|
||||
src/common \\\
|
||||
src/port \\\
|
||||
src/interfaces/libpq \\\
|
||||
src/bin/pg_config
|
||||
|
||||
for subdir in %build_subdirs; do
|
||||
%make_build -C "$subdir"
|
||||
done
|
||||
|
||||
|
||||
%install
|
||||
for subdir in %build_subdirs; do
|
||||
%make_install -C "$subdir"
|
||||
done
|
||||
|
||||
# remove files not to be packaged
|
||||
find $RPM_BUILD_ROOT -name '*.a' -delete
|
||||
# preserve just errcodes.h
|
||||
mv $RPM_BUILD_ROOT%{_includedir}/pgsql/server/utils/errcodes.h \
|
||||
$RPM_BUILD_ROOT%{_includedir}/pgsql
|
||||
rm -r $RPM_BUILD_ROOT%_includedir/pgsql/server
|
||||
mkdir -p $RPM_BUILD_ROOT%{_includedir}/pgsql/server/utils
|
||||
mv $RPM_BUILD_ROOT%{_includedir}/pgsql/errcodes.h \
|
||||
$RPM_BUILD_ROOT%{_includedir}/pgsql/server/utils
|
||||
|
||||
%multilib_fix_c_header --file "%_includedir/pg_config.h"
|
||||
%multilib_fix_c_header --file "%_includedir/pg_config_ext.h"
|
||||
|
||||
find_lang_bins ()
|
||||
{
|
||||
lstfile=$1 ; shift
|
||||
cp /dev/null "$lstfile"
|
||||
for binary; do
|
||||
%find_lang "$binary"-%majorversion
|
||||
cat "$binary"-%majorversion.lang >>"$lstfile"
|
||||
done
|
||||
}
|
||||
|
||||
find_lang_bins %name.lst libpq5
|
||||
find_lang_bins %name-devel.lst pg_config
|
||||
|
||||
|
||||
%files -f %name.lst
|
||||
%license COPYRIGHT
|
||||
%_libdir/libpq.so.5*
|
||||
%dir %_datadir/pgsql
|
||||
%doc %_datadir/pgsql/pg_service.conf.sample
|
||||
|
||||
|
||||
%files devel -f %name-devel.lst
|
||||
%_bindir/pg_config
|
||||
%_includedir/*
|
||||
%_libdir/libpq.so
|
||||
%_libdir/pkgconfig/libpq.pc
|
||||
|
||||
%changelog
|
||||
* Wed Mar 5 2025 Ales Nezbeda <anezbeda@redhat.com> 16.8-2
|
||||
- Bump release for rebuild
|
||||
|
||||
* Thu Feb 20 2025 Ales Nezbeda <anezbeda@redhat.com> 16.8-1
|
||||
- Update to 16.8
|
||||
|
||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 16.1-8
|
||||
- Bump release for October 2024 mass rebuild:
|
||||
Resolves: RHEL-64018
|
||||
|
||||
* Wed Jul 3 2024 Filip Janus <fjanus@redhat.com> - 16.1-7
|
||||
- Disable openssl ENGINE_API
|
||||
|
||||
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 16.1-6
|
||||
- Bump release for June 2024 mass rebuild
|
||||
|
||||
* Tue Jun 18 2024 Filip Janus <fjanus@redhat.com> - 16.1-5
|
||||
- Ship errcodes.h in -devel package (kea package requires errorcodes)
|
||||
|
||||
* Tue Feb 20 2024 Yaakov Selkowitz <yselkowi@redhat.com> - 16.1-4
|
||||
- Backport OpenSSL 3.2 fix from upstream master
|
||||
|
||||
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 16.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 16.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Tue Dec 5 2023 Filip Janus <fjanus@redhat.com> - 16.1-1
|
||||
- Update to 16.1
|
||||
- Build with ICU by default - new upstream feature
|
||||
|
||||
* Wed Aug 2 2023 Filip Janus <fjanus@redhat.com> - 15.3-1
|
||||
- Update to the latest upstream version
|
||||
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 15.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 15.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Mon Dec 05 2022 Filip Janus <fjansu@redhat.com> - 15.0-2
|
||||
- Revert versioning patch
|
||||
- There are no new symbols in libpq 15
|
||||
|
||||
* Tue Sep 27 2022 Ondrej Sloup <osloup@redhat.com> - 15.0-1
|
||||
- Update to v15
|
||||
- Update patches
|
||||
- Resolves: https://fedoraproject.org/wiki/Changes/PostgreSQL_15
|
||||
|
||||
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 14.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Tue Jun 14 2022 Filip Januš <fjanus@redhat.com> - 14.3-1
|
||||
- Update to 14.3
|
||||
|
||||
* Tue Feb 22 2022 Filip Januš <fjanus@redhat.com> - 14.2-1
|
||||
- Update to 14.2
|
||||
|
||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 14.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Mon Jan 03 2022 Filip Januš <fjanus@redhat.com> - 14.1-1
|
||||
- Update to v14
|
||||
- Resolves: https://fedoraproject.org/wiki/Changes/PostgreSQL_14
|
||||
|
||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 13.4-2
|
||||
- Rebuilt with OpenSSL 3.0.0
|
||||
|
||||
* Thu Aug 12 2021 Filip Januš <fjanus@rehdat.com> - 13.4-1
|
||||
- Update to 13.4
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 13.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Mon May 17 2021 Filip Januš <fjanus@redhat.com> - 13.3-1
|
||||
- Update to 13.3
|
||||
|
||||
* Tue Feb 16 2021 Honza Horak <hhorak@redhat.com> - 13.2-1
|
||||
- Update to 13.2
|
||||
|
||||
* Mon Feb 08 2021 Patrik Novotný <panovotn@redhat.com> - 13.1-3
|
||||
- Fix symbol versioning
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 13.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Mon Nov 16 2020 Patrik Novotný <panovotn@redhat.com> - 13.1-1
|
||||
- Rebase to upstream release 13.1
|
||||
|
||||
* Mon Nov 02 2020 Patrik Novotný <panovotn@redhat.com> - 13.0-2
|
||||
- Rebuild for symbol versioning fix
|
||||
|
||||
* Wed Oct 14 2020 Patrik Novotný <panovotn@redhat.com> - 13.0-1
|
||||
- Rebase to upstream release 13.0
|
||||
|
||||
* Tue Aug 18 2020 Patrik Novotný <panovotn@redhat.com> - 12.4-1
|
||||
- Rebase to upstream release 12.4
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 12.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon May 18 2020 Patrik Novotný <panovotn@redhat.com> - 12.3-1
|
||||
- Rebase to upstream release 12.3
|
||||
|
||||
* Mon Feb 17 2020 Patrik Novotný <panovotn@redhat.com> - 12.2-1
|
||||
- Rebase to upstream release 12.2
|
||||
|
||||
* Tue Feb 04 2020 Patrik Novotný <panovotn@redhat.com> - 12.1-1
|
||||
- Rebase to upstream release 12.1
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 11.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Mon Nov 25 2019 Patrik Novotný <panovotn@redhat.com> - 11.6-1
|
||||
- Rebase to upstream version 11.6
|
||||
|
||||
* Wed Aug 07 2019 Petr Kubat <pkubat@redhat.com> - 11.5-1
|
||||
- New upstream version 11.5
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 11.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Tue Jul 09 2019 Petr Kubat <pkubat@redhat.com> - 11.4-1
|
||||
- New upstream version 11.4
|
||||
|
||||
* Fri May 10 2019 Pavel Raiskup <praiskup@redhat.com> - 11.3-2
|
||||
- obsolete anything < %%majorversion+1
|
||||
|
||||
* Thu May 09 2019 Patrik Novotný <panovotn@redhat.com> - 11.3-1
|
||||
- New upstream version 11.3
|
||||
|
||||
* Mon Feb 18 2019 Pavel Raiskup <praiskup@redhat.com> - 11.2-2
|
||||
- fix dnf system-upgrade from f29 to f29+, rhbz#1677849
|
||||
|
||||
* Thu Feb 14 2019 Pavel Raiskup <praiskup@redhat.com> - 11.2-1
|
||||
- latest upstream release, per release notes:
|
||||
https://www.postgresql.org/docs/11/static/release-11-1.html
|
||||
https://www.postgresql.org/docs/11/static/release-11-2.html
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 11.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Oct 16 2018 Pavel Raiskup <praiskup@redhat.com> - 11.0-1
|
||||
- latest upstream release, per release notes:
|
||||
https://www.postgresql.org/docs/11/static/release-11-0.html
|
||||
|
||||
* Tue Sep 04 2018 Pavel Raiskup <praiskup@redhat.com> - 10.5-4
|
||||
- fix provides/obsoletes to final state
|
||||
|
||||
* Thu Aug 30 2018 Pavel Raiskup <praiskup@redhat.com> - 10.5-1
|
||||
- libpq packaging for Fedora
|
1
postgresql-16.8.tar.bz2.sha256
Normal file
1
postgresql-16.8.tar.bz2.sha256
Normal file
@ -0,0 +1 @@
|
||||
9468083a56ce0ee7d294601b74dad3dd9fc69d87aff61f0a9fb63c813ff7efd8 postgresql-16.8.tar.bz2
|
Loading…
Reference in New Issue
Block a user