Update to version 14
Add new symbols into symbol-versioning patch
This commit is contained in:
parent
9f5cabe90a
commit
844bc3732a
@ -78,17 +78,16 @@ index 373d73caef..d5bd5468cd 100644
|
||||
exports_file = $(SHLIB_EXPORTS:%.txt=%.list)
|
||||
ifneq (,$(exports_file))
|
||||
LINK.shared += -Wl,--version-script=$(exports_file)
|
||||
diff --git a/src/interfaces/libpq/exports.txt b/src/interfaces/libpq/exports.txt
|
||||
index bbc1f90..fc3ef8a 100644
|
||||
--- a/src/interfaces/libpq/exports.txt
|
||||
+++ b/src/interfaces/libpq/exports.txt
|
||||
@@ -171,11 +171,11 @@ PQsslAttributeNames 168
|
||||
diff -ur postgresql-14.1/src/interfaces/libpq/exports.txt patched/src/interfaces/libpq/exports.txt
|
||||
--- postgresql-14.1/src/interfaces/libpq/exports.txt 2021-11-08 22:58:24.000000000 +0100
|
||||
+++ patched/src/interfaces/libpq/exports.txt 2022-01-12 12:00:28.000000000 +0100
|
||||
@@ -171,15 +171,15 @@
|
||||
PQsslAttribute 169
|
||||
PQsetErrorContextVisibility 170
|
||||
PQresultVerboseErrorMessage 171
|
||||
-PQencryptPasswordConn 172
|
||||
+PQencryptPasswordConn 172 10
|
||||
-PQresultMemorySize 173
|
||||
+PQencryptPasswordConn 172 10
|
||||
+PQresultMemorySize 173 12
|
||||
PQhostaddr 174
|
||||
PQgssEncInUse 175
|
||||
@ -97,3 +96,8 @@ index bbc1f90..fc3ef8a 100644
|
||||
+PQsetSSLKeyPassHook_OpenSSL 177 13
|
||||
PQgetSSLKeyPassHook_OpenSSL 178
|
||||
PQdefaultSSLKeyPassHook_OpenSSL 179
|
||||
-PQenterPipelineMode 180
|
||||
+PQenterPipelineMode 180 14
|
||||
PQexitPipelineMode 181
|
||||
PQpipelineSync 182
|
||||
PQpipelineStatus 183
|
||||
|
10
libpq.spec
10
libpq.spec
@ -1,10 +1,10 @@
|
||||
%global majorversion 13
|
||||
%global majorversion 14
|
||||
%global obsoletes_version %( echo $(( %majorversion + 1 )) )
|
||||
|
||||
Summary: PostgreSQL client library
|
||||
Name: libpq
|
||||
Version: %{majorversion}.4
|
||||
Release: 2%{?dist}
|
||||
Version: %{majorversion}.1
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: PostgreSQL
|
||||
Url: http://www.postgresql.org/
|
||||
@ -131,6 +131,10 @@ find_lang_bins %name-devel.lst pg_config
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 03 2022 Filip Januš <fjanus@rredhat.com> - 14.1-1
|
||||
- Update to v14
|
||||
- Resolves: https://fedoraproject.org/wiki/Changes/PostgreSQL_14
|
||||
|
||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 13.4-2
|
||||
- Rebuilt with OpenSSL 3.0.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user