Update to version 14
Add new symbols into symbol-versioning patch
This commit is contained in:
parent
9f5cabe90a
commit
844bc3732a
@ -15,7 +15,7 @@ index 67e7998..86612a4 100644
|
|||||||
$(INSTALL_SCRIPT) $(srcdir)/install-sh '$(DESTDIR)$(pgxsdir)/config/install-sh'
|
$(INSTALL_SCRIPT) $(srcdir)/install-sh '$(DESTDIR)$(pgxsdir)/config/install-sh'
|
||||||
$(INSTALL_SCRIPT) $(srcdir)/missing '$(DESTDIR)$(pgxsdir)/config/missing'
|
$(INSTALL_SCRIPT) $(srcdir)/missing '$(DESTDIR)$(pgxsdir)/config/missing'
|
||||||
+ $(INSTALL_SCRIPT) $(srcdir)/build-exports-gnu-ld '$(DESTDIR)$(pgxsdir)/config/build-exports-gnu-ld'
|
+ $(INSTALL_SCRIPT) $(srcdir)/build-exports-gnu-ld '$(DESTDIR)$(pgxsdir)/config/build-exports-gnu-ld'
|
||||||
|
|
||||||
installdirs:
|
installdirs:
|
||||||
$(MKDIR_P) '$(DESTDIR)$(pgxsdir)/config'
|
$(MKDIR_P) '$(DESTDIR)$(pgxsdir)/config'
|
||||||
diff --git a/config/build-exports-gnu-ld b/config/build-exports-gnu-ld
|
diff --git a/config/build-exports-gnu-ld b/config/build-exports-gnu-ld
|
||||||
@ -78,17 +78,16 @@ index 373d73caef..d5bd5468cd 100644
|
|||||||
exports_file = $(SHLIB_EXPORTS:%.txt=%.list)
|
exports_file = $(SHLIB_EXPORTS:%.txt=%.list)
|
||||||
ifneq (,$(exports_file))
|
ifneq (,$(exports_file))
|
||||||
LINK.shared += -Wl,--version-script=$(exports_file)
|
LINK.shared += -Wl,--version-script=$(exports_file)
|
||||||
diff --git a/src/interfaces/libpq/exports.txt b/src/interfaces/libpq/exports.txt
|
diff -ur postgresql-14.1/src/interfaces/libpq/exports.txt patched/src/interfaces/libpq/exports.txt
|
||||||
index bbc1f90..fc3ef8a 100644
|
--- postgresql-14.1/src/interfaces/libpq/exports.txt 2021-11-08 22:58:24.000000000 +0100
|
||||||
--- a/src/interfaces/libpq/exports.txt
|
+++ patched/src/interfaces/libpq/exports.txt 2022-01-12 12:00:28.000000000 +0100
|
||||||
+++ b/src/interfaces/libpq/exports.txt
|
@@ -171,15 +171,15 @@
|
||||||
@@ -171,11 +171,11 @@ PQsslAttributeNames 168
|
|
||||||
PQsslAttribute 169
|
PQsslAttribute 169
|
||||||
PQsetErrorContextVisibility 170
|
PQsetErrorContextVisibility 170
|
||||||
PQresultVerboseErrorMessage 171
|
PQresultVerboseErrorMessage 171
|
||||||
-PQencryptPasswordConn 172
|
-PQencryptPasswordConn 172
|
||||||
+PQencryptPasswordConn 172 10
|
|
||||||
-PQresultMemorySize 173
|
-PQresultMemorySize 173
|
||||||
|
+PQencryptPasswordConn 172 10
|
||||||
+PQresultMemorySize 173 12
|
+PQresultMemorySize 173 12
|
||||||
PQhostaddr 174
|
PQhostaddr 174
|
||||||
PQgssEncInUse 175
|
PQgssEncInUse 175
|
||||||
@ -97,3 +96,8 @@ index bbc1f90..fc3ef8a 100644
|
|||||||
+PQsetSSLKeyPassHook_OpenSSL 177 13
|
+PQsetSSLKeyPassHook_OpenSSL 177 13
|
||||||
PQgetSSLKeyPassHook_OpenSSL 178
|
PQgetSSLKeyPassHook_OpenSSL 178
|
||||||
PQdefaultSSLKeyPassHook_OpenSSL 179
|
PQdefaultSSLKeyPassHook_OpenSSL 179
|
||||||
|
-PQenterPipelineMode 180
|
||||||
|
+PQenterPipelineMode 180 14
|
||||||
|
PQexitPipelineMode 181
|
||||||
|
PQpipelineSync 182
|
||||||
|
PQpipelineStatus 183
|
||||||
|
10
libpq.spec
10
libpq.spec
@ -1,10 +1,10 @@
|
|||||||
%global majorversion 13
|
%global majorversion 14
|
||||||
%global obsoletes_version %( echo $(( %majorversion + 1 )) )
|
%global obsoletes_version %( echo $(( %majorversion + 1 )) )
|
||||||
|
|
||||||
Summary: PostgreSQL client library
|
Summary: PostgreSQL client library
|
||||||
Name: libpq
|
Name: libpq
|
||||||
Version: %{majorversion}.4
|
Version: %{majorversion}.1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
License: PostgreSQL
|
License: PostgreSQL
|
||||||
Url: http://www.postgresql.org/
|
Url: http://www.postgresql.org/
|
||||||
@ -131,6 +131,10 @@ find_lang_bins %name-devel.lst pg_config
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 03 2022 Filip Januš <fjanus@rredhat.com> - 14.1-1
|
||||||
|
- Update to v14
|
||||||
|
- Resolves: https://fedoraproject.org/wiki/Changes/PostgreSQL_14
|
||||||
|
|
||||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 13.4-2
|
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 13.4-2
|
||||||
- Rebuilt with OpenSSL 3.0.0
|
- Rebuilt with OpenSSL 3.0.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user