Rebase to upstream release 13.0

This commit is contained in:
Patrik Novotný 2020-10-22 13:14:13 +02:00
parent 15eca5b3ef
commit 7d81dca0ea
6 changed files with 84 additions and 74 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/postgresql-*.tar.bz2* /postgresql-*.tar.bz2*
/rpms

View File

@ -7,11 +7,11 @@ directory whose path happens to include "postgres" or "pgsql" already.
However, datadir and sysconfdir are already set up in the specfile's However, datadir and sysconfdir are already set up in the specfile's
configure call, so we do not have to append anything to them. configure call, so we do not have to append anything to them.
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
diff -Naur postgresql-9.0.1.orig/src/Makefile.global.in postgresql-9.0.1/src/Makefile.global.in index 9a6265b3a0..c9371a07c4 100644
--- postgresql-9.0.1.orig/src/Makefile.global.in 2010-10-01 10:25:44.000000000 -0400 --- a/src/Makefile.global.in
+++ postgresql-9.0.1/src/Makefile.global.in 2010-10-11 11:52:05.224975308 -0400 +++ b/src/Makefile.global.in
@@ -55,8 +55,7 @@ @@ -82,8 +82,7 @@ vpathsearch = `for f in $(addsuffix /$(1),$(subst :, ,. $(VPATH))); do test -r $
# Installation directories # Installation directories
# #
# These are set by the equivalent --xxxdir configure options. We # These are set by the equivalent --xxxdir configure options. We
@ -21,7 +21,7 @@ diff -Naur postgresql-9.0.1.orig/src/Makefile.global.in postgresql-9.0.1/src/Mak
# #
# In a PGXS build, we cannot use the values inserted into Makefile.global # In a PGXS build, we cannot use the values inserted into Makefile.global
# by configure, since the installation tree may have been relocated. # by configure, since the installation tree may have been relocated.
@@ -74,45 +73,23 @@ @@ -101,45 +100,23 @@ datarootdir := @datarootdir@
bindir := @bindir@ bindir := @bindir@
datadir := @datadir@ datadir := @datadir@

View File

@ -13,10 +13,10 @@ to be updated. (Of course, a user who dislikes this behavior can still
override it via postgresql.conf.) override it via postgresql.conf.)
diff --git a/src/backend/utils/misc/guc.c b/src/backend/utils/misc/guc.c diff --git a/src/backend/utils/misc/guc.c b/src/backend/utils/misc/guc.c
index 9481f2d..75532c7 100644 index 4dde819652..8c2f601333 100644
--- a/src/backend/utils/misc/guc.c --- a/src/backend/utils/misc/guc.c
+++ b/src/backend/utils/misc/guc.c +++ b/src/backend/utils/misc/guc.c
@@ -3196,7 +3196,7 @@ static struct config_string ConfigureNamesString[] = @@ -4159,7 +4159,7 @@ static struct config_string ConfigureNamesString[] =
}, },
&Unix_socket_directories, &Unix_socket_directories,
#ifdef HAVE_UNIX_SOCKETS #ifdef HAVE_UNIX_SOCKETS
@ -26,10 +26,10 @@ index 9481f2d..75532c7 100644
"", "",
#endif #endif
diff --git a/src/bin/initdb/initdb.c b/src/bin/initdb/initdb.c diff --git a/src/bin/initdb/initdb.c b/src/bin/initdb/initdb.c
index feeff9e..3e3d784 100644 index 4ff0c6c700..6ccd96b1f2 100644
--- a/src/bin/initdb/initdb.c --- a/src/bin/initdb/initdb.c
+++ b/src/bin/initdb/initdb.c +++ b/src/bin/initdb/initdb.c
@@ -1234,7 +1234,7 @@ setup_config(void) @@ -1091,7 +1091,7 @@ setup_config(void)
#ifdef HAVE_UNIX_SOCKETS #ifdef HAVE_UNIX_SOCKETS
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = '%s'", snprintf(repltok, sizeof(repltok), "#unix_socket_directories = '%s'",
@ -39,15 +39,15 @@ index feeff9e..3e3d784 100644
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = ''"); snprintf(repltok, sizeof(repltok), "#unix_socket_directories = ''");
#endif #endif
diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
index e278fa0..9ee15d4 100644 index 8f3ec6bde1..066daf3f08 100644
--- a/src/include/pg_config_manual.h --- a/src/include/pg_config_manual.h
+++ b/src/include/pg_config_manual.h +++ b/src/include/pg_config_manual.h
@@ -169,7 +169,7 @@ @@ -203,7 +203,7 @@
* here's where to twiddle it. You can also override this at runtime #ifndef WIN32
* with the postmaster's -k switch. #define DEFAULT_PGSOCKET_DIR "/tmp"
*/ #else
-#define DEFAULT_PGSOCKET_DIR "/tmp" -#define DEFAULT_PGSOCKET_DIR ""
+#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql" +#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
#endif
/* /*
* This is the default event source for Windows event log.

View File

@ -10,6 +10,19 @@ index 67e7998f55..86612a42c3 100644
installdirs: installdirs:
$(MKDIR_P) '$(DESTDIR)$(pgxsdir)/config' $(MKDIR_P) '$(DESTDIR)$(pgxsdir)/config'
diff --git a/src/Makefile.shlib b/src/Makefile.shlib
index 29a7f6d38c..d7599a3e16 100644
--- a/src/Makefile.shlib
+++ b/src/Makefile.shlib
@@ -215,7 +215,7 @@ ifeq ($(PORTNAME), linux)
ifdef soname
LINK.shared += -Wl,-soname,$(soname)
endif
- BUILD.exports = ( echo '{ global:'; $(AWK) '/^[^\#]/ {printf "%s;\n",$$1}' $<; echo ' local: *; };' ) >$@
+ BUILD.exports = $(SHELL) $(top_srcdir)/config/build-exports-gnu-ld < $< > $@
exports_file = $(SHLIB_EXPORTS:%.txt=%.list)
ifneq (,$(exports_file))
LINK.shared += -Wl,--version-script=$(exports_file)
diff --git a/config/build-exports-gnu-ld b/config/build-exports-gnu-ld diff --git a/config/build-exports-gnu-ld b/config/build-exports-gnu-ld
new file mode 100755 new file mode 100755
index 0000000000..84c48e3ade index 0000000000..84c48e3ade
@ -30,56 +43,49 @@ index 0000000000..84c48e3ade
+ +
+open_block () +open_block ()
+{ +{
+ $first || echo + $first || echo
+ first=false + first=false
+ echo "${SYMBOL_VERSION_PREFIX}$version {" + echo "${SYMBOL_VERSION_PREFIX}$version {"
+ echo "global:" + echo "global:"
+} +}
+ +
+close_block () +close_block ()
+{ +{
+ echo "}${version_prev:+ $SYMBOL_VERSION_PREFIX$version_prev};" + echo "}${version_prev:+ $SYMBOL_VERSION_PREFIX$version_prev};"
+ version_prev=$version + version_prev=$version
+ version=$1 + version=$1
+} +}
+ +
+open_block +open_block
+while read -r symbol _ new_version +while read -r symbol _ new_version
+do +do
+ case $symbol in '#'*) continue ;; esac + case $symbol in '#'*) continue ;; esac
+ if test -n "$new_version" && test "$new_version" != "$version"; then + if test -n "$new_version" && test "$new_version" != "$version"; then
+ close_block "$new_version" + close_block "$new_version"
+ open_block + open_block
+ fi + fi
+ echo " $symbol;" + echo " $symbol;"
+done +done
+ +
+echo "local:" +echo "local:"
+echo " *;" +echo " *;"
+close_block +close_block
diff --git a/src/Makefile.shlib b/src/Makefile.shlib
index 373d73caef..d5bd5468cd 100644
--- a/src/Makefile.shlib
+++ b/src/Makefile.shlib
@@ -231,7 +231,7 @@ ifeq ($(PORTNAME), linux)
ifdef soname
LINK.shared += -Wl,-soname,$(soname)
endif
- BUILD.exports = ( echo '{ global:'; $(AWK) '/^[^\#]/ {printf "%s;\n",$$1}' $<; echo ' local: *; };' ) >$@
+ BUILD.exports = $(SHELL) $(top_srcdir)/config/build-exports-gnu-ld < $< > $@
exports_file = $(SHLIB_EXPORTS:%.txt=%.list)
ifneq (,$(exports_file))
LINK.shared += -Wl,--version-script=$(exports_file)
diff --git a/src/interfaces/libpq/exports.txt b/src/interfaces/libpq/exports.txt diff --git a/src/interfaces/libpq/exports.txt b/src/interfaces/libpq/exports.txt
index 7c808e5215..3631340b23 100644 index bbc1f90481..0b00a94279 100644
--- a/src/interfaces/libpq/exports.txt --- a/src/interfaces/libpq/exports.txt
+++ b/src/interfaces/libpq/exports.txt +++ b/src/interfaces/libpq/exports.txt
@@ -171,7 +171,7 @@ PQsslAttributeNames 168 @@ -171,11 +171,11 @@ PQsslAttributeNames 168
PQsslAttribute 169 PQsslAttribute 169
PQsetErrorContextVisibility 170 PQsetErrorContextVisibility 170
PQresultVerboseErrorMessage 171 PQresultVerboseErrorMessage 171
-PQencryptPasswordConn 172 -PQencryptPasswordConn 172
+PQencryptPasswordConn 172 10 -PQresultMemorySize 173
PQresultMemorySize 173 +PQencryptPasswordConn 172 10
+PQresultMemorySize 173 12
PQhostaddr 174 PQhostaddr 174
PQgssEncInUse 175 PQgssEncInUse 175
-PQgetgssctx 176
+PQgetgssctx 176 13
PQsetSSLKeyPassHook_OpenSSL 177
PQgetSSLKeyPassHook_OpenSSL 178
PQdefaultSSLKeyPassHook_OpenSSL 179

View File

@ -1,9 +1,9 @@
%global majorversion 12 %global majorversion 13
%global obsoletes_version %( echo $(( %majorversion + 1 )) ) %global obsoletes_version %( echo $(( %majorversion + 1 )) )
Summary: PostgreSQL client library Summary: PostgreSQL client library
Name: libpq Name: libpq
Version: %{majorversion}.4 Version: %{majorversion}.0
Release: 1%{?dist} Release: 1%{?dist}
License: PostgreSQL License: PostgreSQL
@ -130,6 +130,9 @@ find_lang_bins %name-devel.lst pg_config
%changelog %changelog
* Wed Oct 14 2020 Patrik Novotný <panovotn@redhat.com> - 13.0-1
- Rebase to upstream release 13.0
* Tue Aug 18 2020 Patrik Novotný <panovotn@redhat.com> - 12.4-1 * Tue Aug 18 2020 Patrik Novotný <panovotn@redhat.com> - 12.4-1
- Rebase to upstream release 12.4 - Rebase to upstream release 12.4

View File

@ -1,2 +1,2 @@
SHA512 (postgresql-12.4.tar.bz2) = 36daf10878ca153370829178786dd6ee366ab4d4d6dc9c527536740fdb14b688ae4c33f850eb4243a7667d23f87e4bfd1ddee0755447ad4f3996e423e391c2f3 SHA512 (postgresql-13.0.tar.bz2) = 1fde89487c3e50a7a07e1d42fba60d415645ea89c5d4c5c7fcc93fbd5330feca7ec991d5b274f6ab757d5d04667ca1a7efdf4eaaa760add19d2e02437465f8f5
SHA512 (postgresql-12.4.tar.bz2.sha256) = d5c6d9c6cf189f0ef9c4ebac18782f25c0ff8420d0b063217f4ac250cca4706ec782e983326ffcb23258bcd5bf17b481e53d84aeb85b5744bfd90ea1bd33431a SHA512 (postgresql-13.0.tar.bz2.sha256) = 147e2fa96eb8aab3c80dfbfdcf2dbd220599ec9c2200bd890e30e5a8a65b3136b035835444ab2c98368ac53c8ae190d83999e344ee6b52c069b3cd6d157dd34e