import CS libpq-13.11-1.el9

This commit is contained in:
eabdullin 2023-10-19 08:34:29 +00:00
parent 6a422a08dc
commit 6bc521d00d
8 changed files with 105 additions and 61 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/postgresql-13.5.tar.bz2 SOURCES/postgresql-13.11.tar.bz2

View File

@ -1 +1 @@
9321e2b01d1ffb15adae06945cb2c5f9dd671bc9 SOURCES/postgresql-13.5.tar.bz2 501acb24ba8539c08ba12b08adecd7559bf87e1b SOURCES/postgresql-13.11.tar.bz2

View File

@ -7,11 +7,11 @@ directory whose path happens to include "postgres" or "pgsql" already.
However, datadir and sysconfdir are already set up in the specfile's However, datadir and sysconfdir are already set up in the specfile's
configure call, so we do not have to append anything to them. configure call, so we do not have to append anything to them.
diff --git a/src/Makefile.global.in b/src/Makefile.global.in
diff -Naur postgresql-9.0.1.orig/src/Makefile.global.in postgresql-9.0.1/src/Makefile.global.in index 9a6265b3a0..c9371a07c4 100644
--- postgresql-9.0.1.orig/src/Makefile.global.in 2010-10-01 10:25:44.000000000 -0400 --- a/src/Makefile.global.in
+++ postgresql-9.0.1/src/Makefile.global.in 2010-10-11 11:52:05.224975308 -0400 +++ b/src/Makefile.global.in
@@ -55,8 +55,7 @@ @@ -82,8 +82,7 @@ vpathsearch = `for f in $(addsuffix /$(1),$(subst :, ,. $(VPATH))); do test -r $
# Installation directories # Installation directories
# #
# These are set by the equivalent --xxxdir configure options. We # These are set by the equivalent --xxxdir configure options. We
@ -21,7 +21,7 @@ diff -Naur postgresql-9.0.1.orig/src/Makefile.global.in postgresql-9.0.1/src/Mak
# #
# In a PGXS build, we cannot use the values inserted into Makefile.global # In a PGXS build, we cannot use the values inserted into Makefile.global
# by configure, since the installation tree may have been relocated. # by configure, since the installation tree may have been relocated.
@@ -74,45 +73,23 @@ @@ -101,45 +100,23 @@ datarootdir := @datarootdir@
bindir := @bindir@ bindir := @bindir@
datadir := @datadir@ datadir := @datadir@

View File

@ -13,10 +13,10 @@ to be updated. (Of course, a user who dislikes this behavior can still
override it via postgresql.conf.) override it via postgresql.conf.)
diff --git a/src/backend/utils/misc/guc.c b/src/backend/utils/misc/guc.c diff --git a/src/backend/utils/misc/guc.c b/src/backend/utils/misc/guc.c
index 9481f2d..75532c7 100644 index 4dde819652..8c2f601333 100644
--- a/src/backend/utils/misc/guc.c --- a/src/backend/utils/misc/guc.c
+++ b/src/backend/utils/misc/guc.c +++ b/src/backend/utils/misc/guc.c
@@ -3196,7 +3196,7 @@ static struct config_string ConfigureNamesString[] = @@ -4159,7 +4159,7 @@ static struct config_string ConfigureNamesString[] =
}, },
&Unix_socket_directories, &Unix_socket_directories,
#ifdef HAVE_UNIX_SOCKETS #ifdef HAVE_UNIX_SOCKETS
@ -26,10 +26,10 @@ index 9481f2d..75532c7 100644
"", "",
#endif #endif
diff --git a/src/bin/initdb/initdb.c b/src/bin/initdb/initdb.c diff --git a/src/bin/initdb/initdb.c b/src/bin/initdb/initdb.c
index feeff9e..3e3d784 100644 index 4ff0c6c700..6ccd96b1f2 100644
--- a/src/bin/initdb/initdb.c --- a/src/bin/initdb/initdb.c
+++ b/src/bin/initdb/initdb.c +++ b/src/bin/initdb/initdb.c
@@ -1234,7 +1234,7 @@ setup_config(void) @@ -1091,7 +1091,7 @@ setup_config(void)
#ifdef HAVE_UNIX_SOCKETS #ifdef HAVE_UNIX_SOCKETS
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = '%s'", snprintf(repltok, sizeof(repltok), "#unix_socket_directories = '%s'",
@ -39,7 +39,7 @@ index feeff9e..3e3d784 100644
snprintf(repltok, sizeof(repltok), "#unix_socket_directories = ''"); snprintf(repltok, sizeof(repltok), "#unix_socket_directories = ''");
#endif #endif
diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
index e278fa0..9ee15d4 100644 index 8f3ec6bde1..066daf3f08 100644
--- a/src/include/pg_config_manual.h --- a/src/include/pg_config_manual.h
+++ b/src/include/pg_config_manual.h +++ b/src/include/pg_config_manual.h
@@ -201,7 +201,7 @@ @@ -201,7 +201,7 @@

View File

@ -1,10 +1,13 @@
- The libpq package is supposed to be used for all the PostgreSQL modules commit 75040c3388d9a7dd5ad2bee53cbcc8bf3d35cd17
Author: Honza Horak <hhorak@redhat.com>
Date: Fri Oct 30 20:16:50 2020 +0100
- available in RHEL 8, and ABI versioning will guarantee us that modular RPMs will The libpq package is supposed to be used for all the PostgreSQL modules
- depend on appropriate libpq ABI version (picked at build-time). available in RHEL 8, and ABI versioning will guarantee us that modular RPMs will
depend on appropriate libpq ABI version (picked at build-time).
diff --git a/config/Makefile b/config/Makefile diff --git a/config/Makefile b/config/Makefile
index 67e7998f55..86612a42c3 100644 index 67e7998..86612a4 100644
--- a/config/Makefile --- a/config/Makefile
+++ b/config/Makefile +++ b/config/Makefile
@@ -8,6 +8,7 @@ include $(top_builddir)/src/Makefile.global @@ -8,6 +8,7 @@ include $(top_builddir)/src/Makefile.global
@ -76,16 +79,16 @@ index 373d73caef..d5bd5468cd 100644
ifneq (,$(exports_file)) ifneq (,$(exports_file))
LINK.shared += -Wl,--version-script=$(exports_file) LINK.shared += -Wl,--version-script=$(exports_file)
diff --git a/src/interfaces/libpq/exports.txt b/src/interfaces/libpq/exports.txt diff --git a/src/interfaces/libpq/exports.txt b/src/interfaces/libpq/exports.txt
index ccec59919b..4c2be8b7d5 100644 index bbc1f90..fc3ef8a 100644
--- a/src/interfaces/libpq/exports.txt --- a/src/interfaces/libpq/exports.txt
+++ b/src/interfaces/libpq/exports.txt +++ b/src/interfaces/libpq/exports.txt
@@ -171,11 +171,11 @@ @@ -171,11 +171,11 @@ PQsslAttributeNames 168
PQsslAttribute 169 PQsslAttribute 169
PQsetErrorContextVisibility 170 PQsetErrorContextVisibility 170
PQresultVerboseErrorMessage 171 PQresultVerboseErrorMessage 171
-PQencryptPasswordConn 172 -PQencryptPasswordConn 172
-PQresultMemorySize 173
+PQencryptPasswordConn 172 10 +PQencryptPasswordConn 172 10
-PQresultMemorySize 173
+PQresultMemorySize 173 12 +PQresultMemorySize 173 12
PQhostaddr 174 PQhostaddr 174
PQgssEncInUse 175 PQgssEncInUse 175

View File

@ -0,0 +1 @@
4992ff647203566b670d4e54dc5317499a26856c93576d0ea951bdf6bee50bfb postgresql-13.11.tar.bz2

View File

@ -1 +0,0 @@
9b81067a55edbaabc418aacef457dd8477642827499560b00615a6ea6c13f6b3 postgresql-13.5.tar.bz2

View File

@ -3,7 +3,7 @@
Summary: PostgreSQL client library Summary: PostgreSQL client library
Name: libpq Name: libpq
Version: %{majorversion}.5 Version: %{majorversion}.11
Release: 1%{?dist} Release: 1%{?dist}
License: PostgreSQL License: PostgreSQL
@ -16,7 +16,7 @@ Source1: https://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}
# Comments for these patches are in the patch files. # Comments for these patches are in the patch files.
Patch1: libpq-10.3-rpm-pgsql.patch Patch1: libpq-10.3-rpm-pgsql.patch
Patch2: libpq-10.3-var-run-socket.patch Patch2: libpq-10.3-var-run-socket.patch
Patch3: libpq-13.1-symbol-versioning.patch Patch3: libpq-12.1-symbol-versioning.patch
BuildRequires: gcc BuildRequires: gcc
BuildRequires: glibc-devel bison flex gawk BuildRequires: glibc-devel bison flex gawk
@ -26,6 +26,7 @@ BuildRequires: krb5-devel
BuildRequires: openldap-devel BuildRequires: openldap-devel
BuildRequires: gettext BuildRequires: gettext
BuildRequires: multilib-rpm-config BuildRequires: multilib-rpm-config
BuildRequires: make
Obsoletes: postgresql-libs < %obsoletes_version Obsoletes: postgresql-libs < %obsoletes_version
Provides: postgresql-libs = %version-%release Provides: postgresql-libs = %version-%release
@ -56,7 +57,7 @@ package or any clients that need to connect to a PostgreSQL server.
%prep %prep
( cd "$(dirname "%SOURCE1")" ; sha256sum -c "%SOURCE1" ) ( cd "$(dirname "%SOURCE1")" ; sha256sum -c "%SOURCE1" )
%autosetup -n postgresql-%{version} -p1 %autosetup -n postgresql-%version -p1
# remove .gitignore files to ensure none get into the RPMs (bug #642210) # remove .gitignore files to ensure none get into the RPMs (bug #642210)
find . -type f -name .gitignore | xargs rm find . -type f -name .gitignore | xargs rm
@ -117,7 +118,7 @@ find_lang_bins %name-devel.lst pg_config
%files -f %name.lst %files -f %name.lst
%license COPYRIGHT %license COPYRIGHT
%_libdir/libpq.so.* %_libdir/libpq.so.5*
%dir %_datadir/pgsql %dir %_datadir/pgsql
%doc %_datadir/pgsql/pg_service.conf.sample %doc %_datadir/pgsql/pg_service.conf.sample
@ -130,55 +131,95 @@ find_lang_bins %name-devel.lst pg_config
%changelog %changelog
* Mon Nov 29 2021 Marek Kulik <mkulik@redhat.com> - 13.5-1 * Mon May 29 2023 Dominik Rehák <drehak@redhat.com> - 13.11-1
- Rebase to 13.5 - Update to 13.11
Resolves: #2023294 Resolves: #2171370
* Mon May 31 2021 Honza Horak <hhorak@redhat.com> - 13.3-1 * Tue Nov 16 2021 Marek Kulik <mkulik@redhat.com> - 13.5-1
- Rebase to 13.3 - Update to 13.5
Resolves: #1966146
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 13.2-4
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688
* Wed Jun 16 2021 Mohan Boddu <mboddu@redhat.com> - 13.2-3
- Rebuilt for RHEL 9 BETA for openssl 3.0
Related: rhbz#1971065
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 13.2-2
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
* Tue Feb 16 2021 Honza Horak <hhorak@redhat.com> - 13.2-1 * Tue Feb 16 2021 Honza Horak <hhorak@redhat.com> - 13.2-1
- Rebase to 13.2 - Update to 13.2
Related: #1855776
* Tue Nov 17 2020 Patrik Novotný <panovotn@redhat.com> - 13.1-1 * Mon Feb 08 2021 Patrik Novotný <panovotn@redhat.com> - 13.1-3
- Fix symbol versioning
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 13.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Mon Nov 16 2020 Patrik Novotný <panovotn@redhat.com> - 13.1-1
- Rebase to upstream release 13.1 - Rebase to upstream release 13.1
Resolves: BZ#1855776
(BZ#1856242 particuarly)
* Mon Aug 17 2020 Patrik Novotný <panovotn@redhat.com> - 12.4-1 * Mon Nov 02 2020 Patrik Novotný <panovotn@redhat.com> - 13.0-2
- Rebuild for symbol versioning fix
* Wed Oct 14 2020 Patrik Novotný <panovotn@redhat.com> - 13.0-1
- Rebase to upstream release 13.0
* Tue Aug 18 2020 Patrik Novotný <panovotn@redhat.com> - 12.4-1
- Rebase to upstream release 12.4 - Rebase to upstream release 12.4
* Tue Jun 16 2020 Patrik Novotný <panovotn@redhat.com> - 12.3-1 * Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 12.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Mon May 18 2020 Patrik Novotný <panovotn@redhat.com> - 12.3-1
- Rebase to upstream release 12.3 - Rebase to upstream release 12.3
* Tue Nov 19 2019 Patrik Novotný <panovotn@redhat.com> - 12.1-3 * Mon Feb 17 2020 Patrik Novotný <panovotn@redhat.com> - 12.2-1
- Rebuild with rebased symbol versioning patch - Rebase to upstream release 12.2
* Fri Nov 15 2019 Patrik Novotný <panovotn@redhat.com> - 12.1-2 * Tue Feb 04 2020 Patrik Novotný <panovotn@redhat.com> - 12.1-1
- Rebuild with rebased symbol versioning patch
* Tue Nov 12 2019 Patrik Novotný <panovotn@redhat.com> - 12.1-1
- Rebase to upstream release 12.1 - Rebase to upstream release 12.1
* Fri Nov 08 2019 Honza Horak <hhorak@redhat.com> - 12.0-2 * Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 11.6-2
- Bump release for a new build with gating.yaml added - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
Related: #1749461
* Thu Oct 03 2019 Patrik Novotný <panovotn@redhat.com> - 12.0-1 * Mon Nov 25 2019 Patrik Novotný <panovotn@redhat.com> - 11.6-1
- Initial release for upstream version 12.0 - Rebase to upstream version 11.6
* Wed Aug 08 2018 Pavel Raiskup <praiskup@redhat.com> - 10.5-1 * Wed Aug 07 2019 Petr Kubat <pkubat@redhat.com> - 11.5-1
- update to 10.5 per release notes: - New upstream version 11.5
https://www.postgresql.org/docs/10/static/release-10-5.html
* Fri Jul 13 2018 Pavel Raiskup <praiskup@redhat.com> - 10.4-2 * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 11.4-2
- ABI/symbol versioning - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Thu Jul 12 2018 Pavel Raiskup <praiskup@redhat.com> - 10.4-1 * Tue Jul 09 2019 Petr Kubat <pkubat@redhat.com> - 11.4-1
- rebase to the latest upstream release - New upstream version 11.4
* Fri Apr 13 2018 Pavel Raiskup <praiskup@redhat.com> - 10.3-1 * Fri May 10 2019 Pavel Raiskup <praiskup@redhat.com> - 11.3-2
- initial release, packaging inspired by postgresql.spec - obsolete anything < %%majorversion+1
- provide postgresql-devel to avoid fixing all the client packages
* Thu May 09 2019 Patrik Novotný <panovotn@redhat.com> - 11.3-1
- New upstream version 11.3
* Mon Feb 18 2019 Pavel Raiskup <praiskup@redhat.com> - 11.2-2
- fix dnf system-upgrade from f29 to f29+, rhbz#1677849
* Thu Feb 14 2019 Pavel Raiskup <praiskup@redhat.com> - 11.2-1
- latest upstream release, per release notes:
https://www.postgresql.org/docs/11/static/release-11-1.html
https://www.postgresql.org/docs/11/static/release-11-2.html
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 11.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Oct 16 2018 Pavel Raiskup <praiskup@redhat.com> - 11.0-1
- latest upstream release, per release notes:
https://www.postgresql.org/docs/11/static/release-11-0.html
* Tue Sep 04 2018 Pavel Raiskup <praiskup@redhat.com> - 10.5-4
- fix provides/obsoletes to final state
* Thu Aug 30 2018 Pavel Raiskup <praiskup@redhat.com> - 10.5-1
- libpq packaging for Fedora