Rebase to libpfm-4.3.0.
This commit is contained in:
parent
ec48aaa168
commit
95ba25063d
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/libpfm-4.2.0.tar.gz
|
/libpfm-4.3.0.tar.gz
|
||||||
|
11
libpfm-ldconf.patch
Normal file
11
libpfm-ldconf.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up libpfm-4.2.0/lib/Makefile.orig libpfm-4.2.0/lib/Makefile
|
||||||
|
--- libpfm-4.2.0/lib/Makefile.orig 2012-08-27 14:22:31.855449622 -0400
|
||||||
|
+++ libpfm-4.2.0/lib/Makefile 2012-08-27 14:23:01.783526784 -0400
|
||||||
|
@@ -244,7 +244,6 @@ ifeq ($(CONFIG_PFMLIB_SHARED),y)
|
||||||
|
$(INSTALL) $(SLIBPFM) $(DESTDIR)$(LIBDIR)
|
||||||
|
cd $(DESTDIR)$(LIBDIR); $(LN) $(SLIBPFM) $(VLIBPFM)
|
||||||
|
cd $(DESTDIR)$(LIBDIR); $(LN) $(SLIBPFM) libpfm.$(SOLIBEXT)
|
||||||
|
- $(LDCONFIG)
|
||||||
|
endif
|
||||||
|
|
||||||
|
tags:
|
@ -1,24 +0,0 @@
|
|||||||
diff -up libpfm-4.2.0/perf_examples/notify_group.c.siginfo_t libpfm-4.2.0/perf_examples/notify_group.c
|
|
||||||
--- libpfm-4.2.0/perf_examples/notify_group.c.siginfo_t 2012-06-07 14:48:30.969999948 -0400
|
|
||||||
+++ libpfm-4.2.0/perf_examples/notify_group.c 2012-06-07 14:49:13.124000197 -0400
|
|
||||||
@@ -51,7 +51,7 @@ static int num_fds;
|
|
||||||
static int buffer_pages = 1; /* size of buffer payload (must be power of 2) */
|
|
||||||
|
|
||||||
static void
|
|
||||||
-sigio_handler(int n, struct siginfo *info, struct sigcontext *sc)
|
|
||||||
+sigio_handler(int n, siginfo_t *info, struct sigcontext *sc)
|
|
||||||
{
|
|
||||||
struct perf_event_mmap_page *hdr;
|
|
||||||
struct perf_event_header ehdr;
|
|
||||||
diff -up libpfm-4.2.0/perf_examples/notify_self.c.siginfo_t libpfm-4.2.0/perf_examples/notify_self.c
|
|
||||||
--- libpfm-4.2.0/perf_examples/notify_self.c.siginfo_t 2012-06-07 14:48:39.559998906 -0400
|
|
||||||
+++ libpfm-4.2.0/perf_examples/notify_self.c 2012-06-07 14:49:02.143000006 -0400
|
|
||||||
@@ -47,7 +47,7 @@ static int num_fds = 0;
|
|
||||||
static int buffer_pages = 1; /* size of buffer payload (must be power of 2)*/
|
|
||||||
|
|
||||||
static void
|
|
||||||
-sigio_handler(int n, struct siginfo *info, void *uc)
|
|
||||||
+sigio_handler(int n, siginfo_t *info, void *uc)
|
|
||||||
{
|
|
||||||
struct perf_event_header ehdr;
|
|
||||||
int ret, id;
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -up libpfm-4.2.0/python/src/perfmon_int.i.ill libpfm-4.2.0/python/src/perfmon_int.i
|
|
||||||
--- libpfm-4.2.0/python/src/perfmon_int.i.ill 2012-06-08 12:39:16.872998571 -0400
|
|
||||||
+++ libpfm-4.2.0/python/src/perfmon_int.i 2012-06-08 12:39:30.183000006 -0400
|
|
||||||
@@ -92,7 +92,6 @@ ptr_argout(pfm_event_attr_info_t);
|
|
||||||
|
|
||||||
/* Kernel interface */
|
|
||||||
%include <perfmon/perf_event.h>
|
|
||||||
-ptr_argout(perf_event_attr_t);
|
|
||||||
|
|
||||||
/* Library interface */
|
|
||||||
/* We never set the const char * members. So no memory leak */
|
|
15
libpfm.spec
15
libpfm.spec
@ -9,8 +9,8 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: libpfm
|
Name: libpfm
|
||||||
Version: 4.2.0
|
Version: 4.3.0
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
Summary: Library to encode performance events for use by perf tool
|
Summary: Library to encode performance events for use by perf tool
|
||||||
|
|
||||||
@ -18,9 +18,7 @@ Group: System Environment/Libraries
|
|||||||
License: MIT
|
License: MIT
|
||||||
URL: http://perfmon2.sourceforge.net/
|
URL: http://perfmon2.sourceforge.net/
|
||||||
Source0: http://sourceforge.net/projects/perfmon2/files/libpfm4/%{name}-%{version}.tar.gz
|
Source0: http://sourceforge.net/projects/perfmon2/files/libpfm4/%{name}-%{version}.tar.gz
|
||||||
Patch1: libpfm4-python.patch
|
Patch4: libpfm-ldconf.patch
|
||||||
Patch2: libpfm-siginfo_t.patch
|
|
||||||
Patch3: libpfm-swig.patch
|
|
||||||
|
|
||||||
%if %{with python}
|
%if %{with python}
|
||||||
BuildRequires: python-devel
|
BuildRequires: python-devel
|
||||||
@ -65,9 +63,7 @@ Python bindings for libpfm4 and perf_event_open system call.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1
|
%patch4 -p1
|
||||||
%patch2 -p1
|
|
||||||
%patch3 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if %{with python}
|
%if %{with python}
|
||||||
@ -114,6 +110,9 @@ make \
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 28 2012 William Cohen <wcohen@redhat.com> 4.3.0-1
|
||||||
|
- Rebase on libpfm-4.3.0.
|
||||||
|
|
||||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
|
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.0-8
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
@ -1,35 +0,0 @@
|
|||||||
From fe0b30189334f048db0cab10987b9e2295c5b93c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Arun Sharma <asharma@fb.com>
|
|
||||||
Date: Thu, 26 Apr 2012 17:37:02 +0200
|
|
||||||
Subject: [PATCH] drop shbang from python scripts
|
|
||||||
|
|
||||||
do not make then executable by dropping the
|
|
||||||
!/usr/bin/env python invocation.
|
|
||||||
|
|
||||||
Signed-off-by: Arun Sharma <asharma@fb.com>
|
|
||||||
---
|
|
||||||
python/src/pmu.py | 1 -
|
|
||||||
python/src/session.py | 1 -
|
|
||||||
2 files changed, 0 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/python/src/pmu.py b/python/src/pmu.py
|
|
||||||
index e90b72a..47c3e75 100644
|
|
||||||
--- a/python/src/pmu.py
|
|
||||||
+++ b/python/src/pmu.py
|
|
||||||
@@ -1,4 +1,3 @@
|
|
||||||
-#!/usr/bin/env python
|
|
||||||
#
|
|
||||||
# Copyright (c) 2008 Google, Inc.
|
|
||||||
# Contributed by Arun Sharma <arun.sharma@google.com>
|
|
||||||
diff --git a/python/src/session.py b/python/src/session.py
|
|
||||||
index df22ea6..f598aa4 100644
|
|
||||||
--- a/python/src/session.py
|
|
||||||
+++ b/python/src/session.py
|
|
||||||
@@ -1,4 +1,3 @@
|
|
||||||
-#!/usr/bin/env python
|
|
||||||
#
|
|
||||||
# Copyright (c) 2008 Google, Inc.
|
|
||||||
# Contributed by Arun Sharma <arun.sharma@google.com>
|
|
||||||
--
|
|
||||||
1.7.4.1
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user