Obsolete package

This commit is contained in:
William Eden Cohen 2010-02-26 20:47:57 +00:00
parent 96c665b0cb
commit 1d75737b06
8 changed files with 2 additions and 276 deletions

View File

@ -1 +0,0 @@
libpfm-3.5.tar.gz

View File

@ -1,21 +0,0 @@
# Makefile for source rpm: libpfm
# $Id: Makefile,v 1.2 2007/10/15 19:03:58 notting Exp $
NAME := libpfm
SPECFILE = $(firstword $(wildcard *.spec))
define find-makefile-common
for d in common ../common ../../common ; do if [ -f $$d/Makefile.common ] ; then if [ -f $$d/CVS/Root -a -w $$d/Makefile.common ] ; then cd $$d ; cvs -Q update ; fi ; echo "$$d/Makefile.common" ; break ; fi ; done
endef
MAKEFILE_COMMON := $(shell $(find-makefile-common))
ifeq ($(MAKEFILE_COMMON),)
# attempt a checkout
define checkout-makefile-common
test -f CVS/Root && { cvs -Q -d $$(cat CVS/Root) checkout common && echo "common/Makefile.common" ; } || { echo "ERROR: I can't figure out how to checkout the 'common' module." ; exit -1 ; } >&2
endef
MAKEFILE_COMMON := $(shell $(checkout-makefile-common))
endif
include $(MAKEFILE_COMMON)

2
dead.package Normal file
View File

@ -0,0 +1,2 @@
Obsolete package

View File

@ -1,20 +0,0 @@
--- libpfm-3.2-060926/rules.mk.rpm_opt 2006-09-26 08:21:37.000000000 -0400
+++ libpfm-3.2-060926/rules.mk 2006-10-01 21:33:10.000000000 -0400
@@ -25,12 +25,12 @@
.SUFFIXES: .c .S .o .lo .cpp
.S.o:
- $(CC) $(CFLAGS) -c $*.S
+ $(CC) $(CFLAGS) $(RPM_OPT_FLAGS) -c $*.S
.c.o:
- $(CC) $(CFLAGS) -c $*.c
+ $(CC) $(CFLAGS) $(RPM_OPT_FLAGS) -c $*.c
.cpp.o:
- $(CXX) $(CFLAGS) -c $*.cpp
+ $(CXX) $(CFLAGS) $(RPM_OPT_FLAGS) -c $*.cpp
.c.lo:
- $(CC) -fPIC -DPIC $(CFLAGS) -c $*.c -o $*.lo
+ $(CC) -fPIC -DPIC $(CFLAGS) $(RPM_OPT_FLAGS) -c $*.c -o $*.lo
.S.lo:
- $(CC) -fPIC -DPIC $(CFLAGS) -c $*.S -o $*.lo
+ $(CC) -fPIC -DPIC $(CFLAGS) $(RPM_OPT_FLAGS) -c $*.S -o $*.lo

View File

@ -1,12 +0,0 @@
diff -up libpfm-3.3/lib/pfmlib_itanium2.c.broken libpfm-3.3/lib/pfmlib_itanium2.c
--- libpfm-3.3/lib/pfmlib_itanium2.c.broken 2008-02-26 10:47:03.000000000 -0500
+++ libpfm-3.3/lib/pfmlib_itanium2.c 2008-02-26 10:47:50.000000000 -0500
@@ -231,7 +231,7 @@ check_inst_retired_events(pfmlib_input_p
int code;
int c;
unsigned int i, count, found = 0;
- unsigned long umask, mask;
+ unsigned long umask = 0, mask;
pfm_get_event_code(PME_ITA2_IA64_INST_RETIRED_THIS, &code);

View File

@ -1,38 +0,0 @@
diff -up libpfm-3.5/examples/multiplex.c.unused libpfm-3.5/examples/multiplex.c
--- libpfm-3.5/examples/multiplex.c.unused 2008-07-31 16:58:21.000000000 -0400
+++ libpfm-3.5/examples/multiplex.c 2008-07-31 16:59:18.000000000 -0400
@@ -613,6 +613,7 @@ measure_one_cpu(char **argv)
struct pollfd pollfd;
pid_t pid = 0;
int ret, timeout;
+ int nbytes;
memset(ctx, 0, sizeof(ctx));
memset(&load_arg, 0, sizeof(load_arg));
@@ -721,7 +722,7 @@ measure_one_cpu(char **argv)
*/
if (options.opt_ovfl_switch) {
pfarg_msg_t msg;
- read(ctxid, &msg, sizeof(msg));
+ nbytes = read(ctxid, &msg, sizeof(msg));
}
switch_sets(ctxid);
break;
diff -up libpfm-3.5/lib/pfmlib_os_linux.c.unused libpfm-3.5/lib/pfmlib_os_linux.c
--- libpfm-3.5/lib/pfmlib_os_linux.c.unused 2008-07-30 17:16:40.000000000 -0400
+++ libpfm-3.5/lib/pfmlib_os_linux.c 2008-07-31 16:57:05.000000000 -0400
@@ -390,12 +390,13 @@ static int
pfm_init_syscalls_sysfs(void)
{
FILE *fp;
+ int nbytes;
fp = fopen("/sys/kernel/perfmon/syscall", "r");
if (!fp)
return -1;
- fscanf(fp, "%d", &sys_base);
+ nbytes = fscanf(fp, "%d", &sys_base);
fclose(fp);

View File

@ -1,183 +0,0 @@
Summary: A performance monitoring library for Linux
Name: libpfm
Version: 3.5
Release: 4%{?dist}
License: MIT
Group: Development/Libraries
ExclusiveArch: ia64 %{ix86} x86_64 ppc ppc64
ExclusiveOS: linux
Source: http://prdownloads.sourceforge.net/perfmon2/%{name}-%{version}.tar.gz
URL: http://sourceforge.net/projects/perfmon2/
Patch3: libpfm-3.2-rpm_opt.patch
#Patch4: libpfm-3.2-man3.patch
Patch5: libpfm-3.3-ia64-build.patch
Patch6: libpfm-3.4-unused.patch
BuildRequires: ncurses-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
This package contains a library to develop performance monitoring
applications using the Performance Monitor Unit (PMU) available on
various processors.
%package devel
Summary: the Linux performance library (libpfm) development files.
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description devel
The performance monitoring library (libpfm) is used to develop
performance monitoring applications using the Performance Monitoring
Unit (PMU) available on various processors. This package provides the
files necessary for development of applications.
It requires a kernel perfmon-2.x subsystem.
Requires: ncurses
%prep
%setup -q -n %{name}-%{version}
%patch3 -p1 -b .rpm_opt
#%patch4 -p1 -b .man3
%patch5 -p1 -b .ia64build
%patch6 -p1 -b .unused
%build
make PREFIX=/usr DESTDIR=%{buildroot} LIBDIR=%{_libdir}
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}
make install PREFIX=/usr DESTDIR=%{buildroot} LIBDIR=%{_libdir}
# If we need this static library, make a -static subpackage for it.
rm -rf %{buildroot}/%{_libdir}/*.a
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%clean
rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%doc README COPYRIGHT
%attr(755,root,root) %{_libdir}/*.so.*
%files devel
%defattr(-,root,root,-)
%{_mandir}/man3/*
%{_libdir}/libpfm.so
%{_includedir}/*
%changelog
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Thu Aug 7 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.5-2
- fix license tag
- package cleanups (drop static library, package shared bits correctly)
* Thu Jul 31 2008 Will Cohen <wcohen@redhat.com> - 3.5-1
- Update to libpfm-3.5.
* Fri May 2 2008 Will Cohen <wcohen@redhat.com> - 3.4-1
- Update to libpfm-3.4.
* Tue Feb 26 2008 Will Cohen <wcohen@redhat.com> - 3.3-0.080225.2
- Correct possibly unitialized variable umask. Resolves: rhbz #434968
* Mon Feb 25 2008 Will Cohen <wcohen@redhat.com> - 3.3-0.080225.1
- Update to libpfm-3.3.
* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.2-1.071017.1
- Autorebuild for GCC 4.3
* Wed Oct 24 2007 Will Cohen <wcohen@redhat.com> - 3.2-0.071017.1
- Update to libpfm-3.2-071017.
* Tue Aug 21 2007 Will Cohen <wcohen@redhat.com> - 3.2-0.061205.3
- rebuild
* Mon May 21 2007 Will Cohen <wcohen@redhat.com> - 3.2-0.061205.2
- Fix up rpmlint complaints.
* Mon Dec 4 2006 Will Cohen <wcohen@redhat.com> - 3.2-0.061205.1
- Update to libpfm-3.2-061205.
* Fri Nov 3 2006 Will Cohen <wcohen@redhat.com> - 3.2-0.060926.3
- Add dist tag to build.
* Sun Oct 1 2006 Will Cohen <wcohen@redhat.com> - 3.2-0.060926.2
- Eliminate unneeded libpfm-compa.tpatch.
* Sun Oct 1 2006 Will Cohen <wcohen@redhat.com> - 3.2-0.060926.1
- Update to libpfm-3.2-060926.
* Tue Sep 19 2006 Will Cohen <wcohen@redhat.com> - 3.2-0.060621.10
- Make sure fix works on i386. (#205221)
* Tue Sep 19 2006 Will Cohen <wcohen@redhat.com> - 3.2-0.060621.9
- Make sure libraries put in correct directory. (#205221)
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.2-0.060621.8.1
- rebuild
* Sat Jul 8 2006 Will Cohen <wcohen@redhat.com>
- Avoid pulling in the example ELF executable into /usr/share. (#198001)
- Mark man pages as documentation.
* Tue Jun 27 2006 Will Cohen <wcohen@redhat.com>
- Add ncurses requires.
- Add ncurses-devel buildprereq.
* Mon Jun 26 2006 Will Cohen <wcohen@redhat.com>
- Make sure that CFLAGS in pfmlib/lib/ is used.
- Separate build and install processes.
- Clean up the descriptions.
* Mon Jun 26 2006 Will Cohen <wcohen@redhat.com>
- Update to libpfm-3.2-060621.
* Wed Jun 14 2006 Will Cohen <wcohen@redhat.com>
- Update to libpfm-3.2-060613.
* Fri May 05 2006 Will Cohen <wcohen@redhat.com>
- fno-strict-aliasing so ia64 builds.
* Fri May 05 2006 Will Cohen <wcohen@redhat.com>
- make sure that perfmon_compat.h installed for ia64.
* Thu May 04 2006 Will Cohen <wcohen@redhat.com>
- Update to libpfm-3.2-060421.
* Thu Feb 09 2006 Florian La Roche <laroche@redhat.com>
- remove empty scripts
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.0-4.2
- rebuilt for new gcc4.1 snapshot and glibc changes
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt
* Mon Mar 14 2005 Will Cohen <wcohen@redhat.com>
- Bump rebuild with gcc4.
* Tue Oct 26 2004 Will Cohen <wcohen@redhat.com>
- Correct ownership of files.
* Mon Sep 27 2004 Will Cohen <wcohen@redhat.com>
- Correct spec file for build system.
* Mon Dec 1 2003 Stephane Eranian <eranian@hpl.hp.com>
- release 3.0 final version
* Thu Jan 02 2003 Stephane Eranian <eranian@hpl.hp.com>
- release final 2.0 version
* Fri Dec 20 2002 Stephane Eranian <eranian@hpl.hp.com>
- final 2.0 release
* Thu Dec 05 2002 Stephane Eranian <eranian@hpl.hp.com>
- initial release of the library as a standalone package
- see ChangeLog for actual log

View File

@ -1 +0,0 @@
01caa64e409d378bd420aca9d3bc6efb libpfm-3.5.tar.gz