- Update to libpfm-3.4.
This commit is contained in:
parent
b872444e25
commit
136b4c389a
@ -1 +1 @@
|
||||
libpfm-3.3.tar.gz
|
||||
libpfm-3.4.tar.gz
|
||||
|
22
libpfm-3.4-unused.patch
Normal file
22
libpfm-3.4-unused.patch
Normal file
@ -0,0 +1,22 @@
|
||||
diff -up libpfm-3.4/examples/self_pipe.c.unused libpfm-3.4/examples/self_pipe.c
|
||||
--- libpfm-3.4/examples/self_pipe.c.unused 2008-05-02 09:49:25.000000000 -0400
|
||||
+++ libpfm-3.4/examples/self_pipe.c 2008-05-02 09:49:40.000000000 -0400
|
||||
@@ -125,6 +125,7 @@ main(int argc, char **argv)
|
||||
size_t len;
|
||||
char *name;
|
||||
char c = '0';
|
||||
+ int nbytes;
|
||||
|
||||
/*
|
||||
* pass options to library (optional)
|
||||
@@ -312,8 +313,8 @@ main(int argc, char **argv)
|
||||
* ping pong loop
|
||||
*/
|
||||
while(!quit) {
|
||||
- write(pr[1], "c", 1);
|
||||
- read(pw[0], &c, 1);
|
||||
+ nbytes = write(pr[1], "c", 1);
|
||||
+ nbytes = read(pw[0], &c, 1);
|
||||
}
|
||||
|
||||
if (pfm_stop(ctx_fd))
|
13
libpfm.spec
13
libpfm.spec
@ -1,9 +1,9 @@
|
||||
%define DATE 080225
|
||||
%define libpfm_release 2
|
||||
%define DATE 080502
|
||||
%define libpfm_release 1
|
||||
Summary: A performance monitoring library for Linux/ia64
|
||||
Name: libpfm
|
||||
Version: 3.3
|
||||
Release: 0.%{DATE}.%{libpfm_release}%{?dist}
|
||||
Version: 3.4
|
||||
Release: %{libpfm_release}%{?dist}
|
||||
License: MIT-style
|
||||
Group: Development/Libraries
|
||||
ExclusiveArch: ia64 %{ix86} x86_64
|
||||
@ -15,6 +15,7 @@ URL: http://sourceforge.net/projects/perfmon2/
|
||||
Patch3: libpfm-3.2-rpm_opt.patch
|
||||
#Patch4: libpfm-3.2-man3.patch
|
||||
Patch5: libpfm-3.3-ia64-build.patch
|
||||
Patch6: libpfm-3.4-unused.patch
|
||||
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
@ -42,6 +43,7 @@ Requires: ncurses
|
||||
%patch3 -p1 -b .rpm_opt
|
||||
#%patch4 -p1 -b .man3
|
||||
%patch5 -p1 -b .ia64build
|
||||
%patch6 -p1 -b .unused
|
||||
|
||||
%build
|
||||
make PREFIX=/usr DESTDIR=%{buildroot} LIBDIR=%{_libdir}
|
||||
@ -70,6 +72,9 @@ rm -rf %{buildroot}
|
||||
%{_prefix}/include/*
|
||||
|
||||
%changelog
|
||||
* Fri May 2 2008 Will Cohen <wcohen@redhat.com> - 3.4-1
|
||||
- Update to libpfm-3.4.
|
||||
|
||||
* Tue Feb 26 2008 Will Cohen <wcohen@redhat.com> - 3.3-0.080225.2
|
||||
- Correct possibly unitialized variable umask. Resolves: rhbz #434968
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user