damn fuzz

This commit is contained in:
Dave Airlie 2009-07-31 01:31:29 +00:00
parent e312101c9a
commit 8dae812cd6

View File

@ -1,7 +1,6 @@
diff --git a/include/pciaccess.h b/include/pciaccess.h
index 6413ae0..9d68a08 100644
--- a/include/pciaccess.h
+++ b/include/pciaccess.h
diff -up libpciaccess-0.10.6/include/pciaccess.h.da libpciaccess-0.10.6/include/pciaccess.h
--- libpciaccess-0.10.6/include/pciaccess.h.da 2009-07-31 11:29:24.000000000 +1000
+++ libpciaccess-0.10.6/include/pciaccess.h 2009-07-31 11:29:36.000000000 +1000
@@ -21,6 +21,31 @@
* FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
* DEALINGS IN THE SOFTWARE.
@ -81,36 +80,10 @@ index 6413ae0..9d68a08 100644
+int pci_device_vgaarb_unlock (struct pci_device *dev);
+
#endif /* PCIACCESS_H */
diff --git a/src/Makefile.am b/src/Makefile.am
index 14f2e48..0de6894 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -45,6 +45,12 @@ if SOLARIS
OS_SUPPORT = solx_devfs.c pci_tools.h
endif
+if LINUX
+VGA_ARBITER = common_vgaarb.c
+else
+VGA_ARBITER = common_vgaarb_stub.c
+endif
+
libpciaccess_la_SOURCES = common_bridge.c \
common_iterator.c \
common_init.c \
@@ -53,6 +59,7 @@ libpciaccess_la_SOURCES = common_bridge.c \
common_device_name.c \
common_map.c \
pciaccess_private.h \
+ $(VGA_ARBITER) \
$(OS_SUPPORT)
INCLUDES = -I$(top_srcdir)/include
diff --git a/src/common_interface.c b/src/common_interface.c
index 5dcc707..d46feab 100644
--- a/src/common_interface.c
+++ b/src/common_interface.c
@@ -124,6 +124,21 @@ pci_device_is_boot_vga( struct pci_device * dev )
diff -up libpciaccess-0.10.6/src/common_interface.c.da libpciaccess-0.10.6/src/common_interface.c
--- libpciaccess-0.10.6/src/common_interface.c.da 2009-07-31 11:29:24.000000000 +1000
+++ libpciaccess-0.10.6/src/common_interface.c 2009-07-31 11:29:36.000000000 +1000
@@ -124,6 +124,21 @@ pci_device_is_boot_vga( struct pci_devic
}
/**
@ -132,11 +105,9 @@ index 5dcc707..d46feab 100644
* Probe a PCI device to learn information about the device.
*
* Probes a PCI device to learn various information about the device. Before
diff --git a/src/common_vgaarb.c b/src/common_vgaarb.c
new file mode 100644
index 0000000..302b89d
--- /dev/null
+++ b/src/common_vgaarb.c
diff -up /dev/null libpciaccess-0.10.6/src/common_vgaarb.c
--- /dev/null 2009-07-28 15:36:51.159175345 +1000
+++ libpciaccess-0.10.6/src/common_vgaarb.c 2009-07-31 11:29:36.000000000 +1000
@@ -0,0 +1,245 @@
+/*
+ * Copyright (c) 2007 Paulo R. Zanoni, Tiago Vignatti
@ -383,11 +354,9 @@ index 0000000..302b89d
+
+ return vgaarb_write(pci_sys->vgaarb_fd, buf, len);
+}
diff --git a/src/common_vgaarb_stub.c b/src/common_vgaarb_stub.c
new file mode 100644
index 0000000..5fc5dfe
--- /dev/null
+++ b/src/common_vgaarb_stub.c
diff -up /dev/null libpciaccess-0.10.6/src/common_vgaarb_stub.c
--- /dev/null 2009-07-28 15:36:51.159175345 +1000
+++ libpciaccess-0.10.6/src/common_vgaarb_stub.c 2009-07-31 11:29:36.000000000 +1000
@@ -0,0 +1,73 @@
+/*
+ * Copyright (c) 2009 Tiago Vignatti
@ -462,19 +431,18 @@ index 0000000..5fc5dfe
+{
+ return 0;
+}
diff --git a/src/linux_sysfs.c b/src/linux_sysfs.c
index 1ae9e52..65e1cf6 100644
--- a/src/linux_sysfs.c
+++ b/src/linux_sysfs.c
@@ -76,6 +76,7 @@ static int pci_device_linux_sysfs_write( struct pci_device * dev,
diff -up libpciaccess-0.10.6/src/linux_sysfs.c.da libpciaccess-0.10.6/src/linux_sysfs.c
--- libpciaccess-0.10.6/src/linux_sysfs.c.da 2009-07-31 11:29:24.000000000 +1000
+++ libpciaccess-0.10.6/src/linux_sysfs.c 2009-07-31 11:29:36.000000000 +1000
@@ -78,6 +78,7 @@ static int pci_device_linux_sysfs_write(
pciaddr_t * bytes_written );
static int pci_device_linux_sysfs_boot_vga( struct pci_device * dev );
+static int pci_device_linux_sysfs_has_kernel_driver(struct pci_device *dev);
static const struct pci_system_methods linux_sysfs_methods = {
.destroy = NULL,
@@ -91,6 +92,7 @@ static const struct pci_system_methods linux_sysfs_methods = {
.destroy = pci_device_linux_sysfs_destroy,
@@ -93,6 +94,7 @@ static const struct pci_system_methods l
.fill_capabilities = pci_fill_capabilities_generic,
.enable = pci_device_linux_sysfs_enable,
.boot_vga = pci_device_linux_sysfs_boot_vga,
@ -482,7 +450,7 @@ index 1ae9e52..65e1cf6 100644
};
#define SYS_BUS_PCI "/sys/bus/pci/devices"
@@ -729,3 +731,22 @@ out:
@@ -761,3 +763,22 @@ out:
close(fd);
return ret;
}
@ -505,10 +473,33 @@ index 1ae9e52..65e1cf6 100644
+ return 0;
+ return 1;
+}
diff --git a/src/pciaccess_private.h b/src/pciaccess_private.h
index 769e181..b97d31b 100644
--- a/src/pciaccess_private.h
+++ b/src/pciaccess_private.h
diff -up libpciaccess-0.10.6/src/Makefile.am.da libpciaccess-0.10.6/src/Makefile.am
--- libpciaccess-0.10.6/src/Makefile.am.da 2009-04-18 15:01:36.000000000 +1000
+++ libpciaccess-0.10.6/src/Makefile.am 2009-07-31 11:29:36.000000000 +1000
@@ -45,6 +45,12 @@ if SOLARIS
OS_SUPPORT = solx_devfs.c pci_tools.h
endif
+if LINUX
+VGA_ARBITER = common_vgaarb.c
+else
+VGA_ARBITER = common_vgaarb_stub.c
+endif
+
libpciaccess_la_SOURCES = common_bridge.c \
common_iterator.c \
common_init.c \
@@ -53,6 +59,7 @@ libpciaccess_la_SOURCES = common_bridge.
common_device_name.c \
common_map.c \
pciaccess_private.h \
+ $(VGA_ARBITER) \
$(OS_SUPPORT)
INCLUDES = -I$(top_srcdir)/include
diff -up libpciaccess-0.10.6/src/pciaccess_private.h.da libpciaccess-0.10.6/src/pciaccess_private.h
--- libpciaccess-0.10.6/src/pciaccess_private.h.da 2009-07-31 11:29:24.000000000 +1000
+++ libpciaccess-0.10.6/src/pciaccess_private.h 2009-07-31 11:29:36.000000000 +1000
@@ -61,6 +61,7 @@ struct pci_system_methods {
int (*fill_capabilities)( struct pci_device * dev );
void (*enable)( struct pci_device *dev );