Rebasing to liboqs-0.12.0
Resolves: RHEL-65426
This commit is contained in:
parent
66c4852815
commit
164b549b5b
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
|||||||
/0.9.2.tar.gz
|
/0.9.2.tar.gz
|
||||||
/0.10.1.tar.gz
|
/0.10.1.tar.gz
|
||||||
/0.11.0.tar.gz
|
/0.11.0.tar.gz
|
||||||
|
/liboqs-0.12.0.tar.gz
|
||||||
|
@ -1,43 +0,0 @@
|
|||||||
diff --git a/tests/test_acvp_vectors.py b/tests/test_acvp_vectors.py
|
|
||||||
index 4eee4b810..ddd64003c 100644
|
|
||||||
--- a/tests/test_acvp_vectors.py
|
|
||||||
+++ b/tests/test_acvp_vectors.py
|
|
||||||
@@ -36,9 +36,10 @@ def test_acvp_vec_kem_keygen(kem_name):
|
|
||||||
z = testCase["z"]
|
|
||||||
pk = testCase["ek"]
|
|
||||||
sk = testCase["dk"]
|
|
||||||
-
|
|
||||||
+
|
|
||||||
+ build_dir = helpers.get_current_build_dir_name()
|
|
||||||
helpers.run_subprocess(
|
|
||||||
- ['build/tests/vectors_kem', kem_name, "keyGen", d+z, pk, sk]
|
|
||||||
+ [f'{build_dir}/tests/vectors_kem', kem_name, "keyGen", d+z, pk, sk]
|
|
||||||
)
|
|
||||||
|
|
||||||
assert(variantFound == True)
|
|
||||||
@@ -66,9 +67,10 @@ def test_acvp_vec_kem_encdec_aft(kem_name):
|
|
||||||
#expected results
|
|
||||||
k = testCase["k"]
|
|
||||||
c = testCase["c"]
|
|
||||||
-
|
|
||||||
+
|
|
||||||
+ build_dir = helpers.get_current_build_dir_name()
|
|
||||||
helpers.run_subprocess(
|
|
||||||
- ['build/tests/vectors_kem', kem_name, "encDecAFT", m, pk, k, c]
|
|
||||||
+ [f'{build_dir}/tests/vectors_kem', kem_name, "encDecAFT", m, pk, k, c]
|
|
||||||
)
|
|
||||||
|
|
||||||
assert(variantFound == True)
|
|
||||||
@@ -94,9 +96,10 @@ def test_acvp_vec_kem_encdec_val(kem_name):
|
|
||||||
c = testCase["c"]
|
|
||||||
#expected results
|
|
||||||
k = testCase["k"]
|
|
||||||
-
|
|
||||||
+
|
|
||||||
+ build_dir = helpers.get_current_build_dir_name()
|
|
||||||
helpers.run_subprocess(
|
|
||||||
- ['build/tests/vectors_kem', kem_name, "encDecVAL", sk, k, c]
|
|
||||||
+ [f'{build_dir}/tests/vectors_kem', kem_name, "encDecVAL", sk, k, c]
|
|
||||||
)
|
|
||||||
|
|
||||||
assert(variantFound == True)
|
|
47
liboqs-0.12.0-acvp_patch.patch
Normal file
47
liboqs-0.12.0-acvp_patch.patch
Normal file
@ -0,0 +1,47 @@
|
|||||||
|
diff -up liboqs-0.12.0/tests/test_acvp_vectors.py.xxx liboqs-0.12.0/tests/test_acvp_vectors.py
|
||||||
|
--- liboqs-0.12.0/tests/test_acvp_vectors.py.xxx 2025-01-02 12:42:53.623845023 +0100
|
||||||
|
+++ liboqs-0.12.0/tests/test_acvp_vectors.py 2025-01-02 12:44:42.340435783 +0100
|
||||||
|
@@ -121,8 +121,9 @@ def test_acvp_vec_sig_keygen(sig_name):
|
||||||
|
pk = testCase["pk"]
|
||||||
|
sk = testCase["sk"]
|
||||||
|
|
||||||
|
+ build_dir = helpers.get_current_build_dir_name()
|
||||||
|
helpers.run_subprocess(
|
||||||
|
- ['build/tests/vectors_sig', sig_name, "keyGen", seed, pk, sk]
|
||||||
|
+ [f'{build_dir}/tests/vectors_sig', sig_name, "keyGen", seed, pk, sk]
|
||||||
|
)
|
||||||
|
|
||||||
|
assert(variantFound == True)
|
||||||
|
@@ -146,8 +147,9 @@ def test_acvp_vec_sig_gen_deterministic(
|
||||||
|
sk = testCase["sk"]
|
||||||
|
message = testCase["message"]
|
||||||
|
signature = testCase["signature"]
|
||||||
|
+ build_dir = helpers.get_current_build_dir_name()
|
||||||
|
helpers.run_subprocess(
|
||||||
|
- ['build/tests/vectors_sig', sig_name, "sigGen_det", sk, message, signature]
|
||||||
|
+ [f'{build_dir}/tests/vectors_sig', sig_name, "sigGen_det", sk, message, signature]
|
||||||
|
)
|
||||||
|
|
||||||
|
assert(variantFound == True)
|
||||||
|
@@ -173,8 +175,9 @@ def test_acvp_vec_sig_gen_randomized(sig
|
||||||
|
signature = testCase["signature"]
|
||||||
|
rnd = testCase["rnd"]
|
||||||
|
|
||||||
|
+ build_dir = helpers.get_current_build_dir_name()
|
||||||
|
helpers.run_subprocess(
|
||||||
|
- ['build/tests/vectors_sig', sig_name, "sigGen_rnd", sk, message, signature, rnd]
|
||||||
|
+ [f'{build_dir}/tests/vectors_sig', sig_name, "sigGen_rnd", sk, message, signature, rnd]
|
||||||
|
)
|
||||||
|
|
||||||
|
assert(variantFound == True)
|
||||||
|
@@ -200,8 +203,9 @@ def test_acvp_vec_sig_ver(sig_name):
|
||||||
|
signature = testCase["signature"]
|
||||||
|
testPassed = "1" if testCase["testPassed"] else "0"
|
||||||
|
|
||||||
|
+ build_dir = helpers.get_current_build_dir_name()
|
||||||
|
helpers.run_subprocess(
|
||||||
|
- ['build/tests/vectors_sig', sig_name, "sigVer", pk, message, signature, testPassed]
|
||||||
|
+ [f'{build_dir}/tests/vectors_sig', sig_name, "sigVer", pk, message, signature, testPassed]
|
||||||
|
)
|
||||||
|
|
||||||
|
assert(variantFound == True)
|
14
liboqs.spec
14
liboqs.spec
@ -1,7 +1,7 @@
|
|||||||
%global oqs_version 0.11.0
|
%global oqs_version 0.12.0
|
||||||
Name: liboqs
|
Name: liboqs
|
||||||
Version: %{oqs_version}
|
Version: %{oqs_version}
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: liboqs is an open source C library for quantum-safe cryptographic algorithms.
|
Summary: liboqs is an open source C library for quantum-safe cryptographic algorithms.
|
||||||
|
|
||||||
#liboqs uses MIT license by itself but includes several files licensed under different terms.
|
#liboqs uses MIT license by itself but includes several files licensed under different terms.
|
||||||
@ -10,8 +10,8 @@ Summary: liboqs is an open source C library for quantum-safe cryptographic al
|
|||||||
#see https://github.com/open-quantum-safe/liboqs/blob/main/README.md#license for more details
|
#see https://github.com/open-quantum-safe/liboqs/blob/main/README.md#license for more details
|
||||||
License: MIT AND Apache-2.0 AND BSD-3-Clause AND (BSD-3-Clause OR GPL-1.0-or-later) AND CC0-1.0 AND Unlicense
|
License: MIT AND Apache-2.0 AND BSD-3-Clause AND (BSD-3-Clause OR GPL-1.0-or-later) AND CC0-1.0 AND Unlicense
|
||||||
URL: https://github.com/open-quantum-safe/liboqs.git
|
URL: https://github.com/open-quantum-safe/liboqs.git
|
||||||
Source: https://github.com/open-quantum-safe/liboqs/archive/refs/tags/%{oqs_version}.tar.gz
|
Source: https://github.com/open-quantum-safe/liboqs/archive/refs/tags/liboqs-%{oqs_version}.tar.gz
|
||||||
Patch1: liboqs-0.11.0-acvp_patch.patch
|
Patch1: liboqs-0.12.0-acvp_patch.patch
|
||||||
Patch2: liboqs-0.10.0-std-stricter.patch
|
Patch2: liboqs-0.10.0-std-stricter.patch
|
||||||
|
|
||||||
BuildRequires: ninja-build
|
BuildRequires: ninja-build
|
||||||
@ -82,7 +82,7 @@ done
|
|||||||
%files
|
%files
|
||||||
%license LICENSE.txt
|
%license LICENSE.txt
|
||||||
%{_libdir}/liboqs.so.%{oqs_version}
|
%{_libdir}/liboqs.so.%{oqs_version}
|
||||||
%{_libdir}/liboqs.so.6
|
%{_libdir}/liboqs.so.7
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_libdir}/liboqs.so
|
%{_libdir}/liboqs.so
|
||||||
@ -99,6 +99,10 @@ done
|
|||||||
#%doc %%{_datadir}/doc/oqs/xml/*
|
#%doc %%{_datadir}/doc/oqs/xml/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 02 2025 Dmitry Belyavskiy <dbelyavs@redhat.com> - 0.12.0-1
|
||||||
|
- Rebasing to liboqs-0.12.0
|
||||||
|
Resolves: RHEL-65426
|
||||||
|
|
||||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 0.11.0-4
|
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 0.11.0-4
|
||||||
- Bump release for October 2024 mass rebuild:
|
- Bump release for October 2024 mass rebuild:
|
||||||
Resolves: RHEL-64018
|
Resolves: RHEL-64018
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (0.11.0.tar.gz) = 10dc002f148895cc304d6b0db14734d9149aeae43308caee4fe5c39ee18fbd7297c65f5c67df0a39b84534f676f209bbcda591b353128b4bab152cb69177c6ae
|
SHA512 (liboqs-0.12.0.tar.gz) = 93260f15c02108157fa595e252685c49c5fb6433d04b989c381da4e27169577f3011d9174b2ec0c110fff15d2d3c640a9833bf28aa53949e8f33c0e674b6e781
|
||||||
|
Loading…
Reference in New Issue
Block a user