28 lines
1.2 KiB
Diff
28 lines
1.2 KiB
Diff
From f2c9c1c9cda831a4305e2dc8899d630ed727353a Mon Sep 17 00:00:00 2001
|
|
From: Tom Stellard <tstellar@redhat.com>
|
|
Date: Tue, 16 May 2017 11:52:19 -0400
|
|
Subject: [PATCH] [PATCH][openmp] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a
|
|
cache variable when bulding standalone
|
|
|
|
This way it can be overriden on the command line.
|
|
---
|
|
openmp/runtime/src/CMakeLists.txt | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt
|
|
index 822f9ca..583a3c3 100644
|
|
--- a/openmp/runtime/src/CMakeLists.txt
|
|
+++ b/openmp/runtime/src/CMakeLists.txt
|
|
@@ -346,7 +346,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
|
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
|
|
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
|
|
if(${OPENMP_STANDALONE_BUILD})
|
|
- set(LIBOMP_HEADERS_INSTALL_PATH "${CMAKE_INSTALL_INCLUDEDIR}")
|
|
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
|
|
else()
|
|
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
|
|
set(LIBOMP_HEADERS_INSTALL_PATH "${OPENMP_INSTALL_LIBDIR}/clang/${CLANG_VERSION}/include")
|
|
--
|
|
1.8.3.1
|
|
|