import libomp-7.0.1-1.module+el8+2560+c32c7af1

This commit is contained in:
CentOS Sources 2019-05-07 02:00:53 -04:00 committed by Andrew Lukoshko
commit c8d86eedba
6 changed files with 443 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/openmp-7.0.1.src.tar.xz

1
.libomp.metadata Normal file
View File

@ -0,0 +1 @@
3b931dcafbe6e621c9d99617235fd63f222c2ba2 SOURCES/openmp-7.0.1.src.tar.xz

View File

@ -0,0 +1,29 @@
From 156a23f5d91c35edd888091b3d6416b755fa134d Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Tue, 16 May 2017 11:52:19 -0400
Subject: [PATCH] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a cache variable when
bulding standalone
This way it can be overriden on the command line.
---
runtime/src/CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/runtime/src/CMakeLists.txt b/runtime/src/CMakeLists.txt
index f9e63f4..2bf6796 100644
--- a/runtime/src/CMakeLists.txt
+++ b/runtime/src/CMakeLists.txt
@@ -282,8 +282,8 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
# Install rules
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
-if(${OPENMP_STANDALONE_BUILD})
- set(LIBOMP_HEADERS_INSTALL_PATH include)
+if(${OPENMP_STANDALONE_BUILD})
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
else()
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
set(LIBOMP_HEADERS_INSTALL_PATH "${OPENMP_INSTALL_LIBDIR}/clang/${CLANG_VERSION}/include")
--
1.8.3.1

View File

@ -0,0 +1,195 @@
From ce4337afad70fcf57f6b9afc84203497586f91b8 Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Wed, 12 Dec 2018 10:12:57 -0800
Subject: [PATCH] Fix for https://bugs.llvm.org/show_bug.cgi?id=39970
Summary:
Some tests require more than 1 thread to pass. The patch checks max threads, and if iti is 1 then sets number of threads to more than one.
Exceptions:
ompt/misc/api_calls_places.c - broke the standard requirement, fixed this;
worksharing/for/omp_doacross.c - could not reproduce the failure, increased the number of threads just in case.
Reviewers: jlpeyton, hbae, tlwilmar
Subscribers: openmp-commits, tstellar
Differential Revision: https://reviews.llvm.org/D55598
---
runtime/test/api/omp_in_parallel.c | 5 +++++
runtime/test/flush/omp_flush.c | 5 +++++
runtime/test/ompt/misc/api_calls_places.c | 2 +-
runtime/test/parallel/omp_nested.c | 2 ++
runtime/test/tasking/omp_task.c | 3 +++
runtime/test/tasking/omp_taskyield.c | 3 +++
runtime/test/worksharing/for/kmp_sch_simd_runtime_api.c | 3 ++-
runtime/test/worksharing/for/kmp_sch_simd_runtime_guided.c | 3 ++-
runtime/test/worksharing/for/kmp_sch_simd_runtime_static.c | 3 ++-
runtime/test/worksharing/for/omp_doacross.c | 2 ++
10 files changed, 27 insertions(+), 4 deletions(-)
diff --git a/runtime/test/api/omp_in_parallel.c b/runtime/test/api/omp_in_parallel.c
index d09313e..5e9e635 100644
--- a/runtime/test/api/omp_in_parallel.c
+++ b/runtime/test/api/omp_in_parallel.c
@@ -30,6 +30,11 @@ int main()
int i;
int num_failed=0;
+ // the test requires more than 1 thread to pass
+ omp_set_dynamic(0); // disable dynamic adjustment of threads
+ if (omp_get_max_threads() == 1)
+ omp_set_num_threads(2); // set 2 threads if no HW resources available
+
for(i = 0; i < REPETITIONS; i++) {
if(!test_omp_in_parallel()) {
num_failed++;
diff --git a/runtime/test/flush/omp_flush.c b/runtime/test/flush/omp_flush.c
index 3fd3cdf..95a406d 100644
--- a/runtime/test/flush/omp_flush.c
+++ b/runtime/test/flush/omp_flush.c
@@ -36,6 +36,11 @@ int main()
int i;
int num_failed=0;
+ // the test requires more than 1 thread to pass
+ omp_set_dynamic(0); // disable dynamic adjustment of threads
+ if (omp_get_max_threads() == 1)
+ omp_set_num_threads(2); // set 2 threads if no HW resources available
+
for (i = 0; i < REPETITIONS; i++) {
if(!test_omp_flush()) {
num_failed++;
diff --git a/runtime/test/ompt/misc/api_calls_places.c b/runtime/test/ompt/misc/api_calls_places.c
index ad338a7..3385c9c 100644
--- a/runtime/test/ompt/misc/api_calls_places.c
+++ b/runtime/test/ompt/misc/api_calls_places.c
@@ -42,7 +42,7 @@ int main() {
int omp_nums[omp_nums_size];
omp_get_partition_place_nums(omp_nums);
print_list("omp_get_partition_place_nums", omp_nums_size, omp_nums);
- int ompt_nums_size = ompt_get_partition_place_nums(0, NULL);
+ int ompt_nums_size = ompt_get_partition_place_nums(0, omp_nums);
int ompt_nums[ompt_nums_size];
ompt_get_partition_place_nums(ompt_nums_size, ompt_nums);
print_list("ompt_get_partition_place_nums", ompt_nums_size, ompt_nums);
diff --git a/runtime/test/parallel/omp_nested.c b/runtime/test/parallel/omp_nested.c
index 8b78088..d2d5b08 100644
--- a/runtime/test/parallel/omp_nested.c
+++ b/runtime/test/parallel/omp_nested.c
@@ -12,6 +12,8 @@ int test_omp_nested()
#ifdef _OPENMP
if (omp_get_max_threads() > 4)
omp_set_num_threads(4);
+ if (omp_get_max_threads() < 2)
+ omp_set_num_threads(2);
#endif
int counter = 0;
diff --git a/runtime/test/tasking/omp_task.c b/runtime/test/tasking/omp_task.c
index c534abe..5703225 100644
--- a/runtime/test/tasking/omp_task.c
+++ b/runtime/test/tasking/omp_task.c
@@ -43,6 +43,9 @@ int main()
int i;
int num_failed=0;
+ if (omp_get_max_threads() < 2)
+ omp_set_num_threads(8);
+
for(i = 0; i < REPETITIONS; i++) {
if(!test_omp_task()) {
num_failed++;
diff --git a/runtime/test/tasking/omp_taskyield.c b/runtime/test/tasking/omp_taskyield.c
index 5bb6984..7f85413 100644
--- a/runtime/test/tasking/omp_taskyield.c
+++ b/runtime/test/tasking/omp_taskyield.c
@@ -49,6 +49,9 @@ int main()
int i;
int num_failed=0;
+ if (omp_get_max_threads() < 2)
+ omp_set_num_threads(8);
+
for(i = 0; i < REPETITIONS; i++) {
if(!test_omp_taskyield()) {
num_failed++;
diff --git a/runtime/test/worksharing/for/kmp_sch_simd_runtime_api.c b/runtime/test/worksharing/for/kmp_sch_simd_runtime_api.c
index bb538d1..987a5c0 100644
--- a/runtime/test/worksharing/for/kmp_sch_simd_runtime_api.c
+++ b/runtime/test/worksharing/for/kmp_sch_simd_runtime_api.c
@@ -66,6 +66,7 @@ run_loop(
int ub; // Chunk upper bound.
int st; // Chunk stride.
int rc;
+ int nthreads = omp_get_num_threads();
int tid = omp_get_thread_num();
int gtid = __kmpc_global_thread_num(&loc);
int last;
@@ -134,7 +135,7 @@ run_loop(
printf("Error with iter %d, %d, err %d\n", cur, max, ++err);
// Update maximum for the next chunk.
if (last) {
- if (!no_chunk && cur > ch)
+ if (!no_chunk && cur > ch && nthreads > 1)
printf("Error: too big last chunk %d (%d), tid %d, err %d\n",
(int)cur, ch, tid, ++err);
} else {
diff --git a/runtime/test/worksharing/for/kmp_sch_simd_runtime_guided.c b/runtime/test/worksharing/for/kmp_sch_simd_runtime_guided.c
index d137831..5dfaf24 100644
--- a/runtime/test/worksharing/for/kmp_sch_simd_runtime_guided.c
+++ b/runtime/test/worksharing/for/kmp_sch_simd_runtime_guided.c
@@ -74,6 +74,7 @@ run_loop(
int ub; // Chunk upper bound.
int st; // Chunk stride.
int rc;
+ int nthreads = omp_get_num_threads();
int tid = omp_get_thread_num();
int gtid = __kmpc_global_thread_num(&loc);
int last;
@@ -144,7 +145,7 @@ run_loop(
if (!last && cur % ch)
printf("Error with chunk %d, %d, ch %d, tid %d, err %d\n",
chunk, (int)cur, ch, tid, ++err);
- if (last && !no_chunk && cur > ch)
+ if (last && !no_chunk && cur > ch && nthreads > 1)
printf("Error: too big last chunk %d (%d), tid %d, err %d\n",
(int)cur, ch, tid, ++err);
if (cur < max)
diff --git a/runtime/test/worksharing/for/kmp_sch_simd_runtime_static.c b/runtime/test/worksharing/for/kmp_sch_simd_runtime_static.c
index 4cb15d6..d76046b 100644
--- a/runtime/test/worksharing/for/kmp_sch_simd_runtime_static.c
+++ b/runtime/test/worksharing/for/kmp_sch_simd_runtime_static.c
@@ -67,6 +67,7 @@ run_loop(
int ub; // Chunk upper bound.
int st; // Chunk stride.
int rc;
+ int nthreads = omp_get_num_threads();
int tid = omp_get_thread_num();
int gtid = __kmpc_global_thread_num(&loc);
int last;
@@ -135,7 +136,7 @@ run_loop(
printf("Error with iter %d, %d, err %d\n", cur, max, ++err);
// Update maximum for the next chunk.
if (last) {
- if (!no_chunk && cur > ch)
+ if (!no_chunk && cur > ch && nthreads > 1)
printf("Error: too big last chunk %d (%d), tid %d, err %d\n",
(int)cur, ch, tid, ++err);
} else {
diff --git a/runtime/test/worksharing/for/omp_doacross.c b/runtime/test/worksharing/for/omp_doacross.c
index 4187112..3644306 100644
--- a/runtime/test/worksharing/for/omp_doacross.c
+++ b/runtime/test/worksharing/for/omp_doacross.c
@@ -51,6 +51,8 @@ int test_doacross() {
int main(int argc, char **argv) {
int i;
int num_failed = 0;
+ if (omp_get_max_threads() < 2)
+ omp_set_num_threads(4);
for (i = 0; i < REPETITIONS; i++) {
if (!test_doacross()) {
num_failed++;
--
1.8.3.1

33
SOURCES/runtest.sh Normal file
View File

@ -0,0 +1,33 @@
#!/bin/bash
usage() {
echo "usage: `basename $0` [OPTIONS]"
echo " --threads NUM The number of threads to use for running tests."
}
threads_arg=''
while [ $# -gt 0 ]; do
case $1 in
--threads)
shift
threads_arg="--threads $1"
;;
* )
echo "unknown option: $1"
echo ""
usage
exit 1
;;
esac
shift
done
set -x
lit $threads_arg -v --config-prefix clang /usr/share/libomp/src/runtime/test
fail=$?
lit $threads_arg -v --config-prefix gcc /usr/share/libomp/src/runtime/test
exit $fail || $?

184
SPECS/libomp.spec Normal file
View File

@ -0,0 +1,184 @@
%ifarch ppc64le
%global libomp_arch ppc64
%else
%global libomp_arch %{_arch}
%endif
%ifnarch i686
%global enable_test_pkg 1
%endif
Name: libomp
Version: 7.0.1
Release: 1%{?dist}
Summary: OpenMP runtime for clang
License: NCSA
URL: http://openmp.llvm.org
Source0: http://%{?rc_ver:pre}releases.llvm.org/%{version}/%{?rc_ver:rc%{rc_ver}}/openmp-%{version}%{?rc_ver:rc%{rc_ver}}.src.tar.xz
Source1: runtest.sh
Patch0: 0001-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-a-cache-varia.patch
Patch1: 0001-Fix-for-https-bugs.llvm.org-show_bug.cgi-id-39970.patch
BuildRequires: cmake
BuildRequires: elfutils-libelf-devel
BuildRequires: perl
BuildRequires: perl-Data-Dumper
BuildRequires: perl-Encode
BuildRequires: libffi-devel
Requires: elfutils-libelf%{?isa}
# libomp does not support s390x.
ExcludeArch: s390x
%description
OpenMP runtime for clang.
%package devel
Summary: OpenMP header files
Requires: clang-devel%{?isa} = %{version}
%description devel
OpenMP header files.
%if 0%{?enable_test_pkg}
%package test
Summary: OpenMP regression tests
Requires: libomp%{?isa} = %{version}
Requires: libomp-devel%{?isa} = %{version}
Requires: clang
Requires: llvm
Requires: gcc
Requires: gcc-c++
Requires: python3-lit
%description test
OpenMP regression tests
%endif
%prep
%autosetup -n openmp-%{version}%{?rc_ver:rc%{rc_ver}}.src -p1
%build
mkdir -p _build
cd _build
%cmake .. \
-DLIBOMP_INSTALL_ALIASES=OFF \
-DLIBOMP_HEADERS_INSTALL_PATH:PATH=%{_libdir}/clang/%{version}/include \
%if 0%{?__isa_bits} == 64
-DOPENMP_LIBDIR_SUFFIX=64 \
%else
-DOPENMP_LIBDIR_SUFFIX= \
%endif
%make_build
%install
%make_install -C _build
%if 0%{?enable_test_pkg}
# Test package setup
%global libomp_srcdir %{_datadir}/libomp/src/
%global libomp_testdir %{libomp_srcdir}/runtime/test/
%global gcc_lit_cfg %{buildroot}%{libomp_testdir}/gcc.site.cfg
%global clang_lit_cfg %{buildroot}%{libomp_testdir}/clang.site.cfg
install -d %{buildroot}%{libomp_srcdir}/runtime
cp -R runtime/test %{buildroot}%{libomp_srcdir}/runtime
cp -R runtime/src %{buildroot}%{libomp_srcdir}/runtime
# Add symlinks to the libomp headers/library so gcc can find them.
ln -s %{_libdir}/clang/%{version}/include/omp.h %{buildroot}%{libomp_testdir}/omp.h
ln -s %{_libdir}/clang/%{version}/include/ompt.h %{buildroot}%{libomp_testdir}/ompt.h
ln -s %{_libdir}/libomp.so %{buildroot}%{libomp_testdir}/libgomp.so
# Generic test config
echo "import tempfile" > %{gcc_lit_cfg}
cat _build/runtime/test/lit.site.cfg >> %{gcc_lit_cfg}
sed -i 's~\(config.test_filecheck = \)""~\1"%{_libdir}/llvm/FileCheck"~' %{gcc_lit_cfg}
sed -i 's~\(config.omp_header_directory = \)"[^"]\+"~\1"%{_includedir}"~' %{gcc_lit_cfg}
sed -i 's~\(config.libomp_obj_root = \)"[^"]\+"~\1tempfile.mkdtemp()[1]~' %{gcc_lit_cfg}
sed -i 's~\(lit_config.load_config(config, \)"[^"]\+"~\1"%{libomp_testdir}/lit.cfg"~' %{gcc_lit_cfg}
# GCC config
# test_compiler_features was already populated with gcc information if gcc was used
# to compile libomp.
sed -i 's~\(config.test_c_compiler = \)"[^"]\+"~\1"%{_bindir}/gcc"~' %{gcc_lit_cfg}
sed -i 's~\(config.test_cxx_compiler = \)"[^"]\+"~\1"%{_bindir}/g++"~' %{gcc_lit_cfg}
sed -i 's~\(config.library_dir = \)"[^"]\+"~\1"%{libomp_testdir}"~' %{gcc_lit_cfg}
# Clang config
cp %{gcc_lit_cfg} %{clang_lit_cfg}
sed -i 's~\(config.test_compiler_features = \)\[[^\[]\+]~\1["clang"]~' %{clang_lit_cfg}
sed -i 's~\(config.test_c_compiler = \)"[^"]\+"~\1"%{_bindir}/clang"~' %{clang_lit_cfg}
sed -i 's~\(config.test_cxx_compiler = \)"[^"]\+"~\1"%{_bindir}/clang++"~' %{clang_lit_cfg}
sed -i 's~\(config.library_dir = \)"[^"]\+"~\1"%{_libdir}"~' %{clang_lit_cfg}
install -m 0755 %{SOURCE1} %{buildroot}%{_datadir}/libomp
%endif
%files
%{_libdir}/libomp.so
%{_libdir}/libomptarget.so
%ifnarch %{arm} %{ix86}
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so
%endif
%files devel
%{_libdir}/clang/%{version}/include/omp.h
%ifnarch %{arm}
%{_libdir}/clang/%{version}/include/ompt.h
%endif
%if 0%{?enable_test_pkg}
%files test
%{_datadir}/libomp
%endif
%changelog
* Fri Dec 14 2018 Tom Stellard <tstellar@redhat.com> - 7.0.1-1
- 7.0.1 Release
* Wed Dec 12 2018 Tom Stellard <tstellar@redhat.com> - 7.0.1-0.2.rc3
- Fix test failures on single-core systems
* Mon Dec 10 2018 Tom Stellard <tstellar@redhat.com> - 7.0.1-0.1.rc3
- 7.0.1-rc3 Release
* Tue Nov 27 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-1
- 7.0.0 Release
* Sat Nov 10 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-3
- Don't build libomp-test on i686
* Mon Oct 01 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-2
- Drop scl macros
* Wed Jul 11 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-1
- 6.0.1 Release
* Mon Jan 15 2018 Tom Stellard <tstellar@redhat.com> - 5.0.1-2
- Drop ExcludeArch: ppc64
* Thu Dec 21 2017 Tom Stellard <tstellar@redhat.com> - 5.0.1-1
- 5.0.1 Release.
* Wed Jun 21 2017 Tom Stellard <tstellar@redhat.com> - 4.0.1-1
- 4.0.1 Release.
* Wed Jun 07 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-3
- Rename libopenmp->libomp
* Fri May 26 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-2
- Disable build on s390x
* Mon May 15 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-1
- Initial version.