import libomp-12.0.1-1.module+el8.5.0+11871+08d0eab5
This commit is contained in:
parent
c6b322ae66
commit
832d965400
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/hans-gpg-key.asc
|
SOURCES/openmp-12.0.1.src.tar.xz
|
||||||
SOURCES/openmp-11.0.0.src.tar.xz
|
SOURCES/tstellar-gpg-key.asc
|
||||||
|
@ -1,2 +1,2 @@
|
|||||||
32fa4b0193960f05064f2ab31b5a89c7cf48a0b9 SOURCES/hans-gpg-key.asc
|
7c051f6050ff23763b253a757927774b5eeaf644 SOURCES/openmp-12.0.1.src.tar.xz
|
||||||
fb5502f1cd73bd5c5fdf2544b263fdb2a00791d9 SOURCES/openmp-11.0.0.src.tar.xz
|
b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc
|
||||||
|
@ -1,25 +1,23 @@
|
|||||||
From 156a23f5d91c35edd888091b3d6416b755fa134d Mon Sep 17 00:00:00 2001
|
From f2c9c1c9cda831a4305e2dc8899d630ed727353a Mon Sep 17 00:00:00 2001
|
||||||
From: Tom Stellard <tstellar@redhat.com>
|
From: Tom Stellard <tstellar@redhat.com>
|
||||||
Date: Tue, 16 May 2017 11:52:19 -0400
|
Date: Tue, 16 May 2017 11:52:19 -0400
|
||||||
Subject: [PATCH] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a cache variable when
|
Subject: [PATCH] [PATCH][openmp] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a
|
||||||
bulding standalone
|
cache variable when bulding standalone
|
||||||
|
|
||||||
This way it can be overriden on the command line.
|
This way it can be overriden on the command line.
|
||||||
---
|
---
|
||||||
runtime/src/CMakeLists.txt | 4 ++--
|
openmp/runtime/src/CMakeLists.txt | 2 +-
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/runtime/src/CMakeLists.txt b/runtime/src/CMakeLists.txt
|
diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt
|
||||||
index f9e63f4..2bf6796 100644
|
index 822f9ca..583a3c3 100644
|
||||||
--- a/runtime/src/CMakeLists.txt
|
--- a/openmp/runtime/src/CMakeLists.txt
|
||||||
+++ b/runtime/src/CMakeLists.txt
|
+++ b/openmp/runtime/src/CMakeLists.txt
|
||||||
@@ -282,8 +282,8 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
@@ -305,7 +305,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
||||||
# Install rules
|
|
||||||
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
|
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
|
||||||
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
|
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
|
||||||
-if(${OPENMP_STANDALONE_BUILD})
|
if(${OPENMP_STANDALONE_BUILD})
|
||||||
- set(LIBOMP_HEADERS_INSTALL_PATH include)
|
- set(LIBOMP_HEADERS_INSTALL_PATH include)
|
||||||
+if(${OPENMP_STANDALONE_BUILD})
|
|
||||||
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
|
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
|
||||||
else()
|
else()
|
||||||
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
|
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
|
Binary file not shown.
BIN
SOURCES/openmp-12.0.1.src.tar.xz.sig
Normal file
BIN
SOURCES/openmp-12.0.1.src.tar.xz.sig
Normal file
Binary file not shown.
@ -1,5 +1,4 @@
|
|||||||
#%%global rc_ver 6
|
#%%global rc_ver 5
|
||||||
%global baserelease 1
|
|
||||||
%global libomp_srcdir openmp-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
%global libomp_srcdir openmp-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
||||||
|
|
||||||
|
|
||||||
@ -10,19 +9,19 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Name: libomp
|
Name: libomp
|
||||||
Version: 11.0.0
|
Version: 12.0.1%{?rc_ver:~rc%{rc_ver}}
|
||||||
Release: %{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: OpenMP runtime for clang
|
Summary: OpenMP runtime for clang
|
||||||
|
|
||||||
License: NCSA
|
License: NCSA
|
||||||
URL: http://openmp.llvm.org
|
URL: http://openmp.llvm.org
|
||||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz
|
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz
|
||||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz.sig
|
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz.sig
|
||||||
Source2: https://prereleases.llvm.org/%{version}/hans-gpg-key.asc
|
Source2: tstellar-gpg-key.asc
|
||||||
Source3: run-lit-tests
|
Source3: run-lit-tests
|
||||||
Source4: lit.fedora.cfg.py
|
Source4: lit.fedora.cfg.py
|
||||||
|
|
||||||
Patch0: 0001-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-a-cache-varia.patch
|
Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -44,7 +43,7 @@ OpenMP runtime for clang.
|
|||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Summary: OpenMP header files
|
Summary: OpenMP header files
|
||||||
Requires: clang-devel%{?isa} = %{version}
|
Requires: clang-resource-filesystem%{?isa} = %{version}
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
OpenMP header files.
|
OpenMP header files.
|
||||||
@ -63,11 +62,14 @@ Requires: python3-lit
|
|||||||
OpenMP regression tests
|
OpenMP regression tests
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -n %{libomp_srcdir} -p1
|
%autosetup -n %{libomp_srcdir} -p2
|
||||||
|
|
||||||
%build
|
%build
|
||||||
mkdir -p _build
|
# LTO causes build failures in this package. Disable LTO for now
|
||||||
cd _build
|
%define _lto_cflags %{nil}
|
||||||
|
|
||||||
|
mkdir -p %{_vpath_builddir}
|
||||||
|
cd %{_vpath_builddir}
|
||||||
|
|
||||||
%cmake .. -GNinja \
|
%cmake .. -GNinja \
|
||||||
-DLIBOMP_INSTALL_ALIASES=OFF \
|
-DLIBOMP_INSTALL_ALIASES=OFF \
|
||||||
@ -78,11 +80,12 @@ cd _build
|
|||||||
-DOPENMP_LIBDIR_SUFFIX= \
|
-DOPENMP_LIBDIR_SUFFIX= \
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ninja_build
|
%cmake_build
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
%ninja_install -C _build
|
cd %{_vpath_builddir}
|
||||||
|
%cmake_install
|
||||||
|
|
||||||
# Test package setup
|
# Test package setup
|
||||||
%global libomp_srcdir %{_datadir}/libomp/src/
|
%global libomp_srcdir %{_datadir}/libomp/src/
|
||||||
@ -96,7 +99,7 @@ cp -R runtime/src %{buildroot}%{libomp_srcdir}/runtime
|
|||||||
|
|
||||||
# Generate lit config files. Strip off the last line that initiates the
|
# Generate lit config files. Strip off the last line that initiates the
|
||||||
# test run, so we can customize the configuration.
|
# test run, so we can customize the configuration.
|
||||||
head -n -1 _build/runtime/test/lit.site.cfg >> %{buildroot}%{lit_cfg}
|
head -n -1 runtime/test/lit.site.cfg >> %{buildroot}%{lit_cfg}
|
||||||
|
|
||||||
# Install custom fedora config file
|
# Install custom fedora config file
|
||||||
cp %{SOURCE4} %{buildroot}%{lit_fedora_cfg}
|
cp %{SOURCE4} %{buildroot}%{lit_fedora_cfg}
|
||||||
@ -112,18 +115,15 @@ install -m 0755 %{SOURCE3} %{buildroot}%{_libexecdir}/tests/libomp
|
|||||||
rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
||||||
|
|
||||||
%check
|
%check
|
||||||
%ninja_build check-openmp -C _build
|
cd %{_vpath_builddir}
|
||||||
|
%cmake_build --target check-openmp
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%license LICENSE.txt
|
%license LICENSE.txt
|
||||||
%{_libdir}/libomp.so
|
%{_libdir}/libomp.so
|
||||||
%{_libdir}/libomptarget.so
|
|
||||||
%ifnarch %{arm}
|
%ifnarch %{arm}
|
||||||
%{_libdir}/libarcher.so
|
%{_libdir}/libarcher.so
|
||||||
%endif
|
%endif
|
||||||
%ifnarch %{arm} %{ix86}
|
|
||||||
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_libdir}/clang/%{version}/include/omp.h
|
%{_libdir}/clang/%{version}/include/omp.h
|
||||||
@ -140,6 +140,12 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
|||||||
%{_libexecdir}/tests/libomp/
|
%{_libexecdir}/tests/libomp/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 16 2021 sguelton@redhat.com - 12.0.1-1
|
||||||
|
- 12.0.1 release
|
||||||
|
|
||||||
|
* Thu May 6 2021 sguelton@redhat.com - 12.0.0-1
|
||||||
|
- 12.0.0 release
|
||||||
|
|
||||||
* Thu Oct 29 2020 sguelton@redhat.com - 11.0.0-1
|
* Thu Oct 29 2020 sguelton@redhat.com - 11.0.0-1
|
||||||
- 11.0.0 final release
|
- 11.0.0 final release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user