import libomp-12.0.1-1.module+el8.5.0+11871+08d0eab5
This commit is contained in:
parent
5c17255c60
commit
7d2007aa61
3
.gitignore
vendored
3
.gitignore
vendored
@ -1 +1,2 @@
|
||||
SOURCES/openmp-11.0.1.src.tar.xz
|
||||
SOURCES/openmp-12.0.1.src.tar.xz
|
||||
SOURCES/tstellar-gpg-key.asc
|
||||
|
@ -1 +1,2 @@
|
||||
fd4bf315e7d866812cdc319267e970148d9ea518 SOURCES/openmp-11.0.1.src.tar.xz
|
||||
7c051f6050ff23763b253a757927774b5eeaf644 SOURCES/openmp-12.0.1.src.tar.xz
|
||||
b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc
|
||||
|
@ -1,25 +1,23 @@
|
||||
From 156a23f5d91c35edd888091b3d6416b755fa134d Mon Sep 17 00:00:00 2001
|
||||
From f2c9c1c9cda831a4305e2dc8899d630ed727353a Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Tue, 16 May 2017 11:52:19 -0400
|
||||
Subject: [PATCH] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a cache variable when
|
||||
bulding standalone
|
||||
Subject: [PATCH] [PATCH][openmp] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a
|
||||
cache variable when bulding standalone
|
||||
|
||||
This way it can be overriden on the command line.
|
||||
---
|
||||
runtime/src/CMakeLists.txt | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
openmp/runtime/src/CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/runtime/src/CMakeLists.txt b/runtime/src/CMakeLists.txt
|
||||
index f9e63f4..2bf6796 100644
|
||||
--- a/runtime/src/CMakeLists.txt
|
||||
+++ b/runtime/src/CMakeLists.txt
|
||||
@@ -282,8 +282,8 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
||||
# Install rules
|
||||
diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt
|
||||
index 822f9ca..583a3c3 100644
|
||||
--- a/openmp/runtime/src/CMakeLists.txt
|
||||
+++ b/openmp/runtime/src/CMakeLists.txt
|
||||
@@ -305,7 +305,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
||||
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
|
||||
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
|
||||
-if(${OPENMP_STANDALONE_BUILD})
|
||||
if(${OPENMP_STANDALONE_BUILD})
|
||||
- set(LIBOMP_HEADERS_INSTALL_PATH include)
|
||||
+if(${OPENMP_STANDALONE_BUILD})
|
||||
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
|
||||
else()
|
||||
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
|
Binary file not shown.
BIN
SOURCES/openmp-12.0.1.src.tar.xz.sig
Normal file
BIN
SOURCES/openmp-12.0.1.src.tar.xz.sig
Normal file
Binary file not shown.
@ -1,5 +1,4 @@
|
||||
#%%global rc_ver 6
|
||||
%global baserelease 1
|
||||
#%%global rc_ver 5
|
||||
%global libomp_srcdir openmp-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
|
||||
@ -10,18 +9,19 @@
|
||||
%endif
|
||||
|
||||
Name: libomp
|
||||
Version: 11.0.1
|
||||
Release: %{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||
Version: 12.0.1%{?rc_ver:~rc%{rc_ver}}
|
||||
Release: 1%{?dist}
|
||||
Summary: OpenMP runtime for clang
|
||||
|
||||
License: NCSA
|
||||
URL: http://openmp.llvm.org
|
||||
URL: http://openmp.llvm.org
|
||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz
|
||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz.sig
|
||||
Source2: tstellar-gpg-key.asc
|
||||
Source3: run-lit-tests
|
||||
Source4: lit.fedora.cfg.py
|
||||
|
||||
Patch0: 0001-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-a-cache-varia.patch
|
||||
Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -43,7 +43,7 @@ OpenMP runtime for clang.
|
||||
|
||||
%package devel
|
||||
Summary: OpenMP header files
|
||||
Requires: clang-devel%{?isa} = %{version}
|
||||
Requires: clang-resource-filesystem%{?isa} = %{version}
|
||||
|
||||
%description devel
|
||||
OpenMP header files.
|
||||
@ -62,11 +62,14 @@ Requires: python3-lit
|
||||
OpenMP regression tests
|
||||
|
||||
%prep
|
||||
%autosetup -n %{libomp_srcdir} -p1
|
||||
%autosetup -n %{libomp_srcdir} -p2
|
||||
|
||||
%build
|
||||
mkdir -p _build
|
||||
cd _build
|
||||
# LTO causes build failures in this package. Disable LTO for now
|
||||
%define _lto_cflags %{nil}
|
||||
|
||||
mkdir -p %{_vpath_builddir}
|
||||
cd %{_vpath_builddir}
|
||||
|
||||
%cmake .. -GNinja \
|
||||
-DLIBOMP_INSTALL_ALIASES=OFF \
|
||||
@ -77,11 +80,12 @@ cd _build
|
||||
-DOPENMP_LIBDIR_SUFFIX= \
|
||||
%endif
|
||||
|
||||
%ninja_build
|
||||
%cmake_build
|
||||
|
||||
|
||||
%install
|
||||
%ninja_install -C _build
|
||||
cd %{_vpath_builddir}
|
||||
%cmake_install
|
||||
|
||||
# Test package setup
|
||||
%global libomp_srcdir %{_datadir}/libomp/src/
|
||||
@ -95,7 +99,7 @@ cp -R runtime/src %{buildroot}%{libomp_srcdir}/runtime
|
||||
|
||||
# Generate lit config files. Strip off the last line that initiates the
|
||||
# test run, so we can customize the configuration.
|
||||
head -n -1 _build/runtime/test/lit.site.cfg >> %{buildroot}%{lit_cfg}
|
||||
head -n -1 runtime/test/lit.site.cfg >> %{buildroot}%{lit_cfg}
|
||||
|
||||
# Install custom fedora config file
|
||||
cp %{SOURCE4} %{buildroot}%{lit_fedora_cfg}
|
||||
@ -111,18 +115,15 @@ install -m 0755 %{SOURCE3} %{buildroot}%{_libexecdir}/tests/libomp
|
||||
rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
||||
|
||||
%check
|
||||
%ninja_build check-openmp -C _build
|
||||
cd %{_vpath_builddir}
|
||||
%cmake_build --target check-openmp
|
||||
|
||||
%files
|
||||
%license LICENSE.txt
|
||||
%{_libdir}/libomp.so
|
||||
%{_libdir}/libomptarget.so
|
||||
%ifnarch %{arm}
|
||||
%{_libdir}/libarcher.so
|
||||
%endif
|
||||
%ifnarch %{arm} %{ix86}
|
||||
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%{_libdir}/clang/%{version}/include/omp.h
|
||||
@ -139,8 +140,11 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
||||
%{_libexecdir}/tests/libomp/
|
||||
|
||||
%changelog
|
||||
* Thu Sep 02 2021 Tom Stellard <tstellar@redhat.com> - 11.0.1-1
|
||||
- 11.0.1 Release
|
||||
* Fri Jul 16 2021 sguelton@redhat.com - 12.0.1-1
|
||||
- 12.0.1 release
|
||||
|
||||
* Thu May 6 2021 sguelton@redhat.com - 12.0.0-1
|
||||
- 12.0.0 release
|
||||
|
||||
* Thu Oct 29 2020 sguelton@redhat.com - 11.0.0-1
|
||||
- 11.0.0 final release
|
||||
|
Loading…
Reference in New Issue
Block a user