12.0.0 Release

Related: rhbz#1931719
This commit is contained in:
Tom Stellard 2021-05-07 14:50:02 -07:00
parent 340c07b841
commit 40d93ff3b0
6 changed files with 56 additions and 50 deletions

12
.gitignore vendored
View File

@ -55,3 +55,15 @@
/openmp-11.1.0rc1.src.tar.xz.sig
/openmp-11.1.0rc2.src.tar.xz
/openmp-11.1.0rc2.src.tar.xz.sig
/openmp-12.0.0rc1.src.tar.xz
/openmp-12.0.0rc1.src.tar.xz.sig
/openmp-12.0.0rc2.src.tar.xz
/openmp-12.0.0rc2.src.tar.xz.sig
/openmp-12.0.0rc3.src.tar.xz
/openmp-12.0.0rc3.src.tar.xz.sig
/openmp-12.0.0rc4.src.tar.xz
/openmp-12.0.0rc4.src.tar.xz.sig
/openmp-12.0.0rc5.src.tar.xz
/openmp-12.0.0rc5.src.tar.xz.sig
/openmp-12.0.0.src.tar.xz
/openmp-12.0.0.src.tar.xz.sig

View File

@ -1,25 +1,23 @@
From 156a23f5d91c35edd888091b3d6416b755fa134d Mon Sep 17 00:00:00 2001
From f2c9c1c9cda831a4305e2dc8899d630ed727353a Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Tue, 16 May 2017 11:52:19 -0400
Subject: [PATCH] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a cache variable when
bulding standalone
Subject: [PATCH] [PATCH][openmp] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a
cache variable when bulding standalone
This way it can be overriden on the command line.
---
runtime/src/CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
openmp/runtime/src/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/runtime/src/CMakeLists.txt b/runtime/src/CMakeLists.txt
index f9e63f4..2bf6796 100644
--- a/runtime/src/CMakeLists.txt
+++ b/runtime/src/CMakeLists.txt
@@ -282,8 +282,8 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
# Install rules
diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.txt
index 822f9ca..583a3c3 100644
--- a/openmp/runtime/src/CMakeLists.txt
+++ b/openmp/runtime/src/CMakeLists.txt
@@ -305,7 +305,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
-if(${OPENMP_STANDALONE_BUILD})
if(${OPENMP_STANDALONE_BUILD})
- set(LIBOMP_HEADERS_INSTALL_PATH include)
+if(${OPENMP_STANDALONE_BUILD})
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
else()
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})

View File

@ -1,12 +0,0 @@
--- !Policy
product_versions:
- fedora-*
decision_context: bodhi_update_push_testing
rules:
- !PassingTestCaseRule {test_case_name: fedora-ci.koji-build.tier0.functional}
--- !Policy
product_versions:
- fedora-*
decision_context: bodhi_update_push_stable
rules:
- !PassingTestCaseRule {test_case_name: fedora-ci.koji-build.tier0.functional}

View File

@ -1,5 +1,4 @@
%global rc_ver 2
%global baserelease 3
#%%global rc_ver 5
%global libomp_srcdir openmp-%{version}%{?rc_ver:rc%{rc_ver}}.src
@ -10,8 +9,8 @@
%endif
Name: libomp
Version: 11.1.0
Release: %{?rc_ver:0.}%{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
Version: 12.0.0%{?rc_ver:~rc%{rc_ver}}
Release: 1%{?dist}
Summary: OpenMP runtime for clang
License: NCSA
@ -22,7 +21,7 @@ Source2: tstellar-gpg-key.asc
Source3: run-lit-tests
Source4: lit.fedora.cfg.py
Patch0: 0001-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-a-cache-varia.patch
Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch
BuildRequires: gcc
BuildRequires: gcc-c++
@ -67,7 +66,7 @@ OpenMP regression tests
%prep
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
%autosetup -n %{libomp_srcdir} -p1
%autosetup -n %{libomp_srcdir} -p2
%build
# LTO causes build failures in this package. Disable LTO for now
@ -121,13 +120,9 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
%files
%license LICENSE.txt
%{_libdir}/libomp.so
%{_libdir}/libomptarget.so
%ifnarch %{arm}
%{_libdir}/libarcher.so
%endif
%ifnarch %{arm} %{ix86}
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so
%endif
%files devel
%{_libdir}/clang/%{version}/include/omp.h
@ -144,8 +139,32 @@ rm -rf %{buildroot}%{_libdir}/libarcher_static.a
%{_libexecdir}/tests/libomp/
%changelog
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 11.1.0-0.3.rc2
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
* Fri Apr 16 2021 Tom Stellard <tstellar@redhat.com> - 12.0.0-1
- 12.0.0 Release
* Thu Apr 08 2021 sguelton@redhat.com - 12.0.0-0.7.rc5
- New upstream release candidate
* Fri Apr 02 2021 sguelton@redhat.com - 12.0.0-0.6.rc4
- New upstream release candidate
* Wed Mar 31 2021 Jonathan Wakely <jwakely@redhat.com> - 12.0.0-0.5.rc3
- Rebuilt for removed libstdc++ symbols (#1937698)
* Thu Mar 11 2021 sguelton@redhat.com - 12.0.0-0.4.rc3
- LLVM 12.0.0 rc3
* Tue Mar 09 2021 sguelton@redhat.com - 12.0.0-0.3.rc2
- rebuilt
* Wed Feb 24 2021 sguelton@redhat.com - 12.0.0-0.2.rc2
- 12.0.0-rc2 release
* Mon Feb 22 2021 sguelton@redhat.com - 12.0.0-0.1.rc1
- 12.0.0-rc1 release
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 11.1.0-0.3.rc2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Fri Jan 22 2021 Serge Guelton - 11.1.0-0.2.rc2
- llvm 11.1.0-rc2 release

View File

@ -1,2 +1,2 @@
SHA512 (openmp-11.1.0rc2.src.tar.xz) = 0a204c8826d2f3c4aba3e38082260ba92b44b15b707e79f85406f2632008f16735b5633eede5929e033185acd3fa2cfbb09dfadf28ec2132b6b98843f71b797e
SHA512 (openmp-11.1.0rc2.src.tar.xz.sig) = c18fe7a0e224ae5c47abcb3ceba64b3379172253c2c49d13c0e9a1baf4115c9add21848969985c9addea9c73744023892170c50616f8d3bfd7358fbee244f7bf
SHA512 (openmp-12.0.0.src.tar.xz) = e01808ab41f13137e225e753a4a89f1ca7917b5783fbec16e46407a51266c96d2651b3b1c1f189760d7a43693abbf266ecdacf9c2e607b577dfe96c3098c167d
SHA512 (openmp-12.0.0.src.tar.xz.sig) = c2ba5ddd93997b7d7cff26168497931b7095a89d1b84c4f5fa761bbaf4f47ba6a39ee9daefffb8ddf37add73de4d42141f8145595c04ebf364ccaec99f03a64f

View File

@ -1,11 +0,0 @@
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
required_packages:
- libomp-test
tests:
- libomp-regression-tests:
dir: ./
run: /usr/libexec/tests/libomp/run-lit-tests --threads 8