RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/libomp#2ce2470e7f7dfa9e63e24af66f2a1ec0c0273f7e
This commit is contained in:
parent
20fe2ed706
commit
3701c70230
47
.gitignore
vendored
47
.gitignore
vendored
@ -0,0 +1,47 @@
|
||||
/openmp-5.0.0.src.tar.xz
|
||||
/openmp-5.0.1.src.tar.xz
|
||||
/openmp-6.0.0rc1.src.tar.xz
|
||||
/openmp-6.0.0rc2.src.tar.xz
|
||||
/openmp-6.0.0.src.tar.xz
|
||||
/openmp-6.0.1rc1.src.tar.xz
|
||||
/openmp-6.0.1.src.tar.xz
|
||||
/openmp-7.0.0rc1.src.tar.xz
|
||||
/openmp-7.0.0rc3.src.tar.xz
|
||||
/openmp-7.0.0.src.tar.xz
|
||||
/openmp-7.0.1.src.tar.xz
|
||||
/openmp-8.0.0rc1.src.tar.xz
|
||||
/openmp-8.0.0rc2.src.tar.xz
|
||||
/openmp-8.0.0rc4.src.tar.xz
|
||||
/openmp-8.0.0.src.tar.xz
|
||||
/openmp-9.0.0rc3.src.tar.xz
|
||||
/openmp-9.0.0.src.tar.xz
|
||||
/openmp-9.0.1.src.tar.xz
|
||||
/openmp-10.0.0rc1.src.tar.xz
|
||||
/openmp-10.0.0rc1.src.tar.xz.sig
|
||||
/openmp-10.0.0rc2.src.tar.xz
|
||||
/openmp-10.0.0rc2.src.tar.xz.sig
|
||||
/openmp-10.0.0rc3.src.tar.xz
|
||||
/openmp-10.0.0rc3.src.tar.xz.sig
|
||||
/openmp-10.0.0rc4.src.tar.xz
|
||||
/openmp-10.0.0rc4.src.tar.xz.sig
|
||||
/openmp-10.0.0rc5.src.tar.xz
|
||||
/openmp-10.0.0rc5.src.tar.xz.sig
|
||||
/openmp-10.0.0rc6.src.tar.xz
|
||||
/openmp-10.0.0rc6.src.tar.xz.sig
|
||||
/openmp-10.0.0.src.tar.xz
|
||||
/openmp-10.0.0.src.tar.xz.sig
|
||||
/openmp-11.0.0rc1.src.tar.xz.sig
|
||||
/openmp-11.0.0rc1.src.tar.xz
|
||||
/openmp-11.0.0rc2.src.tar.xz
|
||||
/openmp-11.0.0rc2.src.tar.xz.sig
|
||||
/libomp-10.0.0-0.3.rc3.fc33.src.rpm
|
||||
/libomp-8.0.0-0.3.rc3.fc29.src.rpm
|
||||
/openmp-11.0.0rc3.src.tar.xz
|
||||
/openmp-11.0.0rc3.src.tar.xz.sig
|
||||
/openmp-8.0.0rc3.src.tar.xz
|
||||
/openmp-11.0.0rc5.src.tar.xz
|
||||
/openmp-11.0.0rc5.src.tar.xz.sig
|
||||
/openmp-11.0.0rc6.src.tar.xz
|
||||
/openmp-11.0.0rc6.src.tar.xz.sig
|
||||
/openmp-11.0.0.src.tar.xz
|
||||
/openmp-11.0.0.src.tar.xz.sig
|
@ -0,0 +1,29 @@
|
||||
From 156a23f5d91c35edd888091b3d6416b755fa134d Mon Sep 17 00:00:00 2001
|
||||
From: Tom Stellard <tstellar@redhat.com>
|
||||
Date: Tue, 16 May 2017 11:52:19 -0400
|
||||
Subject: [PATCH] CMake: Make LIBOMP_HEADERS_INSTALL_PATH a cache variable when
|
||||
bulding standalone
|
||||
|
||||
This way it can be overriden on the command line.
|
||||
---
|
||||
runtime/src/CMakeLists.txt | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/runtime/src/CMakeLists.txt b/runtime/src/CMakeLists.txt
|
||||
index f9e63f4..2bf6796 100644
|
||||
--- a/runtime/src/CMakeLists.txt
|
||||
+++ b/runtime/src/CMakeLists.txt
|
||||
@@ -282,8 +282,8 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
||||
# Install rules
|
||||
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
|
||||
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
|
||||
-if(${OPENMP_STANDALONE_BUILD})
|
||||
- set(LIBOMP_HEADERS_INSTALL_PATH include)
|
||||
+if(${OPENMP_STANDALONE_BUILD})
|
||||
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
|
||||
else()
|
||||
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
|
||||
set(LIBOMP_HEADERS_INSTALL_PATH "${OPENMP_INSTALL_LIBDIR}/clang/${CLANG_VERSION}/include")
|
||||
--
|
||||
1.8.3.1
|
||||
|
12
gating.yaml
Normal file
12
gating.yaml
Normal file
@ -0,0 +1,12 @@
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- fedora-*
|
||||
decision_context: bodhi_update_push_testing
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: fedora-ci.koji-build.tier0.functional}
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- fedora-*
|
||||
decision_context: bodhi_update_push_stable
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: fedora-ci.koji-build.tier0.functional}
|
52
hans-gpg-key.asc
Normal file
52
hans-gpg-key.asc
Normal file
@ -0,0 +1,52 @@
|
||||
-----BEGIN PGP PUBLIC KEY BLOCK-----
|
||||
|
||||
mQINBFS+1SABEACnmkESkY7eZq0GhDjbkWpKmURGk9+ycsfAhA44NqUvf4tk1GPM
|
||||
5SkJ/fYedYZJaDVhIp98fHgucD0O+vjOzghtgwtITusYjiPHPFBd/MN+MQqSEAP+
|
||||
LUa/kjHLjgyXxKhFUIDGVaDWL5tKOA7/AQKl1TyJ8lz89NHQoUHFsF/hu10+qhJe
|
||||
V65d32MXFehIUSvegh8DrPuExrliSiORO4HOhuc6151dWA4YBWVg4rX5kfKrGMMT
|
||||
pTWnSSZtgoRhkKW2Ey8cmZUqPuUJIfWyeNVu1e4SFtAivLvu/Ymz2WBJcNA1ZlTr
|
||||
RCOR5SIRgZ453pQnI/Bzna2nnJ/TV1gGJIGRahj/ini0cs2x1CILfS/YJQ3rWGGo
|
||||
OxwG0BVmPk0cmLVtyTq8gUPwxcPUd6WcBKhot3TDMlrffZACnQwQjlVjk5S1dEEz
|
||||
atUfpEuNitU9WOM4jr/gjv36ZNCOWm95YwLhsuci/NddBN8HXhyvs+zYTVZEXa2W
|
||||
l/FqOdQsQqZBcJjjWckGKhESdd7934+cesGD3O8KaeSGxww7slJrS0+6QJ8oBoAB
|
||||
P/WCn/y2AiY2syEKp3wYIGJyAbsm542zMZ4nc7pYfSu49mcyhQQICmqN5QvOyYUx
|
||||
OSqwbAOUNtlOyeRLZNIKoXtTqWDEu5aEiDROTw6Rkq+dIcxPNgOLdeQ3HwARAQAB
|
||||
tCFIYW5zIFdlbm5ib3JnIDxoYW5zQGNocm9taXVtLm9yZz6JAlUEEwECAD8CGwMG
|
||||
CwkIBwMCBhUIAgkKCwQWAgMBAh4BAheAFiEEtsj5goK5ROOw1cJTD8MELjRa0F0F
|
||||
Alpd+i0FCQ8FJo0ACgkQD8MELjRa0F3X3A//dBQLm6GmXlQFjxZbukTw0lZsevFR
|
||||
M/6ljZTxp7bsC+HFzYoaCKv6rikaWzytxk//SOaLKrB4Z9HjAlpBMtyLl2Hk7tcZ
|
||||
bPpFafNmQ+4KgWNjLXCvt9se8BGrQvGQUrbE6YowbXa2YIgxIVEncFzIECAsp/+N
|
||||
xbMcZN5/X1PJxKi/N22gP4nn47muN6L3pKez3CXgWnhGYSc7BuD5ALWYH7yMYUem
|
||||
d4jlXfu5xkBIqirj1arIYC9wmF4ldbLNDPuracc8LmXcSqa5Rpao0s4iVzAD+tkX
|
||||
vE/73m3rhepwBXxrfk0McXuI9aucf5h4/KkIBzZsaJ6JM1tzlrJzzjaBKJF9OI5T
|
||||
jA0qTxdGzdPztS8gPaPcMkRFfh9ti0ZDx4VeF3s8sOtmMRHeGEWfxqUAbBUbwFsa
|
||||
JDu/+8/VO4KijfcuUi8tqJ/JHeosCuGE7TM93LwJu6ZcqMYOPDROE/hsnGm0ZU92
|
||||
xedu+07/X1ESHkSFPoaSHD5/DCNa/tXIyJZ8X7gF3eoDP5mSmrJqIqsOBR9WOVYv
|
||||
dI8i0GHTXbrZj8WXdoS+N8wlyMLLbAS2jvTe7M5RoqbLz4ABOUUnLVoEE0CiccVZ
|
||||
bW75BPxOfaD0szbinAeX6HDPI7St0MbKrRPjuDXjD0JVkLqFINtZfYLGMLss4tgn
|
||||
suefr0Bo9ISwG3u5Ag0EVL7VIAEQAOxBxrQesChjrCqKjY5PnSsSYpeb4froucrC
|
||||
898AFw2DgN/Zz+W7wtSTbtz/GRcCurjzZvN7o2rCuNk0j0+s1sgZZm2BdldlabLy
|
||||
+UF/kSW1rb5qhfXcGGubu48OMdtSfok9lOc0Q1L4HNlGE4lUBkZzmI7Ykqfl+Bwr
|
||||
m9rpi54g4ua9PIiiHIAmMoZIcbtOG1KaDr6CoXRk/3g2ZiGUwhq3jFGroiBsKEap
|
||||
2FJ1bh5NJk2Eg8pV7fMOF7hUQKBZrNOtIPu8hA5WEgku3U3VYjRSI3SDi6QXnDL+
|
||||
xHxajiWpKtF3JjZh8y/CCTD8PyP34YjfZuFmkdske5cdx6H0V2UCiH453ncgFVdQ
|
||||
DXkY4n+0MTzhy2xu0IVVnBxYDYNhi+3MjTHJd9C4xMi9t+5IuEvDAPhgfZjDpQak
|
||||
EPz6hVmgj0mlKIgRilBRK9/kOxky9utBpGk3jEJGru/hKNloFNspoYtY6zATAr8E
|
||||
cOgoCFQE0nIktcg3wF9+OCEnV28/a7XZwUZ7Gl/qfOHtdr374wo8kd8R3V8d2G9q
|
||||
5w0/uCV9NNQ0fGWZDPDoYt6wnPL6gZv/nJM8oZY+u0rC24WwScZIniaryC4JHDas
|
||||
Ahr2S2CtgCvBgslK6f3gD16KHxPZMBpX73TzOYIhMEP/vXgVJbUD6dYht+U9c4Oh
|
||||
EDJown0dABEBAAGJAjwEGAECACYCGwwWIQS2yPmCgrlE47DVwlMPwwQuNFrQXQUC
|
||||
Wl36SwUJDwUmqwAKCRAPwwQuNFrQXT1/D/9YpRDNgaJl3YVDtVZoeQwh7BQ6ULZT
|
||||
eXFPogYkF2j3VWg8s9UmAs4sg/4a+9KLSantXjX+JFsRv0lQe5Gr/Vl8VQ4LKEXB
|
||||
fiGmSivjIZ7eopdd3YP2w6G5T3SA4d2CQfsg4rnJPnXIjzKNiSOi368ybnt9fL0Y
|
||||
2r2aqLTmP6Y7issDUO+J1TW1XHm349JPR0Hl4cTuNnWm4JuX2m2CJEc5XBlDAha9
|
||||
pUVs+J5C2D0UFFkyeOzeJPwy6x5ApWHm84n8AjhQSpu1qRKxKXdwei6tkQWWMHui
|
||||
+TgSY/zCkmD9/oY15Ei5avJ4WgIbTLJUoZMi70riPmU8ThjpzA7S+Nk0g7rMPq+X
|
||||
l1whjKU/u0udlsrIJjzkh6ftqKUmIkbxYTpjhnEujNrEr5m2S6Z6x3y9E5QagBMR
|
||||
dxRhfk+HbyACcP/p9rXOzl4M291DoKeAAH70GHniGxyNs9rAoMr/hD5XW/Wrz3dc
|
||||
KMc2s555E6MZILE2ZiolcRn+bYOMPZtWlbx98t8uqMf49gY4FGQBZAwPglMrx7mr
|
||||
m7HTIiXahThQGOJg6izJDAD5RwSEGlAcL28T8KAuM6CLLkhlBfQwiKsUBNnh9r8w
|
||||
V3lB+pV0GhL+3i077gTYfZBRwLzjFdhm9xUKEaZ6rN1BX9lzix4eSNK5nln0jUq1
|
||||
67H2IH//2sf8dw==
|
||||
=ADVe
|
||||
-----END PGP PUBLIC KEY BLOCK-----
|
299
libomp.spec
Normal file
299
libomp.spec
Normal file
@ -0,0 +1,299 @@
|
||||
#%%global rc_ver 6
|
||||
%global baserelease 1
|
||||
%global libomp_srcdir openmp-%{version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
|
||||
%ifarch ppc64le
|
||||
%global libomp_arch ppc64
|
||||
%else
|
||||
%global libomp_arch %{_arch}
|
||||
%endif
|
||||
|
||||
Name: libomp
|
||||
Version: 11.0.0
|
||||
Release: %{baserelease}%{?rc_ver:.rc%{rc_ver}}%{?dist}
|
||||
Summary: OpenMP runtime for clang
|
||||
|
||||
License: NCSA
|
||||
URL: http://openmp.llvm.org
|
||||
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz
|
||||
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}%{?rc_ver:-rc%{rc_ver}}/%{libomp_srcdir}.tar.xz.sig
|
||||
Source2: https://prereleases.llvm.org/%{version}/hans-gpg-key.asc
|
||||
Source3: run-lit-tests
|
||||
Source4: lit.fedora.cfg.py
|
||||
|
||||
Patch0: 0001-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-a-cache-varia.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: cmake
|
||||
BuildRequires: ninja-build
|
||||
BuildRequires: elfutils-libelf-devel
|
||||
BuildRequires: perl
|
||||
BuildRequires: perl-Data-Dumper
|
||||
BuildRequires: perl-Encode
|
||||
BuildRequires: libffi-devel
|
||||
|
||||
# For gpg source verification
|
||||
BuildRequires: gnupg2
|
||||
|
||||
Requires: elfutils-libelf%{?isa}
|
||||
|
||||
# libomp does not support s390x.
|
||||
ExcludeArch: s390x
|
||||
|
||||
%description
|
||||
OpenMP runtime for clang.
|
||||
|
||||
%package devel
|
||||
Summary: OpenMP header files
|
||||
Requires: clang-devel%{?isa} = %{version}
|
||||
|
||||
%description devel
|
||||
OpenMP header files.
|
||||
|
||||
%package test
|
||||
Summary: OpenMP regression tests
|
||||
Requires: %{name}%{?isa} = %{version}-%{release}
|
||||
Requires: %{name}-devel%{?isa} = %{version}-%{release}
|
||||
Requires: clang
|
||||
Requires: llvm
|
||||
Requires: gcc
|
||||
Requires: gcc-c++
|
||||
Requires: python3-lit
|
||||
|
||||
%description test
|
||||
OpenMP regression tests
|
||||
|
||||
%prep
|
||||
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||
%autosetup -n %{libomp_srcdir} -p1
|
||||
|
||||
%build
|
||||
# LTO causes build failures in this package. Disable LTO for now
|
||||
%define _lto_cflags %{nil}
|
||||
|
||||
%cmake -GNinja \
|
||||
-DLIBOMP_INSTALL_ALIASES=OFF \
|
||||
-DLIBOMP_HEADERS_INSTALL_PATH:PATH=%{_libdir}/clang/%{version}/include \
|
||||
%if 0%{?__isa_bits} == 64
|
||||
-DOPENMP_LIBDIR_SUFFIX=64 \
|
||||
%else
|
||||
-DOPENMP_LIBDIR_SUFFIX= \
|
||||
%endif
|
||||
|
||||
%cmake_build
|
||||
|
||||
|
||||
%install
|
||||
%cmake_install
|
||||
|
||||
# Test package setup
|
||||
%global libomp_srcdir %{_datadir}/libomp/src/
|
||||
%global libomp_testdir %{libomp_srcdir}/runtime/test/
|
||||
%global lit_cfg %{libomp_testdir}/%{_arch}.site.cfg.py
|
||||
%global lit_fedora_cfg %{_datadir}/libomp/lit.fedora.cfg.py
|
||||
|
||||
install -d %{buildroot}%{libomp_srcdir}/runtime
|
||||
cp -R runtime/test %{buildroot}%{libomp_srcdir}/runtime
|
||||
cp -R runtime/src %{buildroot}%{libomp_srcdir}/runtime
|
||||
|
||||
# Generate lit config files. Strip off the last line that initiates the
|
||||
# test run, so we can customize the configuration.
|
||||
head -n -1 %{_vpath_builddir}/runtime/test/lit.site.cfg >> %{buildroot}%{lit_cfg}
|
||||
|
||||
# Install custom fedora config file
|
||||
cp %{SOURCE4} %{buildroot}%{lit_fedora_cfg}
|
||||
|
||||
# Patch lit config files to load custom fedora config
|
||||
echo "lit_config.load_config(config, '%{lit_fedora_cfg}')" >> %{buildroot}%{lit_cfg}
|
||||
|
||||
# Install test script
|
||||
install -d %{buildroot}%{_libexecdir}/tests/libomp
|
||||
install -m 0755 %{SOURCE3} %{buildroot}%{_libexecdir}/tests/libomp
|
||||
|
||||
# Remove static libraries with equivalent shared libraries
|
||||
rm -rf %{buildroot}%{_libdir}/libarcher_static.a
|
||||
|
||||
%check
|
||||
%cmake_build --target check-openmp
|
||||
|
||||
%files
|
||||
%license LICENSE.txt
|
||||
%{_libdir}/libomp.so
|
||||
%{_libdir}/libomptarget.so
|
||||
%ifnarch %{arm}
|
||||
%{_libdir}/libarcher.so
|
||||
%endif
|
||||
%ifnarch %{arm} %{ix86}
|
||||
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%{_libdir}/clang/%{version}/include/omp.h
|
||||
%ifnarch %{arm}
|
||||
%{_libdir}/clang/%{version}/include/omp-tools.h
|
||||
%{_libdir}/clang/%{version}/include/ompt.h
|
||||
# FIXME: This is probably wrong. Seems like LIBOMP_HEADERS_INSTALL may
|
||||
# not be respected.
|
||||
%{_includedir}/ompt-multiplex.h
|
||||
%endif
|
||||
|
||||
%files test
|
||||
%{_datadir}/libomp
|
||||
%{_libexecdir}/tests/libomp/
|
||||
|
||||
%changelog
|
||||
* Thu Oct 15 2020 sguelton@redhat.com - 11.0.0-1
|
||||
- Fix NVR
|
||||
|
||||
* Mon Oct 12 2020 sguelton@redhat.com - 11.0.0-0.5
|
||||
- llvm 11.0.0 - final release
|
||||
|
||||
* Thu Oct 08 2020 sguelton@redhat.com - 11.0.0-0.4.rc6
|
||||
- 11.0.0-rc6
|
||||
|
||||
* Fri Oct 02 2020 sguelton@redhat.com - 11.0.0-0.3.rc5
|
||||
- 11.0.0-rc5 Release
|
||||
|
||||
* Sun Sep 27 2020 sguelton@redhat.com - 11.0.0-0.2.rc3
|
||||
- Fix NVR
|
||||
|
||||
* Thu Sep 24 2020 sguelton@redhat.com - 11.0.0-0.1.rc3
|
||||
- 11.0.0-rc3 Release
|
||||
|
||||
* Tue Sep 01 2020 sguelton@redhat.com - 11.0.0-0.1.rc2
|
||||
- 11.0.0-rc2 Release
|
||||
|
||||
* Mon Aug 10 2020 Tom Stellard <tstellar@redhat.com> - 11.0.0-0.1.rc1
|
||||
- 11.0.0-rc1 Release
|
||||
|
||||
* Mon Aug 10 2020 sguelton@redhat.com - 10.0.0-8
|
||||
- Make gcc dependency explicit, see https://fedoraproject.org/wiki/Packaging:C_and_C%2B%2B#BuildRequires_and_Requires
|
||||
- use %%license macro
|
||||
|
||||
* Sat Aug 08 2020 Jeff Law <releng@fedoraproject.org> - 10.0.0-7
|
||||
- Disable LTO for now
|
||||
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 10.0.0-6
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 10.0.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 20 2020 sguelton@redhat.com - 10.0.0-4
|
||||
- Use modern cmake macro
|
||||
- Use gnupg verify
|
||||
|
||||
* Tue Jun 16 2020 sguelton@redhat.com - 10.0.0-3
|
||||
- Add Requires: libomp = %{version}-%{release} to libomp-test to avoid
|
||||
the need to test interoperability between the various combinations of old
|
||||
and new subpackages.
|
||||
|
||||
* Mon Jun 01 2020 sguelton@redhat.com - 10.0.0-2
|
||||
- Add Requires: libomp-devel = %{version}-%{release} to libomp-test to avoid
|
||||
the need to test interoperability between the various combinations of old
|
||||
and new subpackages.
|
||||
|
||||
* Mon Mar 30 2020 sguelton@redhat.com - 10.0.0-1
|
||||
- 10.0.0 final
|
||||
|
||||
* Wed Mar 25 2020 sguelton@redhat.com - 10.0.0-0.6.rc6
|
||||
- 10.0.0 rc6
|
||||
|
||||
* Fri Mar 20 2020 sguelton@redhat.com - 10.0.0-0.5.rc5
|
||||
- 10.0.0 rc5
|
||||
|
||||
* Sun Mar 15 2020 sguelton@redhat.com - 10.0.0-0.4.rc4
|
||||
- 10.0.0 rc4
|
||||
|
||||
* Thu Mar 05 2020 sguelton@redhat.com - 10.0.0-0.3.rc3
|
||||
- 10.0.0 rc3
|
||||
|
||||
* Fri Feb 14 2020 sguelton@redhat.com - 10.0.0-0.2.rc2
|
||||
- 10.0.0 rc2
|
||||
|
||||
* Fri Jan 31 2020 sguelton@redhat.com - 10.0.0-0.1.rc1
|
||||
- 10.0.0 rc1
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 9.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Dec 19 2019 Tom Stellard <tstellar@redhat.com> - 9.0.1-1
|
||||
- 9.0.1 Release
|
||||
|
||||
* Thu Sep 19 2019 Tom Stellard <tstellar@redhat.com> - 9.0.0-1
|
||||
- 9.0.0 Release
|
||||
|
||||
* Thu Aug 22 2019 Tom Stellard <tstellar@redhat.com> - 9.0.0-0.1.rc3
|
||||
- 9.0.0-rc3 Release
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.0.0-2.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Apr 25 2019 Tom Stellard <tstellar@redhat.com> - 8.0.0-2
|
||||
- Simplify libomp-test package
|
||||
|
||||
* Wed Mar 20 2019 sguelton@redhat.com - 8.0.0-1
|
||||
- 8.0.0 final
|
||||
|
||||
* Tue Mar 12 2019 sguelton@redhat.com - 8.0.0-0.3.rc4
|
||||
- 8.0.0 Release candidate 4
|
||||
|
||||
* Mon Feb 11 2019 sguelton@redhat.com - 8.0.0-0.2.rc2
|
||||
- 8.0.0 Release candidate 2
|
||||
|
||||
* Mon Feb 11 2019 sguelton@redhat.com - 8.0.0-0.1.rc1
|
||||
- 8.0.0 Release candidate 1
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.0.1-1.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Mon Dec 17 2018 sguelton@redhat.com - 7.0.1-1
|
||||
- 7.0.1 Release
|
||||
|
||||
* Wed Sep 12 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-1
|
||||
- 7.0.1 Release
|
||||
|
||||
* Wed Sep 12 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.2.rc3
|
||||
- 7.0.0-rc3 Release
|
||||
|
||||
* Tue Aug 14 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.1.rc1
|
||||
- 7.0.1-rc1 Release
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Jul 02 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-2
|
||||
- Add -threads option to runtest.sh
|
||||
|
||||
* Thu Jun 28 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-1
|
||||
- 6.0.1 Release
|
||||
|
||||
* Fri May 11 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-0.1.rc1
|
||||
- 6.0.1-rc1 Release
|
||||
|
||||
* Wed Mar 28 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-3
|
||||
- Add test package
|
||||
|
||||
* Wed Mar 28 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-2
|
||||
- Enable libomptarget plugins
|
||||
|
||||
* Fri Mar 09 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-1
|
||||
- 6.0.0 Release
|
||||
|
||||
* Tue Feb 13 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-0.3.rc2
|
||||
- 6.0.0-rc2 Release
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.0-0.2.rc1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jan 25 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-0.1.rc1
|
||||
- 6.0.0-rc1 Release
|
||||
|
||||
* Thu Dec 21 2017 Tom Stellard <tstellar@redhat.com> - 5.0.1-1
|
||||
- 5.0.1 Release.
|
||||
|
||||
* Mon May 15 2017 Tom Stellard <tstellar@redhat.com> - 5.0.0-1
|
||||
- Initial version.
|
15
lit.fedora.cfg.py
Normal file
15
lit.fedora.cfg.py
Normal file
@ -0,0 +1,15 @@
|
||||
import tempfile
|
||||
|
||||
compiler = '%(libomp_compiler)s' % lit_config.params
|
||||
config.test_filecheck = '%(bindir)s/FileCheck' % lit_config.params
|
||||
config.omp_header_directory = '%(includedir)s' % lit_config.params
|
||||
config.libomp_obj_root = tempfile.mkdtemp()
|
||||
config.library_dir = '%(libdir)s' % lit_config.params
|
||||
test_root = '%(libomp_test_root)s' % lit_config.params
|
||||
|
||||
# Lit will default to the compiler used to build openmp, which is gcc, but we
|
||||
# want to run the tests using clang.
|
||||
config.test_compiler_features = ['clang']
|
||||
config.test_c_compiler = 'clang'
|
||||
config.test_cxx_compiler = 'clang++'
|
||||
lit_config.load_config(config, '%(libomp_test_root)s/lit.cfg' % lit_config.params)
|
59
run-lit-tests
Normal file
59
run-lit-tests
Normal file
@ -0,0 +1,59 @@
|
||||
#!/usr/bin/bash
|
||||
|
||||
usage() {
|
||||
echo "usage: `basename $0` [OPTIONS]"
|
||||
echo " --threads NUM The number of threads to use for running tests."
|
||||
}
|
||||
|
||||
|
||||
threads_arg=''
|
||||
|
||||
while [ $# -gt 0 ]; do
|
||||
case $1 in
|
||||
--threads)
|
||||
shift
|
||||
threads_arg="--threads $1"
|
||||
;;
|
||||
--multilib-arch)
|
||||
shift
|
||||
ARCH=$1
|
||||
;;
|
||||
* )
|
||||
echo "unknown option: $1"
|
||||
echo ""
|
||||
usage
|
||||
exit 1
|
||||
;;
|
||||
esac
|
||||
shift
|
||||
done
|
||||
|
||||
|
||||
set -xe
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
ARCH=`rpm --eval '%_arch'`
|
||||
fi
|
||||
|
||||
case $ARCH in
|
||||
arm)
|
||||
;&
|
||||
i686)
|
||||
LIB_DIR="/usr/lib/"
|
||||
;;
|
||||
*)
|
||||
LIB_DIR="/usr/lib64/"
|
||||
;;
|
||||
esac
|
||||
|
||||
BIN_DIR="/usr/bin/"
|
||||
INCLUDE_DIR="/usr/include/"
|
||||
|
||||
lit $threads_arg -v \
|
||||
--config-prefix $ARCH \
|
||||
-Dlibomp_compiler=clang \
|
||||
-Dbindir=$BIN_DIR \
|
||||
-Dlibdir=$LIB_DIR \
|
||||
-Dincludedir=$INCLUDE_DIR \
|
||||
-Dlibomp_test_root=/usr/share/libomp/src/runtime/test \
|
||||
/usr/share/libomp/src/runtime/test
|
2
sources
Normal file
2
sources
Normal file
@ -0,0 +1,2 @@
|
||||
SHA512 (openmp-11.0.0.src.tar.xz) = 077301ab0d4c8f438ae92e4ea031ed9d9eb27130d77b3b8c13cb27160bfffe54fc2001c43da6dcaa28da0580a367072ccc37ecddb6e078b18ce873040bbb2b76
|
||||
SHA512 (openmp-11.0.0.src.tar.xz.sig) = 32be746e239a578ef9ee5663f9fae7d9f05d853ed9fb8d6d2f71c0c6fa66013f27106c7dc8cbfaa7fd9e06b1de6bdfb4be02379752b4ebf94ad0511ac4c6b7fb
|
11
tests/tests.yml
Normal file
11
tests/tests.yml
Normal file
@ -0,0 +1,11 @@
|
||||
- hosts: localhost
|
||||
roles:
|
||||
- role: standard-test-basic
|
||||
tags:
|
||||
- classic
|
||||
required_packages:
|
||||
- libomp-test
|
||||
tests:
|
||||
- libomp-regression-tests:
|
||||
dir: ./
|
||||
run: /usr/libexec/tests/libomp/run-lit-tests --threads 8
|
Loading…
Reference in New Issue
Block a user