import libomp-14.0.0-1.module+el8.7.0+15007+c9f3328f
This commit is contained in:
parent
1b9c9a164a
commit
044559726b
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
SOURCES/openmp-13.0.1.src.tar.xz
|
||||
SOURCES/openmp-14.0.0.src.tar.xz
|
||||
SOURCES/tstellar-gpg-key.asc
|
||||
|
@ -1,2 +1,2 @@
|
||||
a5b883a2fbdc14ec44277cc9cc0f6592d80663e4 SOURCES/openmp-13.0.1.src.tar.xz
|
||||
81984bd288c9dead1a310b5fade13c4942195594 SOURCES/openmp-14.0.0.src.tar.xz
|
||||
b8d2648a01d36ed0186fd2c5af325fd28797f9a0 SOURCES/tstellar-gpg-key.asc
|
||||
|
@ -13,11 +13,11 @@ diff --git a/openmp/runtime/src/CMakeLists.txt b/openmp/runtime/src/CMakeLists.t
|
||||
index 822f9ca..583a3c3 100644
|
||||
--- a/openmp/runtime/src/CMakeLists.txt
|
||||
+++ b/openmp/runtime/src/CMakeLists.txt
|
||||
@@ -305,7 +305,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
||||
@@ -346,7 +346,7 @@ add_dependencies(libomp-micro-tests libomp-test-deps)
|
||||
# We want to install libomp in DESTDIR/CMAKE_INSTALL_PREFIX/lib
|
||||
# We want to install headers in DESTDIR/CMAKE_INSTALL_PREFIX/include
|
||||
if(${OPENMP_STANDALONE_BUILD})
|
||||
- set(LIBOMP_HEADERS_INSTALL_PATH include)
|
||||
- set(LIBOMP_HEADERS_INSTALL_PATH "${CMAKE_INSTALL_INCLUDEDIR}")
|
||||
+ set(LIBOMP_HEADERS_INSTALL_PATH include CACHE PATH "Install path for OpenMP headers")
|
||||
else()
|
||||
string(REGEX MATCH "[0-9]+\\.[0-9]+(\\.[0-9]+)?" CLANG_VERSION ${PACKAGE_VERSION})
|
||||
|
12
SOURCES/gcc-workaround.patch
Normal file
12
SOURCES/gcc-workaround.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ruN openmp-14.0.0.src.orig/runtime/src/kmp_lock.cpp openmp-14.0.0.src/runtime/src/kmp_lock.cpp
|
||||
--- a/openmp-14.0.0.src.orig/runtime/src/kmp_lock.cpp 2022-03-14 10:44:55.000000000 +0100
|
||||
+++ b/openmp-14.0.0.src/runtime/src/kmp_lock.cpp 2022-04-22 10:58:26.736078432 +0200
|
||||
@@ -2663,7 +2663,7 @@
|
||||
}
|
||||
|
||||
// Truncated binary exponential backoff function
|
||||
-void __kmp_spin_backoff(kmp_backoff_t *boff) {
|
||||
+void __attribute__((optimize("O1"))) __kmp_spin_backoff(kmp_backoff_t *boff) {
|
||||
// We could flatten this loop, but making it a nested loop gives better result
|
||||
kmp_uint32 i;
|
||||
for (i = boff->step; i > 0; i--) {
|
Binary file not shown.
BIN
SOURCES/openmp-14.0.0.src.tar.xz.sig
Normal file
BIN
SOURCES/openmp-14.0.0.src.tar.xz.sig
Normal file
Binary file not shown.
@ -1,5 +1,5 @@
|
||||
%global libomp_version 13.0.1
|
||||
#global rc_ver 3
|
||||
%global libomp_version 14.0.0
|
||||
#global rc_ver 1
|
||||
%global libomp_srcdir openmp-%{libomp_version}%{?rc_ver:rc%{rc_ver}}.src
|
||||
|
||||
|
||||
@ -23,6 +23,10 @@ Source3: run-lit-tests
|
||||
Source4: lit.fedora.cfg.py
|
||||
|
||||
Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch
|
||||
# RHEL specific: Workaround for a bug in GCC that breaks compiling
|
||||
# the kmp_lock.cpp. Without this patch, GCC errors out with
|
||||
# ../runtime/src/kmp_lock.cpp:2684:1: error: unsupported size for integer register
|
||||
Patch1: gcc-workaround.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -33,11 +37,12 @@ BuildRequires: perl
|
||||
BuildRequires: perl-Data-Dumper
|
||||
BuildRequires: perl-Encode
|
||||
BuildRequires: libffi-devel
|
||||
# RHEL specific: libomp requires libterminfo
|
||||
BuildRequires: ncurses-devel
|
||||
|
||||
# The AMDGCN device RTL requires clang and llvm-link to build
|
||||
BuildRequires: clang
|
||||
BuildRequires: llvm
|
||||
# For gpg source verification
|
||||
BuildRequires: gnupg2
|
||||
|
||||
|
||||
# libomptarget needs the llvm cmake files
|
||||
BuildRequires: llvm-devel
|
||||
@ -71,6 +76,7 @@ Requires: python3-lit
|
||||
OpenMP regression tests
|
||||
|
||||
%prep
|
||||
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||
%autosetup -n %{libomp_srcdir} -p2
|
||||
|
||||
%build
|
||||
@ -90,6 +96,7 @@ cd %{_vpath_builddir}
|
||||
%else
|
||||
-DOPENMP_LIBDIR_SUFFIX= \
|
||||
%endif
|
||||
-DCMAKE_SKIP_RPATH:BOOL=ON
|
||||
|
||||
%cmake_build
|
||||
|
||||
@ -132,11 +139,11 @@ cd %{_vpath_builddir}
|
||||
%files
|
||||
%license LICENSE.TXT
|
||||
%{_libdir}/libomp.so
|
||||
%{_libdir}/libompd.so
|
||||
%ifnarch %{arm}
|
||||
%{_libdir}/libarcher.so
|
||||
%endif
|
||||
%ifnarch %{ix86} %{arm}
|
||||
%{_libdir}/libomptarget-amdgcn*.bc
|
||||
%{_libdir}/libomptarget.rtl.amdgpu.so
|
||||
%{_libdir}/libomptarget.rtl.cuda.so
|
||||
%{_libdir}/libomptarget.rtl.%{libomp_arch}.so
|
||||
@ -159,6 +166,9 @@ cd %{_vpath_builddir}
|
||||
%{_libexecdir}/tests/libomp/
|
||||
|
||||
%changelog
|
||||
* Thu Apr 07 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-1
|
||||
- Update to 14.0.0
|
||||
|
||||
* Thu Feb 03 2022 Tom Stellard <tstellar@redhat.com> - 13.0.1-1
|
||||
- 13.0.1 Release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user