auto-import liboggz-0.9.1-2.fc4 on branch devel from
liboggz-0.9.1-2.fc4.src.rpm
This commit is contained in:
parent
ff23e66075
commit
851d6d195b
@ -0,0 +1 @@
|
||||
liboggz-0.9.1.tar.gz
|
12
liboggz.autotools.patch
Normal file
12
liboggz.autotools.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Naur liboggz-0.9.1/include/oggz/Makefile.am liboggz-0.9.1.patched/include/oggz/Makefile.am
|
||||
--- liboggz-0.9.1/include/oggz/Makefile.am 2004-11-14 02:11:30.000000000 +0100
|
||||
+++ liboggz-0.9.1.patched/include/oggz/Makefile.am 2005-06-03 18:00:48.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
## Process this file with automake to produce Makefile.in
|
||||
|
||||
# Include files to install
|
||||
-includedir = $(prefix)/include/oggz
|
||||
-include_HEADERS = oggz.h oggz_constants.h oggz_read.h oggz_seek.h \
|
||||
+oggzincludedir = $(includedir)/oggz
|
||||
+oggzinclude_HEADERS = oggz.h oggz_constants.h oggz_read.h oggz_seek.h \
|
||||
oggz_write.h oggz_io.h oggz_table.h oggz_deprecated.h
|
13
liboggz.corruption.patch
Normal file
13
liboggz.corruption.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: src/tools/oggzrip.c
|
||||
===================================================================
|
||||
--- src/tools/oggzrip.c (revision 1312)
|
||||
+++ src/tools/oggzrip.c (working copy)
|
||||
@@ -101,7 +101,7 @@
|
||||
static ORData *
|
||||
ordata_new ()
|
||||
{
|
||||
- ORData *ordata = malloc (sizeof (ordata));
|
||||
+ ORData *ordata = malloc (sizeof (ORData));
|
||||
assert (ordata != NULL);
|
||||
memset (ordata, 0, sizeof (ORData));
|
||||
|
99
liboggz.spec
Normal file
99
liboggz.spec
Normal file
@ -0,0 +1,99 @@
|
||||
Name: liboggz
|
||||
Version: 0.9.1
|
||||
Release: 2%{?dist}
|
||||
Summary: Simple programming interface for Ogg files and streams
|
||||
|
||||
Group: System Environment/Libraries
|
||||
License: BSD
|
||||
URL: http://www.annodex.net/
|
||||
Source: http://www.annodex.net/software/liboggz/download/%{name}-%{version}.tar.gz
|
||||
# fixed in upstream CVS
|
||||
Patch: liboggz.autotools.patch
|
||||
# fixed in upstream CVS
|
||||
Patch1: liboggz.corruption.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: libogg-devel >= 1.0
|
||||
|
||||
# libtool
|
||||
BuildRequires: gcc-c++
|
||||
|
||||
# since we patch Makefile.am
|
||||
BuildRequires: libtool
|
||||
BuildRequires: automake
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: pkgconfig
|
||||
|
||||
%description
|
||||
Oggz provides a simple programming interface for reading and writing Ogg files
|
||||
and streams. Ogg is an interleaving data container developed by Monty at
|
||||
Xiph.Org, originally to support the Ogg Vorbis audio format.
|
||||
|
||||
%package devel
|
||||
Summary: Files needed for development using liboggz
|
||||
Group: Development/Libraries
|
||||
Requires: liboggz = %{version}
|
||||
Requires: libogg-devel >= 1.0
|
||||
Requires: pkgconfig
|
||||
|
||||
%description devel
|
||||
Oggz provides a simple programming interface for reading and writing Ogg files
|
||||
and streams. Ogg is an interleaving data container developed by Monty at
|
||||
Xiph.Org, originally to support the Ogg Vorbis audio format.
|
||||
|
||||
This package contains the header files and documentation needed for
|
||||
development using liboggz.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch -p1
|
||||
%patch1 -p0
|
||||
|
||||
%build
|
||||
aclocal
|
||||
autoconf
|
||||
automake
|
||||
%configure
|
||||
make
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
%makeinstall
|
||||
|
||||
# remove unpackaged files from the buildroot
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
|
||||
# remove doxygen build stamp; fixed in upstream CVS
|
||||
rm -f $RPM_BUILD_ROOT%{_datadir}/doc/liboggz/doxygen-build.stamp
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc AUTHORS ChangeLog COPYING README
|
||||
# 0 length NEWS file
|
||||
# %doc NEWS
|
||||
%{_libdir}/liboggz.so.*
|
||||
%{_mandir}/man1/*
|
||||
%{_bindir}/oggz*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/liboggz.so
|
||||
%{_libdir}/liboggz.a
|
||||
%{_libdir}/pkgconfig/oggz.pc
|
||||
%doc %{_docdir}/liboggz
|
||||
%{_includedir}/oggz/oggz*.h
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Mon Jun 13 2005 Thomas Vander Stichele <thomas at apestaart dot org>
|
||||
- 0.9.1-2: rpmlint cleanup
|
||||
|
||||
* Fri Jun 03 2005 Thomas Vander Stichele <thomas at apestaart dot org>
|
||||
- 0.9.1-1: initial package
|
Loading…
Reference in New Issue
Block a user