auto-import changelog data from libogg-1.1-1.src.rpm
1.1-1 - update to 1.1 1.0-5.1 - build for RHEL
This commit is contained in:
parent
7da9c3b985
commit
59375a1d70
@ -1 +1 @@
|
||||
libogg-1.0.tar.gz
|
||||
libogg-1.1.tar.gz
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- libogg-1.0/ogg.m4.ook Wed Dec 11 17:15:08 2002
|
||||
+++ libogg-1.0/ogg.m4 Wed Dec 11 17:15:39 2002
|
||||
--- libogg-1.1/ogg.m4.orig 2003-03-07 21:44:29.000000000 -0500
|
||||
+++ libogg-1.1/ogg.m4 2003-12-11 15:08:01.000000000 -0500
|
||||
@@ -19,7 +19,7 @@
|
||||
elif test "x$ogg_prefix" != "x" ; then
|
||||
OGG_LIBS="-L$ogg_prefix/lib"
|
||||
@ -12,7 +12,7 @@
|
||||
@@ -29,7 +29,7 @@
|
||||
elif test "x$ogg_prefix" != "x" ; then
|
||||
OGG_CFLAGS="-I$ogg_prefix/include"
|
||||
elif test "$prefix" != "xNONE"; then
|
||||
elif test "x$prefix" != "xNONE"; then
|
||||
- OGG_CFLAGS="-I$prefix/include"
|
||||
+ OGG_CFLAGS=""
|
||||
fi
|
||||
|
39
libogg-1.1-64bit.patch
Normal file
39
libogg-1.1-64bit.patch
Normal file
@ -0,0 +1,39 @@
|
||||
--- libogg-1.1/src/bitwise.c.orig 2003-12-07 01:48:17.000000000 +0100
|
||||
+++ libogg-1.1/src/bitwise.c 2003-12-07 01:52:58.000000000 +0100
|
||||
@@ -251,7 +251,8 @@ long oggpack_look(oggpack_buffer *b,int
|
||||
/* Read in bits without advancing the bitptr; bits <= 32 */
|
||||
long oggpackB_look(oggpack_buffer *b,int bits){
|
||||
unsigned long ret;
|
||||
- int m=32-bits;
|
||||
+ unsigned long m=mask[bits];
|
||||
+ int s=32-bits;
|
||||
|
||||
bits+=b->endbit;
|
||||
|
||||
@@ -272,7 +273,7 @@ long oggpackB_look(oggpack_buffer *b,int
|
||||
}
|
||||
}
|
||||
}
|
||||
- return (ret>>(m>>1))>>((m+1)>>1);
|
||||
+ return ((ret>>(s>>1))>>((s+1)>>1)&m);
|
||||
}
|
||||
|
||||
long oggpack_look1(oggpack_buffer *b){
|
||||
@@ -347,7 +348,8 @@ long oggpack_read(oggpack_buffer *b,int
|
||||
/* bits <= 32 */
|
||||
long oggpackB_read(oggpack_buffer *b,int bits){
|
||||
unsigned long ret;
|
||||
- long m=32-bits;
|
||||
+ unsigned long m=mask[bits];
|
||||
+ long s=32-bits;
|
||||
|
||||
bits+=b->endbit;
|
||||
|
||||
@@ -369,7 +371,7 @@ long oggpackB_read(oggpack_buffer *b,int
|
||||
}
|
||||
}
|
||||
}
|
||||
- ret=(ret>>(m>>1))>>((m+1)>>1);
|
||||
+ ret=((ret>>(s>>1))>>((s+1)>>1)&m);
|
||||
|
||||
overflow:
|
22
libogg.spec
22
libogg.spec
@ -1,13 +1,14 @@
|
||||
Summary: The Ogg bitstream file format library.
|
||||
Name: libogg
|
||||
Version: 1.0
|
||||
Release: 5
|
||||
Version: 1.1
|
||||
Release: 1
|
||||
Epoch: 2
|
||||
Group: System Environment/Libraries
|
||||
Copyright: BSD
|
||||
URL: http://www.xiph.org/
|
||||
Source: http://www.xiph.org/pub/ogg/vorbis/download/libogg-%{version}.tar.gz
|
||||
Patch: libogg-1.0-m4.patch
|
||||
Patch2: libogg-1.1-64bit.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
@ -28,6 +29,7 @@ needed for development using libogg.
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch -p1
|
||||
%patch2 -p1 -b .64
|
||||
|
||||
%build
|
||||
perl -p -i -e "s/-O20/$RPM_OPT_FLAGS/" configure
|
||||
@ -49,12 +51,9 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%doc doc/index.html
|
||||
%doc doc/framing.html
|
||||
%doc doc/oggstream.html
|
||||
%doc doc/white-ogg.png
|
||||
%doc doc/white-xifish.png
|
||||
%doc doc/stream.png
|
||||
%doc doc/*.html
|
||||
%doc doc/*.txt
|
||||
%doc doc/*.png
|
||||
%doc doc/ogg
|
||||
%dir %{_includedir}/ogg
|
||||
%{_includedir}/ogg/ogg.h
|
||||
@ -62,6 +61,7 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
%{_includedir}/ogg/config_types.h
|
||||
%{_libdir}/libogg.a
|
||||
%{_libdir}/libogg.so
|
||||
%{_libdir}/pkgconfig/ogg.pc
|
||||
%{_datadir}/aclocal/ogg.m4
|
||||
|
||||
%clean
|
||||
@ -72,6 +72,12 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%changelog
|
||||
* Thu Dec 11 2003 Bill Nottingham <notting@redhat.com> 2:1.1-1
|
||||
- update to 1.1
|
||||
|
||||
* Sun Jun 8 2003 Tim Powers <timp@redhat.com> 2:1.0-5.1
|
||||
- build for RHEL
|
||||
|
||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user