- libogg 1.1.4rc1
- split devel docs to noarch subpackage
This commit is contained in:
parent
2ff87b27a4
commit
3c46770d01
@ -1,3 +1,4 @@
|
|||||||
libogg-1.1.tar.gz
|
libogg-1.1.tar.gz
|
||||||
libogg-1.1.2.tar.gz
|
libogg-1.1.2.tar.gz
|
||||||
libogg-1.1.3.tar.gz
|
libogg-1.1.3.tar.gz
|
||||||
|
libogg-1.1.4rc1.tar.gz
|
||||||
|
@ -1,20 +0,0 @@
|
|||||||
--- libogg-1.1/ogg.m4.orig 2003-03-07 21:44:29.000000000 -0500
|
|
||||||
+++ libogg-1.1/ogg.m4 2003-12-11 15:08:01.000000000 -0500
|
|
||||||
@@ -19,7 +19,7 @@
|
|
||||||
elif test "x$ogg_prefix" != "x" ; then
|
|
||||||
OGG_LIBS="-L$ogg_prefix/lib"
|
|
||||||
elif test "x$prefix" != "xNONE" ; then
|
|
||||||
- OGG_LIBS="-L$prefix/lib"
|
|
||||||
+ OGG_LIBS="-L$libdir"
|
|
||||||
fi
|
|
||||||
|
|
||||||
OGG_LIBS="$OGG_LIBS -logg"
|
|
||||||
@@ -29,7 +29,7 @@
|
|
||||||
elif test "x$ogg_prefix" != "x" ; then
|
|
||||||
OGG_CFLAGS="-I$ogg_prefix/include"
|
|
||||||
elif test "x$prefix" != "xNONE"; then
|
|
||||||
- OGG_CFLAGS="-I$prefix/include"
|
|
||||||
+ OGG_CFLAGS=""
|
|
||||||
fi
|
|
||||||
|
|
||||||
AC_MSG_CHECKING(for Ogg)
|
|
@ -1,39 +0,0 @@
|
|||||||
--- libogg-1.1/src/bitwise.c.orig 2003-12-07 01:48:17.000000000 +0100
|
|
||||||
+++ libogg-1.1/src/bitwise.c 2003-12-07 01:52:58.000000000 +0100
|
|
||||||
@@ -251,7 +251,8 @@ long oggpack_look(oggpack_buffer *b,int
|
|
||||||
/* Read in bits without advancing the bitptr; bits <= 32 */
|
|
||||||
long oggpackB_look(oggpack_buffer *b,int bits){
|
|
||||||
unsigned long ret;
|
|
||||||
- int m=32-bits;
|
|
||||||
+ unsigned long m=mask[bits];
|
|
||||||
+ int s=32-bits;
|
|
||||||
|
|
||||||
bits+=b->endbit;
|
|
||||||
|
|
||||||
@@ -272,7 +273,7 @@ long oggpackB_look(oggpack_buffer *b,int
|
|
||||||
}
|
|
||||||
}
|
|
||||||
}
|
|
||||||
- return (ret>>(m>>1))>>((m+1)>>1);
|
|
||||||
+ return ((ret>>(s>>1))>>((s+1)>>1)&m);
|
|
||||||
}
|
|
||||||
|
|
||||||
long oggpack_look1(oggpack_buffer *b){
|
|
||||||
@@ -347,7 +348,8 @@ long oggpack_read(oggpack_buffer *b,int
|
|
||||||
/* bits <= 32 */
|
|
||||||
long oggpackB_read(oggpack_buffer *b,int bits){
|
|
||||||
unsigned long ret;
|
|
||||||
- long m=32-bits;
|
|
||||||
+ unsigned long m=mask[bits];
|
|
||||||
+ long s=32-bits;
|
|
||||||
|
|
||||||
bits+=b->endbit;
|
|
||||||
|
|
||||||
@@ -369,7 +371,7 @@ long oggpackB_read(oggpack_buffer *b,int
|
|
||||||
}
|
|
||||||
}
|
|
||||||
}
|
|
||||||
- ret=(ret>>(m>>1))>>((m+1)>>1);
|
|
||||||
+ ret=((ret>>(s>>1))>>((s+1)>>1)&m);
|
|
||||||
|
|
||||||
overflow:
|
|
@ -1,11 +0,0 @@
|
|||||||
--- libogg-1.1/ogg.m4.underquoted 2004-07-15 13:13:04.802639840 +0100
|
|
||||||
+++ libogg-1.1/ogg.m4 2004-07-15 13:13:19.319861742 +0100
|
|
||||||
@@ -5,7 +5,7 @@
|
|
||||||
dnl XIPH_PATH_OGG([ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
|
|
||||||
dnl Test for libogg, and define OGG_CFLAGS and OGG_LIBS
|
|
||||||
dnl
|
|
||||||
-AC_DEFUN(XIPH_PATH_OGG,
|
|
||||||
+AC_DEFUN([XIPH_PATH_OGG],
|
|
||||||
[dnl
|
|
||||||
dnl Get the cflags and libraries
|
|
||||||
dnl
|
|
37
libogg.spec
37
libogg.spec
@ -1,13 +1,14 @@
|
|||||||
Summary: The Ogg bitstream file format library
|
Summary: The Ogg bitstream file format library
|
||||||
Name: libogg
|
Name: libogg
|
||||||
Version: 1.1.3
|
Version: 1.1.4
|
||||||
Release: 11%{?dist}
|
# bump to 1%{?dist} for real release, otherwise 0.x.rcX
|
||||||
|
Release: 0.1.rc1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://www.xiph.org/
|
URL: http://www.xiph.org/
|
||||||
Source: http://downloads.xiph.org/releases/ogg/%{name}-%{version}.tar.gz
|
#Source: http://downloads.xiph.org/releases/ogg/%{name}-%{version}.tar.gz
|
||||||
Patch0: libogg-1.0-m4.patch
|
Source: http://downloads.xiph.org/releases/ogg/%{name}-1.1.4rc1.tar.gz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -29,9 +30,17 @@ libogg-devel package contains the header files and documentation
|
|||||||
needed for development using libogg.
|
needed for development using libogg.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel-docs
|
||||||
|
Summary: Documentation for developing Ogg applications
|
||||||
|
Group: Development/Libraries
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel-docs
|
||||||
|
Documentation for developing applications with libogg
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-1.1.4rc1
|
||||||
%patch0 -p1 -b .m4
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -48,10 +57,6 @@ make DESTDIR=$RPM_BUILD_ROOT install
|
|||||||
# remove unpackaged files from the buildroot
|
# remove unpackaged files from the buildroot
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||||
|
|
||||||
# create a cleaned up (Makefile free) copy of doc/libogg for %doc
|
|
||||||
mkdir -p _doc/libogg
|
|
||||||
cp -p doc/libogg/*.html doc/libogg/*.css _doc/libogg
|
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -68,10 +73,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc doc/*.html
|
|
||||||
%doc doc/*.txt
|
|
||||||
%doc doc/*.png
|
|
||||||
%doc _doc/libogg
|
|
||||||
%dir %{_includedir}/ogg
|
%dir %{_includedir}/ogg
|
||||||
%{_includedir}/ogg/ogg.h
|
%{_includedir}/ogg/ogg.h
|
||||||
%{_includedir}/ogg/os_types.h
|
%{_includedir}/ogg/os_types.h
|
||||||
@ -80,8 +81,16 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/pkgconfig/ogg.pc
|
%{_libdir}/pkgconfig/ogg.pc
|
||||||
%{_datadir}/aclocal/ogg.m4
|
%{_datadir}/aclocal/ogg.m4
|
||||||
|
|
||||||
|
%files devel-docs
|
||||||
|
%defattr(-,root,root)
|
||||||
|
# this should use %{name} but the rc name is funky
|
||||||
|
%{_docdir}/libogg-1.1.4rc1/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 03 2009 Adam Jackson <ajax@redhat.com> 1.1.4-0.1.rc1
|
||||||
|
- libogg 1.1.4rc1
|
||||||
|
- split devel docs to noarch subpackage
|
||||||
|
|
||||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.1.3-11
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.1.3-11
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user