Two patches required to avoid Rawhide (f33) build failure

remove_2_backslashes_in_shell_call.patch
remove_eng_inc_in_version_pl.patch

Signed-off-by: Michel Normand <normand@linux.vnet.ibm.com>
This commit is contained in:
Michel Normand 2020-06-25 04:31:10 -04:00
parent 6f928072dd
commit f3371f58a7
3 changed files with 74 additions and 1 deletions

View File

@ -1,11 +1,13 @@
Name: libocxl
Version: 1.1.0
Release: 4%{?dist}
Release: 5%{?dist}
Summary: Allows to implement a user-space driver for an OpenCAPI accelerator
License: ASL 2.0
URL: https://github.com/OpenCAPI/libocxl
Source0: https://github.com/OpenCAPI/libocxl/archive/%{version}.tar.gz
Patch1: remove_2_backslashes_in_shell_call.patch
Patch2: remove_eng_inc_in_version_pl.patch
ExclusiveArch: ppc64le
@ -56,6 +58,11 @@ LDFLAGS="%{build_ldflags}" CFLAGS="%{build_cflags}" make %{?_smp_mflags} V=1
%{_pkgdocdir}
%changelog
* Thu Jun 25 2020 Michel Normand <normand@linux.vnet.ibm.com> 1.1.0-5
- Add remove_2_backslashes_in_shell_call.patch
Add remove_eng_inc_in_version_pl.patch
to avoid f33 build failure
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

View File

@ -0,0 +1,28 @@
From: Michel Normand <normand@linux.vnet.ibm.com>
Subject: remove 2 backslashes in shell call
Date: Fri, 12 Jun 2020 17:26:40 +0200
Remove 2 backslashes in shell call
To avoid make failure.
Seems to start failing in OBS hardware project
between 2020-04-05 and 2020-04-08
Signed-off-by: Michel Normand <normand@linux.vnet.ibm.com>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: libocxl-1.1.0/Makefile
===================================================================
--- libocxl-1.1.0.orig/Makefile
+++ libocxl-1.1.0/Makefile
@@ -18,7 +18,7 @@ HAS_WGET = $(shell /bin/which wget > /de
HAS_CURL = $(shell /bin/which curl > /dev/null 2>&1 && echo y || echo n)
# Update this to test a single feature from the most recent header we require:
-CHECK_OCXL_HEADER_IS_UP_TO_DATE = $(shell /bin/echo -e \\\#include $(1)\\\nvoid test\(struct ocxl_ioctl_features test\)\; | \
+CHECK_OCXL_HEADER_IS_UP_TO_DATE = $(shell /bin/echo -e \#include $(1)\\\nvoid test\(struct ocxl_ioctl_features test\)\; | \
$(CC) $(CFLAGS) -Werror -x c -S -o /dev/null - > /dev/null 2>&1 && echo y || echo n)
check_ocxl_header:

View File

@ -0,0 +1,38 @@
From: Michel Normand <normand@linux.vnet.ibm.com>
Subject: remove perl english include in version.pl
Date: Thu, 25 Jun 2020 04:04:19 -0400
Remove perl english include in version.pl
because not present anymore by default for Rawhide (f33) build env
and not mandatory to create the libocxl_info.h
Signed-off-by: Michel Normand <normand@linux.vnet.ibm.com>
---
Makefile | 1 +
version.pl | 1 -
2 files changed, 1 insertion(+), 1 deletion(-)
Index: libocxl-1.1.0/version.pl
===================================================================
--- libocxl-1.1.0.orig/version.pl
+++ libocxl-1.1.0/version.pl
@@ -1,6 +1,5 @@
#!/usr/bin/env perl
-use English;
use strict;
use warnings;
Index: libocxl-1.1.0/Makefile
===================================================================
--- libocxl-1.1.0.orig/Makefile
+++ libocxl-1.1.0/Makefile
@@ -37,6 +37,7 @@ src/libocxl_info.h: version.pl
VERSION_MAJOR=${VERSION_MAJOR} VERSION_MINOR=${VERSION_MINOR} \
VERSION_PATCH=${VERSION_PATCH} CC="${CC}" CFLAGS="${CFLAGS}" \
./version.pl > src/libocxl_info.h
+ cat src/libocxl_info.h
obj:
mkdir obj