- updated to 1.2.1
This commit is contained in:
parent
0d2f8470a0
commit
4b33942e15
5
.gitignore
vendored
5
.gitignore
vendored
@ -1,3 +1,2 @@
|
||||
/1.0.0-beta2.tar.gz
|
||||
/libocxl-1.0.0.tar.gz
|
||||
/1.1.0.tar.gz
|
||||
/1.*.tar.gz
|
||||
/libocxl-*.tar.gz
|
||||
|
22
libocxl.spec
22
libocxl.spec
@ -1,19 +1,20 @@
|
||||
Name: libocxl
|
||||
Version: 1.1.0
|
||||
Release: 8%{?dist}
|
||||
Version: 1.2.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Allows to implement a user-space driver for an OpenCAPI accelerator
|
||||
|
||||
License: ASL 2.0
|
||||
URL: https://github.com/OpenCAPI/libocxl
|
||||
Source0: https://github.com/OpenCAPI/libocxl/archive/%{version}.tar.gz
|
||||
Patch1: remove_2_backslashes_in_shell_call.patch
|
||||
Patch2: remove_eng_inc_in_version_pl.patch
|
||||
Source0: https://github.com/OpenCAPI/libocxl/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
ExclusiveArch: ppc64le
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: make
|
||||
BuildRequires: make
|
||||
BuildRequires: perl(English)
|
||||
# for tests
|
||||
BuildRequires: fuse-devel
|
||||
|
||||
%description
|
||||
Access library which allows to implement a user-space
|
||||
@ -36,6 +37,7 @@ developing applications that use %{name}.
|
||||
The *-docs package contains doxygen pages for
|
||||
developing applications that use %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
@ -46,6 +48,10 @@ developing applications that use %{name}.
|
||||
%install
|
||||
%make_install PREFIX=%{_prefix}
|
||||
|
||||
%check
|
||||
make testobj/unittests V=1
|
||||
|
||||
|
||||
%files
|
||||
%license COPYING
|
||||
%doc README.md
|
||||
@ -59,7 +65,11 @@ developing applications that use %{name}.
|
||||
%files docs
|
||||
%{_pkgdocdir}
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jun 16 2021 Dan Horák <dan[at]danny.cz> - 1.2.1-1
|
||||
- updated to 1.2.1
|
||||
|
||||
* Tue May 11 2021 Timm Bäder <tbaeder@redhat.com> - 1.1.0-8
|
||||
- Use %%make_build macro
|
||||
|
||||
|
@ -1,28 +0,0 @@
|
||||
From: Michel Normand <normand@linux.vnet.ibm.com>
|
||||
Subject: remove 2 backslashes in shell call
|
||||
Date: Fri, 12 Jun 2020 17:26:40 +0200
|
||||
|
||||
Remove 2 backslashes in shell call
|
||||
|
||||
To avoid make failure.
|
||||
Seems to start failing in OBS hardware project
|
||||
between 2020-04-05 and 2020-04-08
|
||||
|
||||
Signed-off-by: Michel Normand <normand@linux.vnet.ibm.com>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
Index: libocxl-1.1.0/Makefile
|
||||
===================================================================
|
||||
--- libocxl-1.1.0.orig/Makefile
|
||||
+++ libocxl-1.1.0/Makefile
|
||||
@@ -18,7 +18,7 @@ HAS_WGET = $(shell /bin/which wget > /de
|
||||
HAS_CURL = $(shell /bin/which curl > /dev/null 2>&1 && echo y || echo n)
|
||||
|
||||
# Update this to test a single feature from the most recent header we require:
|
||||
-CHECK_OCXL_HEADER_IS_UP_TO_DATE = $(shell /bin/echo -e \\\#include $(1)\\\nvoid test\(struct ocxl_ioctl_features test\)\; | \
|
||||
+CHECK_OCXL_HEADER_IS_UP_TO_DATE = $(shell /bin/echo -e \#include $(1)\\\nvoid test\(struct ocxl_ioctl_features test\)\; | \
|
||||
$(CC) $(CFLAGS) -Werror -x c -S -o /dev/null - > /dev/null 2>&1 && echo y || echo n)
|
||||
|
||||
check_ocxl_header:
|
@ -1,38 +0,0 @@
|
||||
From: Michel Normand <normand@linux.vnet.ibm.com>
|
||||
Subject: remove perl english include in version.pl
|
||||
Date: Thu, 25 Jun 2020 04:04:19 -0400
|
||||
|
||||
Remove perl english include in version.pl
|
||||
|
||||
because not present anymore by default for Rawhide (f33) build env
|
||||
and not mandatory to create the libocxl_info.h
|
||||
|
||||
Signed-off-by: Michel Normand <normand@linux.vnet.ibm.com>
|
||||
---
|
||||
Makefile | 1 +
|
||||
version.pl | 1 -
|
||||
2 files changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
Index: libocxl-1.1.0/version.pl
|
||||
===================================================================
|
||||
--- libocxl-1.1.0.orig/version.pl
|
||||
+++ libocxl-1.1.0/version.pl
|
||||
@@ -1,6 +1,5 @@
|
||||
#!/usr/bin/env perl
|
||||
|
||||
-use English;
|
||||
use strict;
|
||||
use warnings;
|
||||
|
||||
Index: libocxl-1.1.0/Makefile
|
||||
===================================================================
|
||||
--- libocxl-1.1.0.orig/Makefile
|
||||
+++ libocxl-1.1.0/Makefile
|
||||
@@ -37,6 +37,7 @@ src/libocxl_info.h: version.pl
|
||||
VERSION_MAJOR=${VERSION_MAJOR} VERSION_MINOR=${VERSION_MINOR} \
|
||||
VERSION_PATCH=${VERSION_PATCH} CC="${CC}" CFLAGS="${CFLAGS}" \
|
||||
./version.pl > src/libocxl_info.h
|
||||
+ cat src/libocxl_info.h
|
||||
|
||||
obj:
|
||||
mkdir obj
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (1.1.0.tar.gz) = 0306403290819f909f844a367873eeb5fc7e2996815bddb2eaf1b727b0d9ab801b6716c70d3229bb7dbf62f5df24d09b7451bdf1d831e6a5bfbc1cc1de834d9e
|
||||
SHA512 (libocxl-1.2.1.tar.gz) = 07f1fa173b8a866b076b13b8b0fde4d9a72444e9a2694d71f5866144f163a2ba01a2b07aefa6b960a07950e6768e4c1c747cceeb47e6a27a5dcfa48b9c156f56
|
||||
|
Loading…
Reference in New Issue
Block a user