From 92e5664e863b8a84e4cf5673e75fbd0c0fc0a8f5 Mon Sep 17 00:00:00 2001
From: Tulio Magno Quites Machado Filho <tuliom@linux.ibm.com>
Date: Tue, 27 Oct 2020 22:02:12 -0300
Subject: [PATCH] Install libnxz.so as symlink

The symlink libnxz.so is important when developing programs that link
specifically to libnxz, i.e. via -lnxz.

Signed-off-by: Tulio Magno Quites Machado Filho <tuliom@linux.ibm.com>
---
 lib/Makefile | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/lib/Makefile b/lib/Makefile
index 3cb3a7c..5813c79 100644
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -36,7 +36,9 @@ clean:
 install: $(STATICLIB) $(SHAREDLIB)
 	install -d $(LIBDIR)
 	install -m 755 $(SHAREDLIB) $(LIBDIR)
-	install -m 755 $(SHAREDSONAMELIB) $(LIBDIR)
+	{ cd $(LIBDIR); \
+	  ln -s $(SHAREDLIB) $(SHAREDSONAMELIB); \
+	  ln -s $(SHAREDLIB) $(LIBLINK); }
 	install -m 644 $(STATICLIB) $(LIBDIR)
 
 uninstall:
-- 
2.25.4