Update sources and rm-git.patch, remove libnxz.so.patch
Commit 87fd9d1ade
missed these files.
libnxz.so.patch is already applied to 0.62.
This commit is contained in:
parent
87fd9d1ade
commit
6e238eec67
@ -1,31 +0,0 @@
|
|||||||
From 92e5664e863b8a84e4cf5673e75fbd0c0fc0a8f5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tulio Magno Quites Machado Filho <tuliom@linux.ibm.com>
|
|
||||||
Date: Tue, 27 Oct 2020 22:02:12 -0300
|
|
||||||
Subject: [PATCH] Install libnxz.so as symlink
|
|
||||||
|
|
||||||
The symlink libnxz.so is important when developing programs that link
|
|
||||||
specifically to libnxz, i.e. via -lnxz.
|
|
||||||
|
|
||||||
Signed-off-by: Tulio Magno Quites Machado Filho <tuliom@linux.ibm.com>
|
|
||||||
---
|
|
||||||
lib/Makefile | 4 +++-
|
|
||||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/lib/Makefile b/lib/Makefile
|
|
||||||
index 3cb3a7c..5813c79 100644
|
|
||||||
--- a/lib/Makefile
|
|
||||||
+++ b/lib/Makefile
|
|
||||||
@@ -36,7 +36,9 @@ clean:
|
|
||||||
install: $(STATICLIB) $(SHAREDLIB)
|
|
||||||
install -d $(LIBDIR)
|
|
||||||
install -m 755 $(SHAREDLIB) $(LIBDIR)
|
|
||||||
- install -m 755 $(SHAREDSONAMELIB) $(LIBDIR)
|
|
||||||
+ { cd $(LIBDIR); \
|
|
||||||
+ ln -s $(SHAREDLIB) $(SHAREDSONAMELIB); \
|
|
||||||
+ ln -s $(SHAREDLIB) $(LIBLINK); }
|
|
||||||
install -m 644 $(STATICLIB) $(LIBDIR)
|
|
||||||
|
|
||||||
uninstall:
|
|
||||||
--
|
|
||||||
2.25.4
|
|
||||||
|
|
@ -19,7 +19,7 @@ index cc996dc..3cb3a7c 100644
|
|||||||
nx_adler32.o gzip_vas.o nx_compress.o nx_uncompr.o crc32_ppc.o crc32_ppc_asm.o nx_utils.o
|
nx_adler32.o gzip_vas.o nx_compress.o nx_uncompr.o crc32_ppc.o crc32_ppc_asm.o nx_utils.o
|
||||||
|
|
||||||
-VERSION ?= $(shell git describe --tags | cut -d - -f 1,2 | tr - . | cut -c 2-)
|
-VERSION ?= $(shell git describe --tags | cut -d - -f 1,2 | tr - . | cut -c 2-)
|
||||||
+VERSION ?= 0.61
|
+VERSION ?= 0.62
|
||||||
SOVERSION = $(shell echo $(VERSION) | cut -d . -f 1)
|
SOVERSION = $(shell echo $(VERSION) | cut -d . -f 1)
|
||||||
PACKAGENAME = libnxz
|
PACKAGENAME = libnxz
|
||||||
STATICLIB = $(PACKAGENAME).a
|
STATICLIB = $(PACKAGENAME).a
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libnxz-0.61.tar.gz) = bf3390c6a82b715dbf66d597169c54c2c973cebd373bec569234f0874fc9655a43b60044438ffeb3ff1137558a7cb5298eb38c26b3fabcf050675579af1572be
|
SHA512 (libnxz-0.62.tar.gz) = 773760838eb87b6be475226b3aada5fcd84d9d7a1248f4ec00c59f87eef0185afd95d0c449821dd24f32d637376742c33ab411f936f95eed8a713d1cdd35fe6a
|
||||||
|
Loading…
Reference in New Issue
Block a user