* Mon Apr 03 2023 Tomas Bzatek <tbzatek@redhat.com> - 1.4-1
- Upstream v1.4 release
This commit is contained in:
parent
351c1becda
commit
fb706687df
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@
|
|||||||
/libnvme-1.1.tar.gz
|
/libnvme-1.1.tar.gz
|
||||||
/libnvme-1.2.tar.gz
|
/libnvme-1.2.tar.gz
|
||||||
/libnvme-1.3.tar.gz
|
/libnvme-1.3.tar.gz
|
||||||
|
/libnvme-1.4.tar.gz
|
||||||
|
@ -1,38 +0,0 @@
|
|||||||
From ddfb3ba036f9df2737c165b27f9b458dd83a7df8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tomas Bzatek <tbzatek@redhat.com>
|
|
||||||
Date: Tue, 31 Jan 2023 23:27:53 +0100
|
|
||||||
Subject: [PATCH 2/2] build: Fix nss code snippet includes
|
|
||||||
|
|
||||||
With hardened distribution CFLAGS the meson code snippet wouldn't compile:
|
|
||||||
|
|
||||||
Compiler stderr:
|
|
||||||
.build/meson-private/tmpy2z1t5q4/testfile.c: In function 'main':
|
|
||||||
.build/meson-private/tmpy2z1t5q4/testfile.c:2:30: error: storage size of 'hints' isn't known
|
|
||||||
2 | struct addrinfo hints, *result;
|
|
||||||
| ^~~~~
|
|
||||||
.build/meson-private/tmpy2z1t5q4/testfile.c:3:21: warning: implicit declaration of function 'getaddrinfo' [-Wimplicit-function-declaration]
|
|
||||||
3 | return getaddrinfo(argv[1], argv[2], &hints, &result);
|
|
||||||
| ^~~~~~~~~~~
|
|
||||||
---
|
|
||||||
meson.build | 5 ++++-
|
|
||||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/meson.build b/meson.build
|
|
||||||
index d389cbf..cf72d6d 100644
|
|
||||||
--- a/meson.build
|
|
||||||
+++ b/meson.build
|
|
||||||
@@ -199,7 +199,10 @@ conf.set10(
|
|
||||||
conf.set(
|
|
||||||
'HAVE_LIBNSS',
|
|
||||||
cc.links(
|
|
||||||
- '''int main(int argc, char **argv) {
|
|
||||||
+ '''#include <sys/types.h>
|
|
||||||
+ #include <sys/socket.h>
|
|
||||||
+ #include <netdb.h>
|
|
||||||
+ int main(int argc, char **argv) {
|
|
||||||
struct addrinfo hints, *result;
|
|
||||||
return getaddrinfo(argv[1], argv[2], &hints, &result);
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.39.0
|
|
||||||
|
|
14
libnvme.spec
14
libnvme.spec
@ -3,14 +3,12 @@
|
|||||||
|
|
||||||
Name: libnvme
|
Name: libnvme
|
||||||
Summary: Linux-native nvme device management library
|
Summary: Linux-native nvme device management library
|
||||||
Version: 1.3
|
Version: 1.4
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/linux-nvme/libnvme
|
URL: https://github.com/linux-nvme/libnvme
|
||||||
Source0: %{url}/archive/v%{version_no_tilde}/%{name}-%{version_no_tilde}.tar.gz
|
Source0: %{url}/archive/v%{version_no_tilde}/%{name}-%{version_no_tilde}.tar.gz
|
||||||
|
|
||||||
Patch0: libnvme-1.3-meson_nss_includes.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc gcc-c++
|
BuildRequires: gcc gcc-c++
|
||||||
BuildRequires: swig
|
BuildRequires: swig
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
@ -19,6 +17,7 @@ BuildRequires: meson >= 0.50
|
|||||||
BuildRequires: json-c-devel >= 0.13
|
BuildRequires: json-c-devel >= 0.13
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: dbus-devel
|
BuildRequires: dbus-devel
|
||||||
|
BuildRequires: keyutils-libs-devel
|
||||||
%if (0%{?rhel} == 0)
|
%if (0%{?rhel} == 0)
|
||||||
BuildRequires: kernel-headers >= 5.15
|
BuildRequires: kernel-headers >= 5.15
|
||||||
%endif
|
%endif
|
||||||
@ -60,7 +59,7 @@ This package contains Python bindings for libnvme.
|
|||||||
%autosetup -p1 -n %{name}-%{version_no_tilde}
|
%autosetup -p1 -n %{name}-%{version_no_tilde}
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%meson -Dpython=true -Ddocs=all -Ddocs-build=true -Dhtmldir=%{_pkgdocdir}
|
%meson -Dpython=enabled -Ddocs=all -Ddocs-build=true -Dhtmldir=%{_pkgdocdir}
|
||||||
%meson_build
|
%meson_build
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -76,9 +75,9 @@ mv %{buildroot}/usr/*.rst %{buildroot}%{_pkgdocdir}/
|
|||||||
%files
|
%files
|
||||||
%license COPYING ccan/licenses/*
|
%license COPYING ccan/licenses/*
|
||||||
%{_libdir}/libnvme.so.1
|
%{_libdir}/libnvme.so.1
|
||||||
%{_libdir}/libnvme.so.1.3.0
|
%{_libdir}/libnvme.so.1.4.0
|
||||||
%{_libdir}/libnvme-mi.so.1
|
%{_libdir}/libnvme-mi.so.1
|
||||||
%{_libdir}/libnvme-mi.so.1.3.0
|
%{_libdir}/libnvme-mi.so.1.4.0
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_libdir}/libnvme.so
|
%{_libdir}/libnvme.so
|
||||||
@ -98,6 +97,9 @@ mv %{buildroot}/usr/*.rst %{buildroot}%{_pkgdocdir}/
|
|||||||
%{python3_sitearch}/libnvme/*
|
%{python3_sitearch}/libnvme/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 03 2023 Tomas Bzatek <tbzatek@redhat.com> - 1.4-1
|
||||||
|
- Upstream v1.4 release
|
||||||
|
|
||||||
* Tue Jan 31 2023 Tomas Bzatek <tbzatek@redhat.com> - 1.3-1
|
* Tue Jan 31 2023 Tomas Bzatek <tbzatek@redhat.com> - 1.3-1
|
||||||
- Upstream v1.3 release
|
- Upstream v1.3 release
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libnvme-1.3.tar.gz) = c874b29b73e55be842f71e74a226a76fcd50dfa72e2be100f0437bc83e740cd146b6d2f2cdaa940c11c3d8c48ff2c065ac0e8a83d4d0dde743edf4179f328670
|
SHA512 (libnvme-1.4.tar.gz) = cc4a0a78083471e912736d76e4faaa5c285e1149029560f212ff06254863e8f21b48fcb1638599bd68efcf888312a248fb748d23776af03574b39fbd9b2a418d
|
||||||
|
Loading…
Reference in New Issue
Block a user