libnvme: Update to version 1.4
Resolves: #2166329 Signed-off-by: Maurizio Lombardi <mlombard@redhat.com>
This commit is contained in:
parent
d99d70d226
commit
c14cefd10c
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
/libnvme-1.0.tar.gz
|
/libnvme-1.0.tar.gz
|
||||||
/libnvme-1.1.tar.gz
|
/libnvme-1.1.tar.gz
|
||||||
/libnvme-1.2.tar.gz
|
/libnvme-1.2.tar.gz
|
||||||
|
/libnvme-1.4.tar.gz
|
||||||
|
@ -1,33 +0,0 @@
|
|||||||
From 78ce3528d00bb433c661fd24672a1b5c6795b59f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Martin Belanger <martin.belanger@dell.com>
|
|
||||||
Date: Fri, 18 Nov 2022 10:41:32 -0500
|
|
||||||
Subject: [PATCH] fabrics: Fix bad UUID size introduced in recent UUID changes
|
|
||||||
Content-type: text/plain
|
|
||||||
|
|
||||||
71c25d1cf741 ("util: Add simple UUID type") introduced a regression in
|
|
||||||
nvmf_get_tel(). nvmf_get_tel() returns the lenght of the binary
|
|
||||||
representation. Hence use NVME_UUID_LEN instead.
|
|
||||||
|
|
||||||
Signed-off-by: Martin Belanger <martin.belanger@dell.com>
|
|
||||||
[dwagner: massaged commit message]
|
|
||||||
Signed-off-by: Daniel Wagner <dwagner@suse.de>
|
|
||||||
---
|
|
||||||
src/nvme/fabrics.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/nvme/fabrics.c b/src/nvme/fabrics.c
|
|
||||||
index f943090..36bdc2d 100644
|
|
||||||
--- a/src/nvme/fabrics.c
|
|
||||||
+++ b/src/nvme/fabrics.c
|
|
||||||
@@ -1127,7 +1127,7 @@ static __u32 nvmf_get_tel(const char *hostsymname)
|
|
||||||
__u16 len;
|
|
||||||
|
|
||||||
/* Host ID is mandatory */
|
|
||||||
- tel += nvmf_exat_size(NVME_UUID_LEN_STRING);
|
|
||||||
+ tel += nvmf_exat_size(NVME_UUID_LEN);
|
|
||||||
|
|
||||||
/* Symbolic name is optional */
|
|
||||||
len = hostsymname ? strlen(hostsymname) : 0;
|
|
||||||
--
|
|
||||||
2.31.1
|
|
||||||
|
|
22
libnvme.spec
22
libnvme.spec
@ -3,20 +3,22 @@
|
|||||||
|
|
||||||
Name: libnvme
|
Name: libnvme
|
||||||
Summary: Linux-native nvme device management library
|
Summary: Linux-native nvme device management library
|
||||||
Version: 1.2
|
Version: 1.4
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/linux-nvme/libnvme
|
URL: https://github.com/linux-nvme/libnvme
|
||||||
Source0: %{url}/archive/v%{version_no_tilde}/%{name}-%{version_no_tilde}.tar.gz
|
Source0: %{url}/archive/v%{version_no_tilde}/%{name}-%{version_no_tilde}.tar.gz
|
||||||
|
|
||||||
Patch0: 0001-fabrics-Fix-bad-UUID-size-introduced-in-recent-UUID-.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc gcc-c++
|
BuildRequires: gcc gcc-c++
|
||||||
BuildRequires: swig
|
BuildRequires: swig
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
BuildRequires: meson >= 0.48.0
|
BuildRequires: meson >= 0.50.0
|
||||||
BuildRequires: json-c-devel >= 0.13
|
BuildRequires: json-c-devel >= 0.13
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
|
BuildRequires: keyutils-libs-devel
|
||||||
|
BuildRequires: dbus-devel
|
||||||
|
|
||||||
|
Requires: keyutils-libs
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Provides type definitions for NVMe specification structures,
|
Provides type definitions for NVMe specification structures,
|
||||||
@ -45,7 +47,6 @@ This package contains the reference manual for %{name}.
|
|||||||
Summary: Python3 bindings for libnvme
|
Summary: Python3 bindings for libnvme
|
||||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
Provides: python3-nvme = %{version}-%{release}
|
Provides: python3-nvme = %{version}-%{release}
|
||||||
Obsoletes: python3-nvme < 1.0~rc7
|
|
||||||
%{?python_provide:%python_provide python3-libnvme}
|
%{?python_provide:%python_provide python3-libnvme}
|
||||||
|
|
||||||
%description -n python3-libnvme
|
%description -n python3-libnvme
|
||||||
@ -55,7 +56,7 @@ This package contains Python bindings for libnvme.
|
|||||||
%autosetup -p1 -n %{name}-%{version_no_tilde}
|
%autosetup -p1 -n %{name}-%{version_no_tilde}
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%meson -Dpython=true -Ddocs=all -Ddocs-build=true -Dhtmldir=%{_pkgdocdir}
|
%meson -Dpython=enabled -Ddocs=all -Ddocs-build=true -Dhtmldir=%{_pkgdocdir}
|
||||||
%meson_build
|
%meson_build
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -71,9 +72,9 @@ mv %{buildroot}/usr/*.rst %{buildroot}%{_pkgdocdir}/
|
|||||||
%files
|
%files
|
||||||
%license COPYING ccan/licenses/*
|
%license COPYING ccan/licenses/*
|
||||||
%{_libdir}/libnvme.so.1
|
%{_libdir}/libnvme.so.1
|
||||||
%{_libdir}/libnvme.so.1.2.0
|
%{_libdir}/libnvme.so.1.4.0
|
||||||
%{_libdir}/libnvme-mi.so.1
|
%{_libdir}/libnvme-mi.so.1
|
||||||
%{_libdir}/libnvme-mi.so.1.2.0
|
%{_libdir}/libnvme-mi.so.1.4.0
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_libdir}/libnvme.so
|
%{_libdir}/libnvme.so
|
||||||
@ -93,6 +94,9 @@ mv %{buildroot}/usr/*.rst %{buildroot}%{_pkgdocdir}/
|
|||||||
%{python3_sitearch}/libnvme/*
|
%{python3_sitearch}/libnvme/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 03 2023 Maurizio Lombardi <mlombard@redhat.com> - 1.4-1
|
||||||
|
- Update to version 1.4
|
||||||
|
|
||||||
* Thu Jan 12 2023 John Meneghini <jmeneghi@redhat.com> - 1.2-2
|
* Thu Jan 12 2023 John Meneghini <jmeneghi@redhat.com> - 1.2-2
|
||||||
- Fix BZ2158264
|
- Fix BZ2158264
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (libnvme-1.2.tar.gz) = f50517838cd1df3cdd123afdb67870633e9e484bf84dba70b784d7e86ecb355b96ba9d6a1cffb96b35444da7870dfe21c54b69701b5fe5b515319280db4a84e4
|
SHA512 (libnvme-1.4.tar.gz) = cc4a0a78083471e912736d76e4faaa5c285e1149029560f212ff06254863e8f21b48fcb1638599bd68efcf888312a248fb748d23776af03574b39fbd9b2a418d
|
||||||
|
Loading…
Reference in New Issue
Block a user